none
Ajout d'un broker sur une ferme RDS

    Question

  • Bonjour à tous,

    Nous avons actuellement un serveur RDS standalone qui est configuré avec les rôles suivants :

    - Accès Web des services Bureau à distance

    - Service Broker pour les connexions Bureau à distance

    - Hôte de session Bureau à distance

    C'est le contrôleur du domaine qui possède le rôle "Gestionnaire de licences des services Bureau à distance".

    Aucun problème actuellement. L’objectif est d'ajouter un second serveur RDS et de bénéficier de la répartition de charge.

    Je souhaite donc que le serveur AD soit le serveur Broker et redirige les connexions utilisateurs vers l'un des deux hôtes RDS.


    Voici les actions réalisées :

    - Installation de SQL Express sur l'AD, installation du pilote ODBC, ajout des droits adéquats etc...

    - Installation du rôle Broker sur l'AD puis ajout de celui-ci dans la ferme actuel

    - Suppression du rôle Broker sur le serveur RDS1

    - Ajout du second hôte (RDS2) dans la ferme actuelle

    Avec ces opérations, j'ai uniquement deux RDSH et un seul serveur Broker qui est l'AD.

    Dans les propriétés de déploiement (Haute disponibilité), j'ai configuré l'entrée "broker.rds", et ce nom pointe uniquement sur le serveur AD.

    Cependant, impossible de me connecter à la ferme, j'ai à chaque fois les mêmes erreurs sur mon Broker :

    Échec du service Broker pour les connexions Bureau à distance lors du traitement de la demande de connexion pour l’utilisateur DOMAIN\test02.
    Erreur : Élément introuvable.

    Échec du client du service Broker pour les connexions Bureau à distance lors de l’obtention du paquet de redirection auprès du service Broker pour les connexions.
    Utilisateur : DOMAIN\test02
    Erreur : Élément introuvable.

    Échec du client du service Broker pour les connexions Bureau à distance lors de l’obtention du paquet de redirection auprès du service Broker pour les connexions.
    Utilisateur : DOMAIN\test02
    Erreur : Élément introuvable.

    Je passe pourtant par le raccourci présent sur l'interface Web d'un des deux RDS, j'utilise donc bien l'option "loadbalance" pour me connecter à la collection.

    Chose étrange, lorsque je me connecte en administrateur sur les deux RDS, l'utilisateur "administrateur" n'apparait pas dans le tableau "Connexions".


    J'ai essayé d'installer le service Broker sur les deux hôtes RDS (en plus de celui sur l'AD). Je vois bien les connexions quand je me connecte en administrateur sur les deux serveurs. J'arrive aussi à accéder à l'un des deux serveurs via un compte, mais je suis toujours redirigé sur le même hôte.

    Je ne comprend vraiment pas, j'ai essayé de modifier les GPO "Composants Windows/Services Bureau à distance/Hôte de la session Bureau à distance/Service Broker pour les connexions Bureau à distance", rien n'y fait.

    J'ai vérifié les accès du Broker vers la base de données, pas de problème à priori.

    D'après vous, quelle pourrais être la cause du problème ?

    Merci d'avance !

    vendredi 29 décembre 2017 16:01

Réponses