none
UAC bloque le lancement de ma mmc ! RRS feed

  • Question

  • Bonjour !

    J'aimerai votre aide concernant un problème que je n'arrive pas a résoudre ou contourner.
    J'ai récemment installé Windows 10 Enterprise sur mon pc, et dans le cadre de mon travail, je dispose d'une console mmc avec différents composant comme l'AD,DNS, etc... Pré-enregistrés.
    Cette console je la lance en mode "admin du domaine" avec le compte adapté via un batch très simple que j'avais créé : runas /savecred /user:contoso\domainAdminAcc"mmc.exe D:\MMC\console1.msc" je n'avais jamais eu de problème sous Windows 7, mais sous Windows 10 rien ne se lance lorsque j'exécute mon batch et ma console ne s'ouvre pas. En cherchant un peu, j'ai vu qu'il s'agit d'un problème de droit avec le message suivant : "740 : l'opération demandée nécessite une élévation"  l'UAC est au plus bas sur mon pc pourtant. Il semble qu'il ne veut pas ouvrir "mmc.exe" situé dans system32. quoi que je fasse. Pourtant lorsque je double clique dessus directement la console s'ouvre bien. (mais vide évidemment) Pouvez vous m'aider ! Merci.

    Julien.

    mardi 15 décembre 2015 08:58

Réponses

  • A priori le problème est là depuis la version 1511 de Windows 10.

    Pouvez-vous tenter d'executer votre console en passant par un deuxième CMD ? (exemple pour le composant compmgmt.msc) :

    runas /user:Administrateur /savecred "cmd /c \"start compmgmt.msc\""


    Ludovic CHOLLET | Microsoft System Administrator

    • Marqué comme réponse DarkMoutch mercredi 16 décembre 2015 10:57
    mercredi 16 décembre 2015 09:35

Toutes les réponses

  • Bonjour,

    Avez vous tenté d'ouvrir "CMD" en tant qu'administrateur (Clique droit > Executer en tant qu'administrateur) puis de lancer votre runas depuis cette invite de commande ?

    Cdt,


    Ludovic CHOLLET | Microsoft System Administrator

    mardi 15 décembre 2015 09:17
  • Bonjour Ludovic,

    Oui j'ai essayé de cette manière mais même erreur.
    J'ai vraiment l'impression que c'est le fait d'appeler "mmc.exe" depuis mon batch qui ne passe pas.
    peut être qu'en complétant mon batch, il est possible de forcer l'ouverture de la console, mais je ne connais pas la syntaxe...
    Je ne peux même pas jouer avec la sécurité de l'exécutable du fichier mmc.exe, tout est grisé. (et je ne vais pas casser l'héritage des droits a ce niveau du système) :-D

    J'ai bien trouvé une solution de contournement pas très propre, j'ai désactivé dans les stratégies de sécurité local l'UAC à proprement parlé, et ça marchait, mais lorsque je voulais utiliser Edge il ne s'ouvrait plus avec l'erreur: "ne peut pas s'ouvrir avec le compte administrateur" (bizarre), et Windows m'avertissait en permanence que le service "Centre de sécurité" était arrêté. donc j'ai remis les options par défaut et me retrouve au point de départ.
     da
    Edit : j'ai pu quand même modifier qui est propriétaire de "mmc.exe" dans les paramètres de sécurité avancé... mais pas concluant.

    Julien.


    • Modifié DarkMoutch mardi 15 décembre 2015 09:56
    mardi 15 décembre 2015 09:33
  • Je pense que votre problèmatique est détaillée ici (effectivement le comportement de l'UAC évolue avec W10):

    http://superuser.com/questions/978686/how-to-run-windows-10-settings-app-as-administrator

    Cdt,


    Ludovic CHOLLET | Microsoft System Administrator

    mardi 15 décembre 2015 10:00
  • Merci.
    Non ça ne fonctionne pas en suivant ce tuto. :-(
    Et je n'ai pas bien compris quel était le but exact de ce tuto pour être franc.

    Je suis habituellement logué avec un compte user AD standard (qui est admin local je précise).
    Je souhaite ouvrir ma console avec tout mes composants (outils d'administration de serveurs distants) directement avec mon compte admin du domaine.
    Pour cela j'utilise un Batch qui me permet d'éviter simplement de faire un runas à chaque fois que je veux ouvrir ma console. Mais ça ne fonctionne pas avec le message d'erreur cité au dessus.

    Donc depuis mon compte standard, lorsque je double clic simplement sur "console1.msc", la mmc s'ouvre avec mes composants, mais avec mon compte de domaine standard, donc pas accès au contrôleurs de domaine, et lorsque je clique directement sur mmc.exe ca s'ouvre aussi mais vide, logique.
    En d'autre terme, j'ai bien accès à la mmc en général, seulement c'est avec mon batch que ça ne veut pas s'ouvrir et qui nécessite soi-disant une élévation.
    Merci d'avance !


    Julien.


    • Modifié DarkMoutch mardi 15 décembre 2015 11:11
    mardi 15 décembre 2015 11:11
  • Etrange,

    Confirmons d'abord que le problème ne vient pas de l'UAC (même si je vois qu'il a l'air désactivé chez vous).

    Pouvez-vous lancer la commande suivante (désactive l'UAC), redémarrer le poste et refaire un test ?

    C:\Windows\System32\cmd.exe /k %windir%\System32\reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f
    Si vous faites un runas avec votre compte administrateur de domaine (graphiquement, donc, sans passer par le batch : clic-droit exécuter en tant que), la console s'ouvre t'elle avec vos préférences ?


    Ludovic CHOLLET | Microsoft System Administrator


    • Modifié Ludovic CH mardi 15 décembre 2015 14:13
    mardi 15 décembre 2015 14:12
  • Ca marche de cette manière.
    et avec le Batch aussi du coup.
    Mais Edge refuse de s'ouvrir maintenant.
    La valeur DWORD modifié à le même effet que de désactiver l' UAC via les stratégies de sécurité locales.
    (Strategie Locales->Options de sécurité->Contrôle de compte d'utilisateur : exécuter les comptes d'administrateurs en mode d'approbation d'administrateur)
    Bien que, Edge n'est pas une application que j'utiliserai tout les jours je peux largement m'en passer aussi. Mais je n'aimerai pas que le problème se reproduisent ailleurs que sur Edge.

    Julien.

    mardi 15 décembre 2015 14:51
  • Ok, oui en effet. Il n'est pas recommandé de désactiver l'UAC ou même de l'autoriser par défaut pour des taches automatisées. Je vous recommande de le réactiver.

    Avez vous contrôlé les paramètres de compatibilité de votre fichier BATCH ?

    Clic droit sur votre script > Onglet Compatibilité > La case "Exécuter ce programme en tant qu'administrateur" est bien cochée.


    Ludovic CHOLLET | Microsoft System Administrator


    • Modifié Ludovic CH mardi 15 décembre 2015 15:38
    mardi 15 décembre 2015 15:38
  • hmm...
    Pas d'onglet compatibilité disponible lorsque je clic droit propriété dessus.

    Julien.

    mardi 15 décembre 2015 15:59
  • Essaye ceci, crée un raccourci vers ton batch. Ensuite dans les propriétés du raccourci coche l'option pour qu'il soit executé toujours en administrateur.

    Execute au moins une fois la commande dans une fenetre CMD ouverte pour voir ce qui se passe avec et sans le parametre /savecred


    signatureforums

    mardi 15 décembre 2015 16:32
    Modérateur
  • Le comportement démontre bien un problème d'élévation... Je l'ai validé sur mon environnement également W10. Très étrange problème qu'est le votre !

    Avez vous bien lancer votre BATCH avec l'option disponible dans le menu contextuelle clic droit "Exécuter en tant qu'administrateur" (et pas "Exécuter en tant qu'autre utilisateur").


    Ludovic CHOLLET | Microsoft System Administrator

    mercredi 16 décembre 2015 08:22
  • Bonjour Yannick,

    J'utilise un raccourci sur le bureau éxécuté en tant qu'administrateur et j'ai déjà tenté cette opération mais rien n'y fait.
    SavCred ou non le problème est le même toujours cette élévation demandée.

    Merci d'avance.

    Julien.

    mercredi 16 décembre 2015 08:57
  • Bonjour Ludovic,

    Et quand vous dites que vous l'avez validé, vous rencontrez le même problème que moi sans pouvoir le résoudre ou vous avez pu vous en dépêtrer ?!

    Oui j'ai essayé de lancer le batch en tant qu'administrateur mais pareil.
    J'ai recréé de toute piece le batch mais toujours le même problème.
    Est ce qu'il est possible de déplacer ou sortir "mmc.exe" et ses fichiers associés ? j'ai l'impression que c'est a cause de l'accès au folder "system32"

    Merci.

    Julien.


    • Modifié DarkMoutch mercredi 16 décembre 2015 09:04
    mercredi 16 décembre 2015 09:00
  • A priori le problème est là depuis la version 1511 de Windows 10.

    Pouvez-vous tenter d'executer votre console en passant par un deuxième CMD ? (exemple pour le composant compmgmt.msc) :

    runas /user:Administrateur /savecred "cmd /c \"start compmgmt.msc\""


    Ludovic CHOLLET | Microsoft System Administrator

    • Marqué comme réponse DarkMoutch mercredi 16 décembre 2015 10:57
    mercredi 16 décembre 2015 09:35
  • pareil. ne fonctionne pas.
    Par contre si je démarre ma console.msc avec le compte administrateur en passant par un batch ca passe. mais avec mon compte admin du domaine non...

    Julien.


    • Modifié DarkMoutch mercredi 16 décembre 2015 10:42
    mercredi 16 décembre 2015 10:42
  • STOP !

    runas /savecred /user:domainAdm@mydomaine.com "cmd /c\"start Console1.msc\""

    Ca marche !
    Certainement Ludovic que tu souhaitais que je fasse ça dans ton dernier poste.


    Julien.


    • Modifié DarkMoutch mercredi 16 décembre 2015 10:56
    mercredi 16 décembre 2015 10:54
  • Oui, c'est un contournement moche mais il fonctionne :)

    Avec plaisir.


    Ludovic CHOLLET | Microsoft System Administrator

    mercredi 16 décembre 2015 10:59
  • je m'en contenterai parfaitement !
    Merci :-)

    Julien.

    mercredi 16 décembre 2015 11:00