none
Problemas con S2D (Storages Spaces Direct) RRS feed

  • Question

  • Hola, quisiera hacerles una pregunta, siempre que despliego S2D en un Clúster FailOver con 2 nodos (Iguales) y una carpeta compartida como Witness, además de que el almacenamiento está en modo Espejo o "Mirror"... Me ocurre un problema, al terminar la configuración y darme todo "OK", cuando hago pruebas de "Fallo de un nodo", siempre ocurre un problema con uno de los nodos:


    Si el nodo HV2 "falla", el nodo HV1 se recupera correctamente, pone en marcha las VMs que tenía encendidas el HV2, y se hace cargo del CSV y el Volumen. Pero si pasa al revés, es decir, el HV1 falla, el HV2 es incapaz de poner en línea el CSV y el Disco, resultando así en el fallo del Failover y no pudiéndose recuperar el mismo, del fallo de un nodo.


    Me parece raro, puesto a que he desplegado esto dos veces, y en las dos veces, siempre pasa lo mismo, solo que la primera vez pasaba al "revés", el nodo HV2 era quien se recuperaba correctamente, mientras que el nodo HV1 fallaba a la hora de poner en línea el CSV y el Volumen, si el HV2 fallaba.


    No se me ocurren muchas ideas de cara a solucionar el fallo. Porque se supone que debería "ponerse siempre en marcha de nuevo" porque ambos servidores tienen las mismas especificaciones, los discos están configurados como JBOD y tienen NICs de 10Gbps para la comunicación de los mismos.

    No se si puede tener mucha relación, pero la diferencia de tiempo, entre las pruebas de "fallo de un nodo" fueron de unos 10-12min, con respecto la emulación del fallo en el nodo 1, y el nodo 2. Aunque también probé la primera vez, con una diferencia de 1 día, y fallaba igual...

    Un saludo.

    vendredi 26 octobre 2018 07:57