none
[EXCHANGE 2013] Outlook Anywhere - Pb de connexion depuis l'exterieur RRS feed

  • Question

  • Bonjour,

    Un user, sous Outlook 2013, ne parvient pas à se connecter à sa messagerie lorsqu'il est hors du réseau entreprise (depuis chez lui par exemple).

    Il doit y avoir un loup dans ma config Outlook Anywhere.

    Nom du serveur: mail.toto.fr (Nom publique) ou xxx-mail-01.groupe-xxx.local sur mon reseau LAN.

    DNS publique Gandi, zone toto.fr:

    autodiscover 300 IN A 93.17.230.xxx
    mail 300 IN A 93.17.230.xxx
    owa 300 IN A 93.17.230.xxx
    webmail 300 IN A 93.17.230.xxx

    @ 300 IN A 93.17.230.xxx

    Je constate dans un 1er temps, au niveau des paramètres du client Outlook (configuré apres un autodiscover local OK) que le nom du serveur Exchange apparait sous la forme "2999c8988-b867-4067-5643-9fa16@toto.fr" et pas mail.toto.fr

    Si je lance un test de config depuis le client Outlook local, sur le réseau local:

    Test Client local Outlook


    Au niveau de mon DNS local (Split DNS), voici ce que j'ai (je me demande si ca ne vient pas de là...):



    Depuis l'exterieur, si je lance l'outil de controle de configuration M$ https://testconnectivity.microsoft.com, j'ai ceci:


    Et là, je constate que le test me renvoie un nom en server-mail-01.groupe-toto.local pour mon serveur !!! Aucune chance donc de résoudre et de trouver mon Exchange depuis l'exterieur !

    J'imagine alors que mon client exterieur commence à dialoguer avec mon Exchange mais que ce dernier, en raison d'une mauvaise conf, lui renvoie un nom DNS erroné en .local.

    Bref, je suis preneur de tous vos avis ...

    Merci beaucoup !!!!

    A tout hasard: mon certificat SSL porte les noms et Alternames suivants:

    ps1:

    Si je fais un Get-OutlookAnywhere -Server "toto-mail-01" (nom local de mon serveur), j'ai ceci:

    ServerName: toto-mail-01

    ExternalHostName: rien !!!!

    InternaleHostName: toto-mail-01.groupe-toto.local


    Dominique





    • Modifié Catindy jeudi 3 septembre 2015 18:32
    jeudi 3 septembre 2015 17:06

Réponses

  • Je me réponds à moi meme ...

    Mon erreur était non pas dans un soucis de split DNS mais dans une configuration incomplete de l'Outlook Anywhere tel que le montrait le résultat de ma commande get-OutlookAnywhere ...

    L'InternalHostName et l'ExternalHostName devaient répondre sur le nom mail.toto.fr et donc ne pas être vides ou de la forme serveur.domaine.local.

    Je reste toutefois perplexe sur le fait que, dans mon client Outlook, le serveur Exchange apparait avec un nom de la forme "2999c8988-b867-4067-5643-9fa16@toto.fr" ...

    Cela peut il encore cacher un lézard ????


    Dominique




    • Modifié Catindy jeudi 3 septembre 2015 20:39
    • Marqué comme réponse Teodora Sharkova dimanche 6 septembre 2015 22:36
    jeudi 3 septembre 2015 20:13

Toutes les réponses

  • Je me réponds à moi meme ...

    Mon erreur était non pas dans un soucis de split DNS mais dans une configuration incomplete de l'Outlook Anywhere tel que le montrait le résultat de ma commande get-OutlookAnywhere ...

    L'InternalHostName et l'ExternalHostName devaient répondre sur le nom mail.toto.fr et donc ne pas être vides ou de la forme serveur.domaine.local.

    Je reste toutefois perplexe sur le fait que, dans mon client Outlook, le serveur Exchange apparait avec un nom de la forme "2999c8988-b867-4067-5643-9fa16@toto.fr" ...

    Cela peut il encore cacher un lézard ????


    Dominique




    • Modifié Catindy jeudi 3 septembre 2015 20:39
    • Marqué comme réponse Teodora Sharkova dimanche 6 septembre 2015 22:36
    jeudi 3 septembre 2015 20:13
  • Non il n'y a pas de lézard.

    Ne t'inquiete pas

    jeudi 3 septembre 2015 20:32