none
Poste mobile EFS et Répertoire partagé RRS feed

  • Question

  • Bonjour,

    Je recherche un information simple, a priorit.

    J'ai mis en place une infrastructure EFS pour les postes mobiles sous windows 7 & 8.1.

    Cela marche bien ainsi que le DRA.

    Le problème étant simple : 

    Le personne ayant un cryptage EFS copie leur fichier crypté sur un répertoire partagé afin qu'un autre personne puisse travailler sur ce fichier.

    Lorsqu'il le copie, celui est crypté sur le répertoire partagé.

    Est ce que la seul solution pour que le fichier soit décrypte sur le répertoire partagé étant de désactivé le cryptage au niveau du serveur.

    Ou existe t il une autre solution comme le décryptage par le serveur lors de la copie ou je ne sais point.

    Je ne parles pas bien sur de l'ajout sur le fichier crypté d'un autre utilisateur.

    Merci par avance 

    lundi 13 juin 2016 14:10

Réponses

  • Bonjour,

    en regardant la clé de registre correspondante, on trouve maintenant l'entrée

    "NtfsDisableEncryption"

    qui a la valeur 0.

    => Il suffit de positionner à 1

    A bientôt, 


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mardi 14 juin 2016 06:46
  • @Phillipe ==> Sans soucis ;-)

    @Thierry ==> Je n'ai pas encore tester mais cela ressemble à la solution

    Il suffit qu'au niveau des serveurs de fichier soit avec une stratégie local ou de groupe, on interdise l'EFS :

    Ouvrez Utilisateurs et ordinateurs Active Directory.
    
    Cliquez avec le bouton droit sur le domaine dont vous souhaitez modifier la stratégie de récupération, puis cliquez sur Propriétés.
    
    Cliquez sur l'onglet Stratégie de groupe.
    
    Cliquez avec le bouton droit sur la stratégie de récupération à modifier, puis cliquez sur Modifier.
    
    Dans l'arborescence de la console, cliquez sur Système de fichiers EFS (Encrypting File System).
    
    Où ?
    
    Configuration ordinateur/Paramètres Windows/Paramètres de sécurité/Stratégies de clés publiques/Système de fichiers EFS (Encrypting File System)
    
    Cliquez avec le bouton droit sur Système de fichiers EFS (Encrypting File System), puis cliquez sur Propriétés.
    
    Désactivez la case à cocher Permettre de crypter les fichiers à l'aide du système EFS.
    

    A ce moment là, lors de la copie de fichier cryptés, le système signale : 
    Vous êtes en train de copier le fichier dans une destination qui ne prends pas en charge le chiffrement.

    Je ne sais pas si cela joue sur le même paramètre et met une fenêtre d'avertissement.

    • Marqué comme réponse Didier Hoen mardi 14 juin 2016 11:41
    mardi 14 juin 2016 08:37

Toutes les réponses

  • Le fichier ne peut être décrypté que par le compte qui dispose de l'accès à la clé de cryptage et donc l'utilisateur.  Pour partager les fichiers EFS  voir : http://windows.microsoft.com/fr-fr/windows-vista/share-encrypted-files

    N'oublie pas de créer un agent de récupération EFS, par défaut le compte "administrateur" du DC est agent de récupération, mais son certificat d'agent n"existe que sur le premier DC créer dans le domaine et il est recommandé de l'exporter. Si vous ne l'avez pas fait et que ce DC n'existe plus vous n'aurez pas de possibilité de le récupérer. Il suffit que l'utilisateur perde la session sur le poste à partir duquel le fichier a été crypté pour perdre l'accès au contenu .

    Voir : https://technet.microsoft.com/en-us/library/cc512680.aspx


    lundi 13 juin 2016 17:18
    Modérateur
  • Bonjour,

    de mémoire, il existe une clé de registre pour décrypter (forcer le décryptage) automatiquement les fichiers lors du transfert sur le réseau.

    Voici une KB ressemblant étrangement : "HOW TO: Prevent Files from Being Encrypted When Copied to a Server"

    https://support.microsoft.com/en-us/kb/302093

    Les fichiers sont par défaut recryptés si le serveur fait partie du même domaine que la station, et que donc le certificat est utilisable...

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info


    lundi 13 juin 2016 19:05
  • Merci Thierry, c'est exactement ce que je n'arrivais pas a trouvé. Je vais tester cela et reviens vous donner mes résultats.

    Philippe, merci de vous intéresser à mon post et poster un réponse. malheureusement, elle semble formater et sans rapport puisque je précise que tout marche bien.

    mardi 14 juin 2016 05:39
  • Bonjour,

    en regardant la clé de registre correspondante, on trouve maintenant l'entrée

    "NtfsDisableEncryption"

    qui a la valeur 0.

    => Il suffit de positionner à 1

    A bientôt, 


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mardi 14 juin 2016 06:46
  • Oui désolé je viens de relire la question et j'ai répondu un peu vite ...

    mardi 14 juin 2016 07:42
    Modérateur
  • @Phillipe ==> Sans soucis ;-)

    @Thierry ==> Je n'ai pas encore tester mais cela ressemble à la solution

    Il suffit qu'au niveau des serveurs de fichier soit avec une stratégie local ou de groupe, on interdise l'EFS :

    Ouvrez Utilisateurs et ordinateurs Active Directory.
    
    Cliquez avec le bouton droit sur le domaine dont vous souhaitez modifier la stratégie de récupération, puis cliquez sur Propriétés.
    
    Cliquez sur l'onglet Stratégie de groupe.
    
    Cliquez avec le bouton droit sur la stratégie de récupération à modifier, puis cliquez sur Modifier.
    
    Dans l'arborescence de la console, cliquez sur Système de fichiers EFS (Encrypting File System).
    
    Où ?
    
    Configuration ordinateur/Paramètres Windows/Paramètres de sécurité/Stratégies de clés publiques/Système de fichiers EFS (Encrypting File System)
    
    Cliquez avec le bouton droit sur Système de fichiers EFS (Encrypting File System), puis cliquez sur Propriétés.
    
    Désactivez la case à cocher Permettre de crypter les fichiers à l'aide du système EFS.
    

    A ce moment là, lors de la copie de fichier cryptés, le système signale : 
    Vous êtes en train de copier le fichier dans une destination qui ne prends pas en charge le chiffrement.

    Je ne sais pas si cela joue sur le même paramètre et met une fenêtre d'avertissement.

    • Marqué comme réponse Didier Hoen mardi 14 juin 2016 11:41
    mardi 14 juin 2016 08:37
  • Je pense qu'il s'agit du même paramètre, mais par GPO!

    J'avais eu besoin de ce paramètre pour réaliser la synchronisation des données locales de l'utilisateur vers un serveur de partage avec ROBOCOPY... Il n'y avait alors pas de message d'alerte.

    XCOPY a une option spécifique /G pour gérer la copie vers des destinations non cryptées.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info


    mardi 14 juin 2016 08:41