none
[SP2013]Problème de lenteur et alias de site RRS feed

  • Question

  • Bonjour à tous, 

    J'ai un gros soucis de lenteur lors de l'accès à mon serveur Sharepoint 2013. Lorsque j'accède au site via le navigateur web (chrome ou IE8-9), le site met beaucoup de trop de temps à charger, plus de 30s! ce qui est intolérable. De plus, lors ce que le site s'ouvre enfin, un message SP "Nous avons bientôt terminé" s'affiche, ça tourne, et à un moment on peut enfin naviguer sur le site.

    Le serveur est une machine virtuelle Win 2008 R2, et en manque pas de ressource.

    quelle peut être la cause de ce ralentissement ?

    Je voudrais également savoir comment faire pour que l'adresse du site qui est actuellement

    http://srvw-spdpi:28967

    devienne, ou soit accessible depuis

    http://intranet ?

    ou autre dénomination si intranet n'est pas possible, car l'adresse avec le port et FQDN peu explicite, c'est pas terrible.

    Merci d'avance.

    Aurélien R.


    mardi 28 mai 2013 13:19

Réponses

  • Salut,

    1) Les 30 secondes, c'est tout le temps ou juste la première fois? Car si c'est la première fois, vous pouvez utiliser un script de warmup.

    2) Pour changer le nom de votre site il faut faire des modification aux niveau DNS, IIS et SharePoint.

    • Creation d'un alias dans DNS avec le NOM du site et IP
    • Dans IIS creation d'un bindigs dans le site adéquat aevc le NOM du site et l'IP
    • AAM dans SharePoint modifier la web app et mettre le nom du site

    Courage,

    Gokan


    SharePoint Forums Moderator    My Blog
    twitter  linkedin

    • Proposé comme réponse Valentin Lecerf mercredi 29 mai 2013 11:24
    • Marqué comme réponse Aurélien R mercredi 29 mai 2013 11:25
    mercredi 29 mai 2013 06:39
  • attention à l'emplacement, tu dois ouvrir le magasin du serveur local, pas celui utilisateur !

    ça expliquerait que tu n'aie pas de section SharePoint. L'autre explication serait que tu a une autorité de certif dans ton domaine, mais ca parait peu probable.

    respecte bien ces manips la :http://www.sharepointblues.com/2012/01/09/sharepoint-certificate-errors/ en sélectionnant "serveur local" dans certificates. 

    Il y avait aussi la solution de mettre 127.0.0.1 crl.microsoft.com dans le host en 2010, mais ça marche plus en 2013.



    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2013)

    • Marqué comme réponse Aurélien R lundi 10 juin 2013 09:24
    vendredi 7 juin 2013 12:18

Toutes les réponses

  • Salut,

    1) Les 30 secondes, c'est tout le temps ou juste la première fois? Car si c'est la première fois, vous pouvez utiliser un script de warmup.

    2) Pour changer le nom de votre site il faut faire des modification aux niveau DNS, IIS et SharePoint.

    • Creation d'un alias dans DNS avec le NOM du site et IP
    • Dans IIS creation d'un bindigs dans le site adéquat aevc le NOM du site et l'IP
    • AAM dans SharePoint modifier la web app et mettre le nom du site

    Courage,

    Gokan


    SharePoint Forums Moderator    My Blog
    twitter  linkedin

    • Proposé comme réponse Valentin Lecerf mercredi 29 mai 2013 11:24
    • Marqué comme réponse Aurélien R mercredi 29 mai 2013 11:25
    mercredi 29 mai 2013 06:39
  • 1) je viens de faire des tests, je pense que cela se produit lors qu'un nouveau compte accède au serveur SP. le démarrage est long et après cela ne le fait plus. Je vais continuer de suivre ce problème avec d'autres utilisateurs

    2) Merci, cela fonctionne parfaitement.

    mercredi 29 mai 2013 09:28
  • Hello,

    Si le serveur est coupé d'internet, il faut maintenant impérativement déclarer l'autorité de certification en local pour ne pas avoir de timeouts. En effet, en .NET les dlls signées sont checkées sur une liste de révocation.

    C'est déclaré par défaut pour windows (Microsoft root authority), mais pas pour sharepoint. Tu peux vérifier cela dans le plugin "certificats" de mmc, en allant dans "sharepoint" --> le chemin de certification n'est pas valide.

    Exporte le certificat sharepoint et importe le sur chaque serveur, cf http://onpointwithsharepoint.blogspot.fr/2012/11/powershell-for-exporting-and-copying.html (premiere option) pour exporter, puis tu le reimporte dans le magasin root du serveur. Les autres options, c'est si tu utilise des choses compliquées :)


    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2010)

    vendredi 31 mai 2013 11:36
  • Merci,

    le serveur est dans notre réseau, pour une utilisation exclusivement intra.

    Sachant que l'on passe par un proxy, il se peut qu’effectivement la connexion internet soient indirectement coupée.

    J'ai bien exporté le certificat, par contre, pour le chemin du "path of the root certificate" cela correspond à quoi exactement ? j'ai laisser comme sur le tuto, j'ai ensuite double cliqué dessus pour l'installer.

    vendredi 31 mai 2013 12:33
  • et hop, la kb ;)

    http://support.microsoft.com/kb/2625048?wa=wsignin1.0


    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2013)

    vendredi 31 mai 2013 17:13
  • +1 Emmanuel,

    Voici l'article que j'avais écrit dans le temps: https://www.nothingbutsharepoint.com/sites/itpro/Pages/How-to-Improve-Speed-in-SharePoint-2013.aspx

    Courage,

    Gokan


    SharePoint Forums Moderator    My Blog
    twitter  linkedin

    samedi 1 juin 2013 17:36
  • Bonjour, merci pour votre aide.

    j'ai bien intégré le certificat dans "Autorité de certification racine de confiance", mais c'est toujours aussi long et dans les journaux j'ai ça:

    "Une opération de validation de certificat a duré 30062,4519 millisecondes et a dépassé le délai d’exécution limite. Si cette situation se reproduit, cela signifie qu’un problème de configuration peut en être la cause."

     

    [EDIT] Je viens de m’apercevoir que je n'ai pas de section Sharpeoint dans les certificats...
    lundi 3 juin 2013 08:39
  • Même après vérifications, redémarrages, reconfiguration, le certificat ne passe pas, le soucis c'est que j'ai pas de section "SharePoint" dans mes certificats, j'ai bien "Autorités de certificats racine de confiance", et le reste ...

    mais c'est tout, rien en rapport avec SP (le certificat est tout de fois bien installé (SharePoint Root Authority)

    Merci de vitre aide

    vendredi 7 juin 2013 11:37
  • attention à l'emplacement, tu dois ouvrir le magasin du serveur local, pas celui utilisateur !

    ça expliquerait que tu n'aie pas de section SharePoint. L'autre explication serait que tu a une autorité de certif dans ton domaine, mais ca parait peu probable.

    respecte bien ces manips la :http://www.sharepointblues.com/2012/01/09/sharepoint-certificate-errors/ en sélectionnant "serveur local" dans certificates. 

    Il y avait aussi la solution de mettre 127.0.0.1 crl.microsoft.com dans le host en 2010, mais ça marche plus en 2013.



    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2013)

    • Marqué comme réponse Aurélien R lundi 10 juin 2013 09:24
    vendredi 7 juin 2013 12:18
  • Merci, effectivement, j’étais sur le local user...

    par contre aucun changement, toujours aussi long.

    les certificats sont valides, je me demande si ça bloque pas à cause du proxy quand même, car à coté de ça j'ai une erreur dans mes journaux : 53 - Récupérer l'objet à partir du réseau.

    Dans le détail on trouve : HTTP/1.0 407 Proxy Authentication Required

    pour récupérer un .cab depuis Microsoft.

    comment peut on configurer un accès ouvert en continu du proxy ?

    lundi 10 juin 2013 08:23
  • si le proxy te pose souci, il faut effectivement ajouter "127.0.0.1 crl.microsoft.com" dans le host, ou autoriser cette url. Est ce que tu vois bien "certificat OK" dans la section sharepoint?


    Emmanuel ISSALY - Architecte Infra Sharepoint (MCITP 2013)

    lundi 10 juin 2013 08:45
  • il semblerai que cela soit bon finalement, ralentissements sans doute dus à notre réseau ...

    Merci.

    il reste des erreurs dans le journal (CAPI2) mais c'est un soucis de proxy (mise à jour des certificats disallowedcertstl.cab et authrootstl.cab)

    lundi 10 juin 2013 09:24