none
Service transport Exchange 2007 ne démarre plus RRS feed

  • Discussion générale

  • Depuis lundi le service microsoft exchange transport ne veut pas démarrer sur mon serveur Hub .

    Les erreurs :
    Erreur 1053 : Le service n'a pas répondu assez vite à la demande de
    lancement ou de contrôle.
    et les erreurs 7000 et 7009 disant qu'il ne peut pas démarrer le service , je n'ai pas le service smtp d'installé sur la machine
    Est ce que quelqu'un a une solution ?
    jeudi 18 mars 2010 10:39

Toutes les réponses

  • Peut être avez vous passé un patch récemment sur Exchange, ou redémarré récemment Exchange ?

    La solution "propre" est indiquée ici : http://support.microsoft.com/kb/944752 , sinon vous pouvez augmenter le timeout dans le registre :

    Start Registry Editor.
    2.     Change the value data for the ServicesPipeTimeout DWORD value to 60000 in the Control subkey. To do this, follow these steps:
    a.     Click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
    b.     Click the Control registry subkey.
    c.     Right-click the ServicesPipeTimeout DWORD value, and then click Modify.
    d.     Click Decimal.
    e.     Type 60000, and then click OK.
    3.     If the ServicesPipeTimeout value is not available, add the new DWORD value, and then set its value data to 60000 in the Control registry subkey. To do this, follow these steps:
    a.     Click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet.
    b.     Click the Control registry subkey.
    c.     On the Edit menu, point to New, and then click DWORD Value.
    d.     Type ServicesPipeTimeout, and then press ENTER.
    e.     Right-click the ServicesPipeTimeout DWORD value, and then click Modify.
    f.     Click Decimal.
    g.     Type 60000, and then click OK.

    Note The value 60000 milliseconds equals 60 seconds.
    This change does not take effect until you restart the computer. After you increase the ServicesPipeTimeout value in the registry, the SCM waits for the services to use the whole ServicesPipeTimeout value before the System log reports that the service did not start.

    If the services require several minutes to start, a value of 60 seconds may be insufficient. Therefore, increase the ServicesPipeTimeout value to give the services sufficient time to start.

    http://laubel.wordpress.com/
    jeudi 18 mars 2010 15:16
  • Bonjour,

    je pense que tu as déjà essayé mais au cas ou, le serveur a été redémarré ? :)
    sinon augmenter le niveau de log du service MSExchangeTransport

    http://technet.microsoft.com/en-us/library/aa997825%28EXCHG.65%29.aspx

    Essayer de démarrer le service et regarder le journal d'application, des erreurs, des avertissements ?

    Pas d'erreur MSADACCESS comme quoi le serveur Exchange ne trouve pas l'AD ?

    nltest /dsgetdc:domain.local OK ?

    ping du domaine ok ?

    La configuration réseau est correcte ? adresse IP statique, pas d'autre programme qui utilise le port 25 ?
    bon courage

    yohan
    jeudi 18 mars 2010 17:23
  • Je vous remercie pour vos réponses, mais pour l'instant ca ne marche toujours pas.
    J'ai essayé d'allonger le time out (jusque 600000) mais rien n'y fait.
    Je précise qu'il s'agit d'un SBS 2008.
    Je ne pense pas qu'il y ait un autre programme sur le port 25, mais je n'en suis pas completement sur.

    Par contre j'ai une autre erreur qui est peut être en lien :
    Event id 10016 :

    Les paramètres d'autorisation spécifiques à l'application n'accordent pas d'autorisation Local Activation pour l'application serveur COM avec le CLSID

    {61738644-F196-11D0-9953-00C04FD919C1}

    au SID AUTORITE NT\SERVICE RÉSEAU de l'utilisateur (S-1-5-20) depuis l'adresse LocalHost (utilisation de LRPC). Cette autorisation de sécurité peut être modifiée à l'aide de l'outil d'administration Services de composants.

    Je ne comprends pas cette erreur et suis incapable de voir si elle a un lien avec le non démarrage du service transport exchange.

    jeudi 18 mars 2010 20:26
  • Bonjour,

     

    si tu n'as pas installé de dernier rollup d'Exchange tu peut aussi essayer de l'installer.

    Pour le reste, ca m'étonne que tu n'ais aucun avertissement ou erreur MSExchangeTransport dans le journal d'application quand tu démarres ton service.

    Autre chose, si tu as un antivirus au niveau système de fichier, vérifie que les exclusions pour Exchange aient été configurées, et essaie de désactiver l'antivirus histoire de voir si ce dernier t'a pas vérouillé un fichier utilisé par le service transport.

    a+


    vendredi 19 mars 2010 07:49
  • En faisant un Test-ServiceHealth qu'avez vous comme résultat ?

    Essayez de forcer le démarrage des services avec le script suivant :

    gwmi win32_service | where-Object {$_.StartMode -eq « Auto » -and $_.Name -like « MSExchange* » -and $_.State -eq « Stopped »} | Start-Service



    http://laubel.wordpress.com/
    vendredi 19 mars 2010 07:54