none
When editing the page in SharePoint we cannot edit the content area and we need to click on Save and keep editing to enable us to change the page layout or edit the content area

    Question

  • In SharePoint 2013, when editing a publishing page (in all sites and sub sites), it doesn’t let us to edit the content area and the below is added to the URL of the page:

    ?PageView=Shared&InitialTabId=Ribbon.WebPartPage&VisibilityContext=WSSWebPartPage

    In addition, Hide/Show ribbon is disappeared from the Settings menu. (in the Site navigation settings “Show ribbon” is selected). Therefore, we cannot see if the page is checked out by someone else anymore.

    When clicking on Save and keep editing, then I am able to edit the content area and the below is added to the URL of the page:

    ?ControlMode=Edit&DisplayMode=Design

    It seems that this is a SharePoint product issue!

    Some other site collections are fine. I can see this issue in some site collections in SharePoint online and SharePoint 2013 on-premises.

    The main problem is the need to click several times to open a page for editing.

    I appreciate your advises.

    Thanks, Kate








    mercredi 17 mai 2017 08:37

Réponses


  • I was able to fix it by deactivating the SharePoint Server Publishing feature in all sub sites in the site collection.

    Then in Site Settings > Site Collection Features, Deactivate/Activate SharePoint Server Publishing Infrastructure feature. 

    Finally, I have activated the SharePoint Server Publishing feature in all site and sub-sites.

    The issue is fixed on all sites.

    jeudi 18 mai 2017 09:40

Toutes les réponses

  • You can check in Site Contents -> Site Pages if the page is Checked Out.
    Also check if you have the correct permissions to EDIT the page.
    mercredi 17 mai 2017 09:27
  • Harshal, Thanks for your reply but I know that we can open the page library and see if the page is checked out to someone else! 

    The problem is that our client is complaining about these more steps and clicks for the page editors.

    When editing the page, they need to click on "Save and Keep Editing" to be able to edit the page content or change the page layout. This is frustrating and requires user training.  

    mercredi 17 mai 2017 11:44

  • I was able to fix it by deactivating the SharePoint Server Publishing feature in all sub sites in the site collection.

    Then in Site Settings > Site Collection Features, Deactivate/Activate SharePoint Server Publishing Infrastructure feature. 

    Finally, I have activated the SharePoint Server Publishing feature in all site and sub-sites.

    The issue is fixed on all sites.

    jeudi 18 mai 2017 09:40
  • We are currently having the exact same issue.... going to give your fix a try. 

    sayitfast

    vendredi 18 mai 2018 16:48
  • The fix listed above worked for me also.... deactivate at every sub-site and root site.  I then activated Site collection feature followed by site feature at root site.... than just activated at every sub-site that needed the publishing features and walla back in business. 


    sayitfast

    samedi 19 mai 2018 01:18