locked
[SFB-EX16] Messagerie unifiée non fonctionnel RRS feed

  • Question

  • Bonjour,

    Je me permets d'ouvrir un topic car je ne trouve pas la solution à mon problème.

    En effet, j'ai mis en place la messagerie unifiée entre Skype for Business et Exchange 2016.

    Concernant Skype For Business, nous avons une passerelle PSTN qui fait le lien entre notre skype et les appels audio vers l'extérieur (Nous avons également un Lync Edge).

    Je vois bien mon serveur Exchange dans Skype (je le vois en webmail.societe.com) et inversement dans Exchange.

    Nous avons un certificat public en webmail.societe.com et autodiscover.societe.com sur notre Exchange.

    Concernant le problème, je vois bien les options de messagerie vocales sur le client lync de mon utilisateur, sauf que lorsque je choisis d'appeler la messagerie vocale cela raccroche instantanément.

    Dans l'observateur de mon Skype, j'obtiens les erreurs suivantes :

    Dans système : Erreur 36884, schannel : 

    "Le certificat reçu à partir du serveur distant ne contient par le nom attendu. Il n’est par conséquent pas possible de déterminer si nous sommes connecté au serveur correct. Le nom de serveur attendu est serveurexchange.societe.lcl. La demande de connexion SSL a échoué. Les données jointes contiennent le certificat du serveur."

    Dans les logs Lync server : 

    1) Erreur 14428, LS Protocol Stack 

    "

    Échecs de connexion TLS sortante.

    Au cours des 2 dernières minutes, Skype Entreprise Server a rencontré 1427 échec(s) de connexion TLS sortante. Le code d’erreur du dernier échec est 0x80090322(SEC_E_WRONG_PRINCIPAL). L’erreur s’est produite lors de la tentative de connexion au serveur « serveurexchange.societe.lcl », à l’adresse [10.0.0.235:5061], et le nom d’affichage du certificat d’homologue est « webmail.societe.com ».
    Cause : généralement, il s’agit d’un problème avec le certificat de l’homologue ou avec l’enregistrement du nom d’hôte (DNS) utilisé pour atteindre le serveur de l’homologue. Un nom de principal cible incorrect signifie que le certificat de l’homologue ne contient pas le nom que le serveur local a utilisé pour se connecter. Une erreur liée à une racine de certificat non approuvée signifie que le certificat de l’homologue a été émis par une autorité de certification distante qui n’est pas approuvée par l’ordinateur local.
    Résolution :
    Vérifiez que l’adresse et le port correspondent au nom de domaine complet (FQDN) utilisé pour se connecter, et que le certificat de l’homologue contient ce nom de domaine complet (FQDN) dans son objet ou ses champs SAN. Si le nom de domaine complet (FQDN) fait référence à un pool de charge DNS équilibrée, vérifiez que toutes les adresses retournées par DNS font référence à un serveur du même pool. Dans le cas d’une erreur liée à une racine non approuvée, assurez-vous que la chaîne de certificats de l’autorité de certification distante est installée localement. Si vous avez déjà installé la chaîne de certificats de l’autorité de certification distante, essayez de redémarrer l’ordinateur local."

    2) Erreur 44009, LS Exchange Unified Messaging Routing 

    "Échec des tentatives de routage vers des serveurs d’un plan de numérotation de la messagerie unifiée Exchange

    Aucun serveur du plan de numérotation [SOCIETE-DIAL.societe.lcl] n’a accepté l’appel avec l’ID [e603be2a49b541719ed8d0aa640efe2f].
    Cause : le plan de numérotation n’est pas correctement configuré.
    Résolution :
    Vérifiez la configuration du plan de numérotation sur les serveurs de messagerie unifiée."

    J'ai essayé avec un certificat interne et j'ai quand même le soucis.

    J'ai regardé mon plan de numérotation, il me semble correct également.

    Si vous avez des questions ou des pistes, n'hésitez pas.

    Merci d'avance pour vos retours.

    Mikael

    mercredi 10 octobre 2018 13:57

Réponses

  • la messagerie unifiée n'utilise pas les URLs webmail.societe.com ni autodiscover.societe.com, c'est pourquoi il faut utiliser un certificat interne, contenant le fqdn réel du serveur pour les services UM et un autre certificat pour vos URLs publiques (services IIS)

    Avez-vous bien redémarré les services UM suite au changement de certificat?

    • Marqué comme réponse Mikalak77 vendredi 12 octobre 2018 09:01
    mercredi 10 octobre 2018 15:06
  • oui c'est cela car l'authentification se fait via le nom du serveur depuis la version E2013. 

    En version E2007 et E2010, il y'a avait une URL à configurer pour accéder à l'UM et donc vous auriez pu utiliser votre certificat, webmail.societe.com.

    ______________________________

    Merci de marquer comme reponse les interventions qui vous ont été utiles.

    • Marqué comme réponse Mikalak77 vendredi 12 octobre 2018 09:02
    jeudi 11 octobre 2018 08:34

Toutes les réponses

  • Bonjour 

    Avez-vous suivi cet article : 

    http://cloudexchangers.com/exchange-2016-um-integration-with-skype-for-business-2016-servers-2/

    et surtout la partie pré-requis : Enable Server to Server Authentication.

    mercredi 10 octobre 2018 14:18
  • Merci pour votre retour rapide.

    Oui j'ai bien suivi cette procédure. J'ai refais un test avec Test-CsExStorageConnectivity (pour être sûr) et le test a bien réussi.

    mercredi 10 octobre 2018 14:29
  • parfait

    pour moi le certificat associé aux services Messagerie unifiée MS Exchange et Routeur d'appel de messagerie unifiée doit absolument correspondre au nom de votre/vos serveurs Exchange - j'utilise généralement un certificat issue d'une PKI interne et non un autosigné

    mercredi 10 octobre 2018 14:41
  • Mon serveur Exchange est accessible depuis l'externe et interne en webmail.societe.com

    Mon certificat a pour SAN : webmail.societe.com et un enregistrement supplémentaire en autodiscover.societe.com.

    J'ai également tenter de créer un certificat depuis ma PKI interne et le problème est toujours présent.

    mercredi 10 octobre 2018 14:59
  • la messagerie unifiée n'utilise pas les URLs webmail.societe.com ni autodiscover.societe.com, c'est pourquoi il faut utiliser un certificat interne, contenant le fqdn réel du serveur pour les services UM et un autre certificat pour vos URLs publiques (services IIS)

    Avez-vous bien redémarré les services UM suite au changement de certificat?

    • Marqué comme réponse Mikalak77 vendredi 12 octobre 2018 09:01
    mercredi 10 octobre 2018 15:06
  • J'ai créer un certificat uniquement avec le nom du serveur local et cela fonctionne dorénavant.

    Il n'y a donc aucune possibilité d'utiliser le certificat public ? Il faut obligatoirement un certificat interne ?

    Merci en tout cas pour vos retours.

    mercredi 10 octobre 2018 22:36
  • oui c'est cela car l'authentification se fait via le nom du serveur depuis la version E2013. 

    En version E2007 et E2010, il y'a avait une URL à configurer pour accéder à l'UM et donc vous auriez pu utiliser votre certificat, webmail.societe.com.

    ______________________________

    Merci de marquer comme reponse les interventions qui vous ont été utiles.

    • Marqué comme réponse Mikalak77 vendredi 12 octobre 2018 09:02
    jeudi 11 octobre 2018 08:34
  • Merci pour vos explications.

    J'en profite pour vous posez une dernière question, nous avons fait l'achat de message vocaux en mp3, wap et wma.

    Savez-vous si il est possible de modifier les messages d'accueil des boites vocales avec ces fichiers pour remplacer ceux par défaut ?

    De ce que j'ai vu, je n'ai trouvé que l'option de le faire nous-même au micro.

    jeudi 11 octobre 2018 16:35
  • Ce n'est à ma connaissance pas possible de se passer du micro pour modifier les annonces personnelles.

    ________________________________

    Merci de marquer comme réponse les interventions qui vous ont été utiles.

    jeudi 11 octobre 2018 18:23
  • Merci pour toutes vos réponses.
    vendredi 12 octobre 2018 09:01