none
Déploiement Windows 7 : erreur lors de l'execution de la séquence de tâche RRS feed

  • Question

  • Bonjour,

    j'ai créer une séquence de tâches pour déployer Windows 7 en suivant le tutoriel des laboratoires Technet (ici : https://cmg.vlabcenter.com/manualprint.aspx?EnvironmentID=4adccc5c-0708-4607-aefc-5ec91316fc18)

    Mon client execute toutes les étapes de la séquence de tâche jusqu'a la restitution des données utilisateur

    J'obtient le message d'état suivant :

    Le moteur d'exécution des séquences de tâches n'a pas pu exécuter l'action (Demander le stockage de l'état de l'utilisateur) dans le groupe (Restaurer les fichiers et paramètres utilisateur) avec le code d'erreur 16389
    Sortie de l'action : bled. Checking quarantine status.
    Loading client certificates.
    Request to SMP '<NOMSERVEUR>.<NOMDOMAINE>' failed with error (Code 0x80092004). Trying next SMP.
    Sleeping for 60 seconds before next attempt to locate an SMP.
    Failed to find client signing certificate. Code 0x80092004
    ClientRequestToSMP::DoRequest failed. error = (0x80092004).
    Retry number 3
    Client is not domain joined.
    IPv6 entry points already initialized.
    DHCP entry points already initialized.
    Adapter {6D3D6AD0-681A-4890-A2D5-799C085B122A} is DHCP enabled. Checking quarantine status.
    Loading client certificates.
    Request to SMP <NOMSERVEUR>.<NOMDOMAINE>' failed with error (Code 0x80092004). Trying next SMP.
    OSDSMPClient finished: 0x00004005
    Failed to find client signingcertificate. Code 0x80092004
    ClientRequestToSMP::DoRequest failed. error = (0x80092004).
    Failed to find an SMP that can serve request after trying 4 attempts.
    ExecuteRestoreRequestToSMP failed (0x80004005).
    ExecuteRestoreRequest failed (0x80004005)..

     

    Mon client devrait :

    être sous Windows 7 (C'est le cas)

    avoir les données utilisateur sauvegardées au début de la séquence (Ce n'est pas le cas)

    être entré dans le domaine de l'entreprise (Ce n'est pas le cas)

     

    Avez vous déjà rencontré ce genre de problème ? Si oui, avez vous trouvé une solution ?

     

    Merci d'avance


    jeudi 5 mai 2011 14:32

Toutes les réponses

  • Bonjour,

    Est ce que ton pb est résolu ? Sinon est ce que tu est entrain d'utiliser Windows 7 SP1, si la réponse est oui alors tu peux jeter un oeil sur ce thread http://ctp.social.technet.microsoft.com/Forums/en/configmgrosd/thread/004cbb3d-2e01-42e3-8b36-231a46ff6d0a


    Bechir Gharbi | http://myitforum.com/cs2/blogs/bgharbi/
    mardi 10 mai 2011 09:57
    Modérateur
  • Bonjour,

    mon problème n'est malheureusement pas résolu. Je souhaite effectivement deployer Windows 7 SP1 et je suis déjà tombé sur ce thread.

    Je n'ai pas compris le principe de la réponse :

    "1. Create a standalone package of 'ccmcertfix.exe' (extract kb977203.exe hotfix) with program normal command line like 'ccmcertfix.exe c:\CCMCertFix.log'
    2. Distribute above package to required distribution point(s).
    3. Go to Task Sequence, Under 'State Capture' group add 'install software' step and point to 'cmcertfix' package and it's program."

    En effet, lorsque j'ai lancé KB977203.exe, un dossier a été créé dans c:\SMSPKGC$\<IDPACKAGE>\i386. Ce dossier se nomme hotfix et contient le fichier sccm2007ac-sp2-kb977203-x86.msp.

    J'ai rechercher ccmcertfix.exe sur le poste SCCM et je n'ai pas réussi a mettre la main dessus. Après quelques petite recherche, je suis tombé sur ça:

    http://support.microsoft.com/kb/977203

    J'ai donc essayer de modifier ma séquence de tâche en ajoutant PATCH="%_SMSTSMDataPath%\OSD\<var><package_id></package_id></var>\i386\hotfix\KB977203\SCCM2007AC-SP2-KB977203-x86.msp" dans les propriété de l'instalation sous Configurer Windows et ConfigMgr (Comme indiquer sur le post) mais rien n'as changer.

    Je cherche encore.


    Edit :

    J'ai finalement trouver ccmcertfix.exe, je n'avais pas cherché au bon endroit. J'essaye avec ça et je vous tiens au courant. Merci encore.


    Edit N°2 :

    J'ai créer un package d'installation de ccmcertfix.exe et je pensais pouvoir ajouter l'installation du package dans la séquence de tâche. Je suis confronté a un autre problème. En effet, lorsque je choisi "Ajouter / Général / Installer un logiciel" dans l'outil de modification de ma séquence de tâches et que je veux choisir mon package contenant ccmcertfix, il n'apparait pas dans la liste des programmes a executer. Idem pour tout mes packages mis a par l'installation de 7zip (qui est le seul .msi, je pense que c'est lié...). Une suggestion ?


    mardi 10 mai 2011 10:52
  • Bonjour,

    J'ai enfin trouver pourquoi mes appli n'était pas visible : voulant les installer de façon silencieuse, j'avais placer des commutateurs afin de ne pas voir l'execution de ses appli. Genre install.exe /silent. Il me fallait faire simplement "install.exe" /silent.

    Donc, j'ai enfin ajouter ccmcertfix.exe a ma séquence de tâches (Après l'étape de Capture d'état utilisateur). Je vois ce que ça donne et je vous tiens au courant dans l'apres-midi.

    jeudi 12 mai 2011 10:19
  • Bonjour,

    Je viens vous faire un petit rapport de la situation actuelle.

    Le déploiement de l'OS se déroule bien, mon XP passe en Windows 7.

    Mon poste de travail remonte enfin dans le domaine de l'entreprise.

    J'ai toujours mon soucis avec les données utilisateur.

    Voici un screen de ma séquence de tâche. J'ai mis en évidence l'étape durant laquelle je lance ccmcertfix.exe. Peut être me suis-je trompé d'endrois.

    http://hpics.li/767a25a

    J'obtient ce message d'erreur :

    Le moteur d'exécution des séquences de tâches n'a pas pu exécuter l'action (Demander le stockage de l'état de l'utilisateur) dans le groupe (Restaurer les fichiers et paramètres utilisateur) avec le code d'erreur 16389
    Sortie de l'action : tificates.
    Request to SMP '<NOMSERVEUR>.<NOMDOMAINE>' failed with error (Code 0x80092004). Trying next SMP.
    Sleeping for 60 seconds before next attempt to locate an SMP.
    Failed to find client signing certificate. Code 0x80092004
    ClientRequestToSMP::DoRequest failed. error = (0x80092004).
    Retry number 3
    Client joined to the <NOMDOMAINE> domain.
    Client is a member of the Site-central site.
    IPv6 entry points already initialized.
    DHCP entry points already initialized.
    Adapter {C8A6B305-76E6-4E0C-AB0C-CC172F223015} is DHCP enabled. Checking quarantine status.
    Loading client certificates.
    Request to SMP '<NOMSERVEUR>.<NOMDOMAINE>' failed with error (Code 0x80092004). Trying next SMP.
    OSDSMPClient finished: 0x00004005
    Failed to find client signingcertificate. Code 0x80092004
    ClientRequestToSMP::DoRequest failed. error = (0x80092004).
    Failed to find an SMP that can serve request after trying 4 attempts.
    ExecuteRestoreRequestToSMP failed (0x80004005).
    ExecuteRestoreRequest failed (0x80004005).. 

    Merci d'avance.





    vendredi 13 mai 2011 06:28
  • Bonjour, La situation n'évoluant pas, j'ai modifié ma séquence de tâches pour qu'elle ne fasse tout simplement pas de restauration de données. Le tout sera gérér par les profils itinérants de l'entreprise. Tant pis pour SCCM / USMT Merci pour le coup de main.

    J'ai tout de même une nouvelle question : est-il possible de copier des données présentes sur le disque dur du PC avant la migration ?

    Nous utilisons PowerPoint et il serait très interessant de conserver les archives de messageries des utilisateurs.

    J'aimerais, s'il est possible, réaliser une sorte de recherche de fichiers d'un certain type, les copier sur le Point de Migration, Migrer l'ordinnateur et déplacer de nouveau les fichiers sur l'ordinnateur nouvellement migré.

     

    Merci d'avance

    vendredi 20 mai 2011 13:20