none
Getting error while configuring SharePoint 2013 that "SocketException was thrown with SocketError ConnectionRefused"

    Question

  • Hi,

    I am installing the SharePoint-2013 on development virtual machine. and i have the following environment.

    Windows server : 2012

    SQL server 2012(enterprise edition)

    Active directory(domain) is configured on same server.

    for SharePoint configuration purpose i had  created SP_farm account with SQL server DB_creator,security admin etc rights.

    even though m facing this issue related with socket exception.

    Error in log file :

    04/08/2014 12:26:33  1  INF            Trying to see if port 35513 is free on machine SHAREPOINT2013.  Min port we will try is  1024, Max port we will try is 49151
    04/08/2014 12:26:35  1  INF            A SocketException was thrown with SocketError ConnectionRefused
    04/08/2014 12:26:35  1  INF            Connect has been refused for port 35513, so we will consider this a free port
    04/08/2014 12:26:35  1  INF            Have not found a free port yet.  Number of tries is 1.  Min port we will try is 1024, Max  port we will try is 49151
    04/08/2014 12:26:35  1  INF            Adding port 35513 to the exclusion list so it is not chosen again during this run

    So m bit confuse about is this error related to network issue or something else that i have to configure on server.

     any suggestion or reply will be appreciated..!:-) 


    Shiv

    mardi 8 avril 2014 07:19

Toutes les réponses

  • Is the firewall turned on?

    Regards, Matthew
    MCPD | MCITP
    My Blog
    View Matthew Yarlett's LinkedIn profileView Matthew Yarlett's profile

    See my webpart on the TechNet Gallery that allows administrative users to upload, crop and format user profile photos. Check it out here: Upload and Crop User Profile Photos

    mardi 8 avril 2014 07:29
  • Hi Matthew ,

    I had tried to configured the setup both ways i.e keeping Firewall on and making off too....!

    but no success...!

    please help.............!

    Shivaprasad S.


    Shiv

    mardi 8 avril 2014 07:37
  • Did you ever get an answer to this?  I have the same problem

    A SocketException was thrown with SocketError ConnectionRefused

    lundi 19 mai 2014 16:51
  • Matthew Carter,Yes

    Please re-run the setup once again its seems to be issue  with system Firewall configuration


    Shiv



    jeudi 16 octobre 2014 15:08
  • Did you ever get this fixed? I have the same. It's not firewall related as far as I can see. Perhaps this has something to do with a router port not being free? I am installing on a single domain machine and the DNS all looks good, no errors in DCDIAG... what to check now? 


    Jiggy Gaton, Trainer and Media Consultant for Nepal and S. Asia

    vendredi 22 mai 2015 12:17
  • What version are you installing? I installed SW_DVD5_SharePoint_Server_2013w_SP1_64Bit_English_MLF_X19-36118.ISO and it worked for me, I just installed on new VMware "hardware" (a VM) on Server 2012 SP0

    I had windows firewall "on" and "out of the box" configuration.

    I am connecting to ANOTHER SQL database server, if that helps, NOT standalone, on same server (SharePoint and SQL Server 2012 SP2 Developer Edition or Standard Edition (non production)). 

    Matt

    vendredi 22 mai 2015 12:23
  • Hi matt, I installed en_sharepoint_server_2013_x64_dvd_1121447.iso, got the error, then applied the SP1 update, still no go. I am using a Windows 2012 r2 and SQL 2014 server with all the updates applied. I am also inside a VM (Parallels Desktop 10), everything seems to be running well but this install. My end goal is to get a project server going, so this is critical :) 

    Thx! 


    Jiggy Gaton, Trainer and Media Consultant for Nepal and S. Asia

    vendredi 22 mai 2015 12:43
  • I'd try to turn off windows firewall and possibly antivirus if possible to try to rule anything out.

    You're surely a local admin on the VM box and you're surely running SharePoint 2013 Products Configuration Wizard

    "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\BIN\psconfigui.exe"

    as administrator.

    Are you checking for chimney=disabled? I think I set this up before I did the install, however I didn't document it in my installation graphics.

    Change Network configuration

    ON VM’s

    https://technet.microsoft.com/en-us/library/hh851996.aspx

    netsh int tcp set global chimney=disabled

    netsh int ip set global taskoffload=disabled

    Check if task offload is disabled:

    netsh int ipv4 show global

    netsh int ipv6 show global

    Sadly besides this, I am not sure what else to try.

    vendredi 22 mai 2015 13:08
  • I have similar error installing SharePoint 2016 trial. Whatever port I m trying, configuration fails with exactly same resulting message. I have no idea how to overcome this.
    mercredi 13 juin 2018 14:13