none
SharePoint 2010 / Service Sync qui ne démarre pas RRS feed

  • Question

  • Bonjour à tous,

    Je suis confronté à un problème ennuyeux concernant le service de Synchro AD et plus précisemment avec Forefront Identity Manager.

    Contexte : 2 Web, 2 App / SHP 2010 CU MARS 2011 W2K8R2 SP1 / 1 cluster SQL 2008 SP2

    Toute l'installation de la ferme est OK, toutes les Service App sont déployées et configurées.

    Reste User Profile :(

    L'installation de la SA est OK, je peux accéder au site d'admin sans souci. Par contre, si je veux démarrer le service User Profile Synchronization Service, ça coince.

    J'ai déja rencontré des problèmes similaires et j'ai suivi A LA LETTRE le tuto ici : http://www.harbar.net/articles/sp2010ups.aspx

    Dans le journal App du serveur sur lequel FIM est censé démarrer, je trouve les erreurs suivantes :

    D'abord 2 :

    Microsoft Ressource Manager / Error 22 / The Forefront Identity Manager Service cannot connect to the SQL Database Server.
    Note : j'ai déja vu ce message sur d'autres fermes sans que cela fonctionne mal pour autant

    Puis ensuite :

    FIMSynchronizationService / Error 6306
    The server encountered an unexpected error while performing an operation for the client.
     
     "BAIL: MMS(9672): mastate.cpp(3145): 0x80230622 (A management agent with this name already exists.): MA directory cannot be created because it is already in use by an existing MA: C:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\MaData\ILMMA
    BAIL: MMS(9672): mastate.cpp(1637): 0x80230622 (A management agent with this name already exists.)
    BAIL: MMS(9672): server.cpp(964): 0x80230622 (A management agent with this name already exists.)

    Suivi d'erreurs 3 source Forefront Identity Manager

    Suite à cela, les 2 services FIM s'arretent et, dans la console Central Admin, le User Profile Sync Service repasse en STOPPED.

    Je ne sais plus quoi faire. Merci pour votre aide si vous avez quelque idée.
    Bonne journée !

    jeudi 30 juin 2011 13:16

Toutes les réponses

  • Il me semble avoir déjà eu ce type de message et il me semble l'avoir résolu en supprimant le User Profile SA pour ensuite le recréer mais en utilisant un nom différent.

    En effet, le SA est franchement pas évident à configurer et du coup on en arrive à le supprimer pour le recréer pensant qu'on a fait une erreur. Là où le bat blesse c'est qu'on le recréer souvent avec le même nom et du coup... bardaf c'est l'embardée, on a des conflits dans tous les sens...

    En espérant que vous soyez dans le même cas de figure sinon on est pas sorti de l'auberge ;-)


    Pascal P
    http://sharepoint-afterwork.com
    http://pascalp.dotnet-france.com/
    Twitter: @PascalPoeck
    jeudi 30 juin 2011 13:54
  • Merci beaucoup pour ta réponse et ton conseil.

    J'ai essayé plusieurs fois cette manipulation sans succès, démarrage également du sync service sur d'autres serveurs de la ferme, le problème est similaire.

    Je pense que le pb se focalise sur l'initialisation du service Forefront Identity Manager ; à la base il doit créer des agents, un qui s'appelle ILMMA et un autre MOSS*. J'ai tout de suite une erreur qui apparait indiquant que le ILMMA existe déja et qu'il ne peut pas continuer.

    Cf copie du log dans mon précédent message.

    Toute aide / piste est la bienvenue !

     

    vendredi 1 juillet 2011 06:02
  • Bonjour,

    J'ai eu deux problématiques à l'installation, que je te donne, en esperant que ceci puisse t'aider

    Problématique numéro 1 :

    http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010setup/thread/9e5fb41b-1709-49de-acc2-b9784ba5ea4b

    Recoution :

    •On the SharePoint Server: CD %ProgramFiles%/Microsoft Office Servers

    •Right click on the directory 14.0

    •Select Properties

    •Select Security

    •My system did not have "Network Service" granted any privs

    •Granted Read & Execute to "Network Service"

     

    Problématique numéro 2

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/6d467dd8-dc2b-4191-8b5c-6bcf61448fb5/

    Resolution

    1.       Open Registry Editor and navigate to the SQLInstance value located at HKLM\SYSTEM\CurrentControlSet\services\FIMSynchronizationService\Parameters

    2. Open the SQLInstance value and type in your SQL Server name\Instance.  Do not hit OK yet.

    3. Open Central Admin and browse to Manage Services on Server. 

    4. Start User Profile Synchronization Service.

    5. Immediately after starting the User Profile Synchronization Service go back to the registry and click OK to add the SQLInstance value typed in step 2.

    *Please note: you may have to attempt the steps above more than once before the User Profile Synchronization Service will start successfully.

    Bon courage

     

    Thierry Buisson

    mardi 5 juillet 2011 09:38
    Modérateur
  • Bonjour Jmo91,

    Est-ce que les éléments de Thierry vous ont aidé à résoudre votre problème ?

    Cordialement,

    Pïerre


    Pierre Vivier-Merle - MVP SharePoint Server
    http://blogs.developpeur.org/pierre
    Merci de valider les réponses qui correspondent à votre problème afin qu'il apparaisse comme résolu.
    dimanche 17 juillet 2011 08:20
    Modérateur
  • Bonjour à tous,

    Hélas non, après de vaines recherches, j'ai demandé à nos amis du Support Premier de lancer des investigations.

    Le problème a l'air plus compliqué qu'il n'y parait, cela fait une semaine qu'ils cherchent la solution :)

    Du coup, n'ayant jamais rencontré cette problématique précise, je me demande si le problème ne vient pas d'une restriction de l'infra client (AD, Policy ou autre)

    Je vous tiens au courant.

    Bonne journée !

     

    mardi 19 juillet 2011 07:41