none
Parametrage pour connecteur spécifique sous Exchange 2007 RRS feed

  • Question

  • Bonjour à tous !
    
    
    
    J'avais paramétré mon ancien serveur Exchange 2003 avec un connecteur 
    
    spécifique lorsque je devais envoyer des messages vers AOL.
    
    
    
    Après avoir migré avec succès il y a 6 mois vers Exchange 2007 (un seul serveur qui gère tous les rôles classiques hormis messagerie unifiée, nom de domaine géré par OVH, enregistrements normalement à jour), avoir changé de F.A.I (Orange pro),fait pas mal de modifs pour que tout soit "clean" (paramétrages habituels de sécurité + mise en place params SPF + GFI Mail Essentials v14.0 + filtres Microsoft activés), j'ai malheureusement hérité d'une I.P fixe qui est reconnue comme étant "résidentielle" ou dans une plage à risque comme d'hab' devrais-je dire, par un editeur (depuis ce mois-ci MX Tools m'indique que mon I.P est clean !), ce qui me génère ce genre de réponse de rejet pour deux ou trois noms de domaines pour le moment
    
    :
    
    _______________________________________________
    
    
    
    La remise a échoué pour ces destinataires ou listes de distribution :
    
    
    
    'xx.xxxxx@gia.fr'
    
    Votre message n'a pas été remis en raison des stratégies de sécurité. 
    
    Microsoft Exchange ne tentera plus de remettre ce message pour vous. 
    
    Fournissez le texte de diagnostic suivant à votre administrateur système.
    
    
    
    L'organisation suivante a refusé votre message : smtp17.msg.oleane.net.
    
    
    
      _____  
    
    
    
    Envoyé par Microsoft Exchange Server 2007 
    
    
    
    Informations de diagnostic pour les administrateurs :
    
    
    
    Serveur de génération : XXXEXCHANGE.MONNOMDEDOMAINE.fr
    
    
    
    xx.xxxxx@gia.fr
    
    smtp17.msg.oleane.net #550 5.7.1 Access denied - Reverse IP with this 
    
    generic domain name is considered as source of spam ##
    
    
    
    En-têtes de message d'origine :
    
    
    
    Received: from XXXEXCHANGE.MONNOMDEDOMAINE.fr ([fe80::791e:9435:b93c:6c0e]) by
    
     XXXEXCHANGE.MONNOMDEDOMAINE.fr ([fe80::791e.....:6c0e%10]) with mapi; Thu, 18
    
     Feb 2010 13:24:33 +0100
    
    From: Prenom NOM <user@MONNOMDEDOMAINE.fr>
    
    To: "'xx.xxxxx@gia.fr'" <xx.xxxxx@gia.fr>
    
    Return-Receipt-To: <user@MONNOMDEDOMAINE.fr>
    
    Date: Thu, 18 Feb 2010 13:24:31 +0100
    
    Subject: Envoi message contournement
    
    Thread-Topic: Envoi message contournement
    
    Thread-Index: AcqwlVc4r3Rej3lMRhO6rqo7QIZcIQ==
    
    Message-ID: 
    
    <159EEE83C9EADD4987FD74B9F06B41183704C1FADD@XXXEXCHANGE.MONNOMDEDOMAINE.fr>
    
    Accept-Language: fr-FR
    
    Content-Language: fr-FR
    
    X-MS-Has-Attach:
    
    X-MS-TNEF-Correlator:
    
    acceptlanguage: fr-FR
    
    Content-Type: multipart/alternative;
    
    	boundary="_000_159EEE83C9EADD4987FD74B9F06B41183704C1FADDXXXEXCHANGEP_"
    
    MIME-Version: 1.0
    
    ______________________________________________
    
    
    
    Impossible bien evidemment d'y remédier puisque la seule solution 
    
    impliquerait une modif des reversedns qu'Orange ne prendra pas la peine 
    
    d'effectuer comme ils me l'ont confirmé par email...
    
    
    
    Retour donc à la case départ et je me pose la question sur ce qui serait le 
    
    plus pertinent dans mon cas !
    
    
    
    Etant donné que TOUS les autres domaines connus avec lesquels nous 
    
    échangeons acceptent notre nom de domaine, que je ne souhaite pas dans un 
    
    premier temps configurer mon serveur Exchnage sur le serveur authentifié 
    
    d'Orange pro pour l'enemble de mon flux de messagerie, me faut-il créer un 
    
    connecteur spécifique comme je l'avais fait sous Exchange 2003, ou existe 
    
    t-il une alternative moins "lourde" ?



















    Si je dois créer un connecteur spécifique, sous Exchnage 2007, de quel type doit-il être et quels doivent être les paramètres suivants :






    - Personnalisé ou Internet ?
    - Espace d'adressage : mentionner en file indienne les noms de domaine qui rejetent pour le moment ? Poids : 1, 10 autre ?
    - Paramètres du réseau : "Utiliser les enregistrements MX..." ou "Router les messages via les hôtes actifs siivants" et indiquer le smtp spécifique d'Orange dans "Ajouter un hôte actif" (smtp-msa.orange.fr) ?
    - Configurer les authentifications : là j'ai les infos d'Orange pro.
    - Serveur source : le mien bien evidemment.

    Si d'autres noms de domaines venaient par aventure ne pas accepter mon nom de domaine, me faudra t'il empiler les exceptions une à une ? Merci d'avance pour vos suggestions, Philippe.
    vendredi 19 février 2010 13:35

Réponses

  • Bonjour à tous !

    En cette froide journée dominicale, je viens d'obtenir la réponse (enfin j'espère, mais cela semble bien parti !) du newsgroup Exchange U.S !

    Comme cela m'agaçait, j'ai pris ma plume et rédigé un post similaire qui a été particulièrement fructueux ( http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/df3eb89e-685d-4a87-a1c7-9e3e7e5cb27e ) !

    J'ai effectué la modification suggérée, et la file d'attente s'est immédiatement vidée après un refresh !

    J'attends maintenant le retour du message du destinataire qui gère son compte à distance pour confirmer tout cela !

    Pour ceux que cela pourrait interesser, effectivement, dans l'EMC il n'y a RIEN qui permette de modifier le port par défaut des Send Connectors !

    Il faut passer par l'EMS pour opérer des modifications...

    Je ne suis pas un fondu de la ligne de commandes, je l'utilise quand cela est vraiment nécessaire, et je continue de me demander quel est l'intérêt d'effectuer cela de façon archaïque alors qu'une simple case (tout comme pour d'autres sections où l'on peut affecter un port différent !) avec le port pourait être affichée...
    Tout le monde n'a pas 400 serveurs à scripter M. Microsoft !
    Laissez au moins l'alternative "graphique" quand il n'y a pas plus d'opérateurs à fournir et ceux qui veulent continuer d'utiliser la ligne de commandes pourront le faire à satiété...
    Enfin bref...

    Voici les opérations possibles en ce qui concerne mon problème qui manifestement se retrouve à l'international, ce qui n'a rien de surprenant puisqu'il consiste à reprendre le port par défaut du "Receipt Connector" par le F.A.I ( http://forums.msexchange.org/m_1800467895/mpage_1/key_/tm.htm#1800467906 ):

    Unfortunately, there isn’t a nice way to set the Send Connector port in the Exchange Management Console (I am sure that you don’t hear this for the first time ).

    Open Exchange Management Shell and start by checking your Send Connector(s) :

       Get-SendConnector

    You should get the name of your send connector(s) – like “Default Send Connector”.

    If you haven’t messed up with the port configuration of the connector yet, it should be using the default port -25.
    It is a good idea to confirm this with the command:

       Get-SendConnector | fl port

    Then change the port with the command:

       Set-SendConnector –Identity “Your Send Connector Name” -Port 587

    If you have only one Send Connector you can use that command too:

       Get-SendConnector | Set-SendConnector -Port 587

    Of course, it is a good idea to check the final result again with:

       Get-SendConnector | fl port

    Or even take a look at the full listing for the send connector:
    Get-SendConnector | fl

    Regards,

    Dean

    Voilà, cela me semble un bon point de départ et je ne vois pas pourquoi cela ne fonctionnerait pas puisque pour moi c'était la raison la plus probable du blocage du message dans la file d'attente !

    Un grand merci à Jon-Alfred Smith pour ses "tips" très interessants !

    Bien amicalement,

    Philippe.
    dimanche 21 février 2010 08:47

Toutes les réponses

  • Voir : http://technet.microsoft.com/fr-fr/library/aa998814(EXCHG.80).aspx


    Maxence Derieppe -- Consultant Overlap Groupe -- MCITP EA & EMA -- http://derieppe-maxence.blogspot.com
    vendredi 19 février 2010 23:19
  • Bonjour Maxence,

    Tout d'abord, merci pour cette réponse rapide.

    Je viens de créer le connecteur puisque manifestement sous Exchange 2007 il n'y a pas eu de changements significatifs comparé à la vresion 2003.

    J'aurais juste besoin d'une petite précision : le connecteur "Personnalisé" est utilisé pour router des messages en interne vers des serveurs NON Exchange si j'ai bien compris et pour TOUT routage VERS Internet, c'est systématiquement le connecteur éponyme ?

    Le message est bloqué dans la file d'attente... soit le routage via l'option "Router les messages via les hôtes actifs suivants (smtp-msa.orange.fr)" n'est pas le bon et il faut opter pour l'autre choix ("Utiliser les enregistrements MX DNS..."), soit il faut changer d'autres paramètres !!?

    Message d'erreur dans la file d'attente : "421 4.2.1 Unable to connect. " Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

    Pour mémoire, il faut remplir à trois conditions pour router via les serveurs Orange :

       - Hôte : smtp-msa.orange.fr
       - Authentification : celle de la BAL de l'abonné
       - Port : 587

    Petite précision supplémentaire : un simple paramétrage sur un client Outlook avec les infos mentionnées sur le serveur (smtp, port, authentification fournies par Orange pro) permet d'envoyer avec usccès les messages.
    De même sur le routeur, ports parfaitement ouverts.

    La file d'attente est à jour, elle n'est pas suspendue, je n'ai aucun autre problème avéré dans le flux de ma messagerie et la résolution DNS et parfaitement opérationnelle pour l'enemble du domaine.

    Une idée ?
      
    Bien cordialement,

    Philippe.
    samedi 20 février 2010 09:26
  • Bonjour,

    la solution globale est d'utiliser systématiquement le relais proposé par son fournisseur d'accès Internet, et d'indiquer l'authentification nécessaire sur ce connecteur.

    Le principal inconvénient est qu'il n'y a plus de remise directe dans les messageries distantes, et donc plus de suivi possible dans les logs des remises sur ces messageries.

    L'autre solution est effectivement de créer un connecteur spécifique (utilisant l'authentification et le relais du FAI) uniquement pour les domaines posant problème.

    A bientôt,

    PS: un connecteur de type "Custom" permet de réaliser n'importe quelle configuration en fonction des éléments saisis.

    Thierry DEMAN. MCSE+MSI, MCDBA, MCITP SQL2K5,SQL2K8,EXCH2K7,W2K8 ADM&ENT, MCTS OCS2007, HyperV,WM6.5. Exchange MVP (http://www.faqexchange.info) LE PERMIS INFORMATIQUE.
    samedi 20 février 2010 16:53
    Modérateur
  • Bonjour,

    la solution globale est d'utiliser systématiquement le relais proposé par son fournisseur d'accès Internet, et d'indiquer l'authentification nécessaire sur ce connecteur.
    Le principal inconvénient est qu'il n'y a plus de remise directe dans les messageries distantes, et donc plus de suivi possible dans les logs des remises sur ces messageries.


    Bonjour Thierry

    Oui, ce serait le plus simple, mais pour les raisons évoquées plus bas dans votre réponse, cele me semble ennuyeux...


    L'autre solution est effectivement de créer un connecteur spécifique (utilisant l'authentification et le relais du FAI) uniquement pour les domaines posant problème.

    A bientôt,


    C'est bien cette solution que je m'evertue à privilégier, mais vous avez pu constater les problèmes que cela occasionne dans mon précédent email !

    Comment utiliser cette solution quand le port est atypique (587) !!???

    Pour moi la problématique semble se situer là, mais peut-être que je me trompe...

    Y a t'il une étape supplémentaire que j'aurais omise ?

    Encore une fois, l'envoi d'un message test depuis un client Outlook avec le smtp + port 587 + authentification demandés par Orange pro FONCTIONNE !

    SI l'on implémente un connecteur, le message reste bloqué dans la file d'attente avec le message cité dans mon précédent email !

    Mes recherches sur le Net pointent sur des cas présentants des messages simialires mais avec de problématiques liées soient au firewall (je suis catégorique ce n'est pas mon cas !) soit de mauvaises I.P ou références du smtp à utiliser, ce qui n'est, encore une fois pas le cas, puisque l'envoi via un client Outlook fonctionne parfaitement !!!

    La seule aide fournie par Orange consiste à suivre cet article concernant Exchange 2003 et qui revient à votre "situation globale" :

       - http://assistance.orange.fr/2017.php 

    Mais quid de l'opération sous Exchange 2007 ou de la possibilité de l'effectuer avec un seul connecteur à mettre en place !

    Une autre idée sur la problématique, car là, j'avoue que je sèche !!??

    Bien cordialement,

    Philippe.
    samedi 20 février 2010 17:45
  • Bonjour à tous !

    En cette froide journée dominicale, je viens d'obtenir la réponse (enfin j'espère, mais cela semble bien parti !) du newsgroup Exchange U.S !

    Comme cela m'agaçait, j'ai pris ma plume et rédigé un post similaire qui a été particulièrement fructueux ( http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/df3eb89e-685d-4a87-a1c7-9e3e7e5cb27e ) !

    J'ai effectué la modification suggérée, et la file d'attente s'est immédiatement vidée après un refresh !

    J'attends maintenant le retour du message du destinataire qui gère son compte à distance pour confirmer tout cela !

    Pour ceux que cela pourrait interesser, effectivement, dans l'EMC il n'y a RIEN qui permette de modifier le port par défaut des Send Connectors !

    Il faut passer par l'EMS pour opérer des modifications...

    Je ne suis pas un fondu de la ligne de commandes, je l'utilise quand cela est vraiment nécessaire, et je continue de me demander quel est l'intérêt d'effectuer cela de façon archaïque alors qu'une simple case (tout comme pour d'autres sections où l'on peut affecter un port différent !) avec le port pourait être affichée...
    Tout le monde n'a pas 400 serveurs à scripter M. Microsoft !
    Laissez au moins l'alternative "graphique" quand il n'y a pas plus d'opérateurs à fournir et ceux qui veulent continuer d'utiliser la ligne de commandes pourront le faire à satiété...
    Enfin bref...

    Voici les opérations possibles en ce qui concerne mon problème qui manifestement se retrouve à l'international, ce qui n'a rien de surprenant puisqu'il consiste à reprendre le port par défaut du "Receipt Connector" par le F.A.I ( http://forums.msexchange.org/m_1800467895/mpage_1/key_/tm.htm#1800467906 ):

    Unfortunately, there isn’t a nice way to set the Send Connector port in the Exchange Management Console (I am sure that you don’t hear this for the first time ).

    Open Exchange Management Shell and start by checking your Send Connector(s) :

       Get-SendConnector

    You should get the name of your send connector(s) – like “Default Send Connector”.

    If you haven’t messed up with the port configuration of the connector yet, it should be using the default port -25.
    It is a good idea to confirm this with the command:

       Get-SendConnector | fl port

    Then change the port with the command:

       Set-SendConnector –Identity “Your Send Connector Name” -Port 587

    If you have only one Send Connector you can use that command too:

       Get-SendConnector | Set-SendConnector -Port 587

    Of course, it is a good idea to check the final result again with:

       Get-SendConnector | fl port

    Or even take a look at the full listing for the send connector:
    Get-SendConnector | fl

    Regards,

    Dean

    Voilà, cela me semble un bon point de départ et je ne vois pas pourquoi cela ne fonctionnerait pas puisque pour moi c'était la raison la plus probable du blocage du message dans la file d'attente !

    Un grand merci à Jon-Alfred Smith pour ses "tips" très interessants !

    Bien amicalement,

    Philippe.
    dimanche 21 février 2010 08:47