none
Exchange Server 2016 - OWA Erreur - ASP.NET 1309 - Event Code 3005 - Impossible de charger le type Microsoft.Exchange.Services.GlobalSettings RRS feed

  • Question

  • Bonjour;

    Quelqu'un aurait des pistes pour résoudre ce problème?

    Merci.

    OWA ne fonctionne plus : "Nous avons rencontré un problème" après la connexion.

    ECP focntionne.

    Le serveur a déjà été redémarré et le répertoire virtuel OWA déjà reinitialisé/supprimé/recrée.

    Aucune ligne concernant cette assembly dans le webconfig.

    Détails :

    Serveur info : Windows Serveur 2012R2 - Exchange 2016 CU 22

    Application Log : Avertissment - Source : ASP.NET 4.0.30319.0 - ID : 1309 - Categorie : Web Event

    Event code: 3005
    Event message: Une exception non gérée s'est produite.
    Event time: 26/11/2021 17:16:08
    Event time (UTC): 26/11/2021 16:16:08
    Event ID: bc4c518171d449eea8cc5f699b6ff0ea
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0

    Application information:
        Application domain: /LM/W3SVC/2/ROOT/owa-9-132824169609246309
        Trust level: Full
        Application Virtual Path: /owa
        Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\
        Machine name: SRV

    Process information:
        Process ID: 17432
        Process name: w3wp.exe
        Account name: AUTORITE NT\Système

    Exception information:
        Exception type: HttpException
        Exception message: Impossible de charger le type 'Microsoft.Exchange.Services.GlobalSettings' à partir de l'assembly 'Microsoft.Exchange.Services, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
       à System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app)
       à System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       à System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       à System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       à System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Impossible de charger le type 'Microsoft.Exchange.Services.GlobalSettings' à partir de l'assembly 'Microsoft.Exchange.Services, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
       à Microsoft.Exchange.Clients.Owa2.Server.Core.BaseApplication.ExecuteApplicationStart(Object sender, EventArgs e)
       à Microsoft.Exchange.Clients.Owa2.Server.Core.Global.Application_Start(Object sender, EventArgs e)



    Request information:
        Request URL: https://SRV.DOM.com:444/owa
        Request path: /owa
        User host address: ::1
        User:  
        Is authenticated: False
        Authentication Type:  
        Thread account name: AUTORITE NT\Système

    Thread information:
        Thread ID: 39
        Thread account name: AUTORITE NT\Système
        Is impersonating: False
        Stack trace:    à System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app)
       à System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       à System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       à System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       à System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)


    Custom event details:

            
    vendredi 26 novembre 2021 17:06

Toutes les réponses

  • Bonjour ncoutinho,

    Merci d'avoir sollicité la communauté TechNet France.

    Pouvez-vous nous communiquer le niveau de CU de votre Exchange 2016 ? 

    Dans l'éventualité ou vous ne seriez pas up to date je vous invite à mettre à jour votre Exchange au plus vite pour des questions de sécurité et de vulnérabilité.

    Voici un lien qui reprend les cumulatives disponibles ainsi  qu'un autre lien du Blog Exchange :

    Voici également un lien forum qui traite d'une erreur similaire à la votre et qui serait relative à un souci de vulnérabilité

    Si tel est le cas je vous invite à utiliser les scripts pour vérifier la santé de votre environnement disponibles dans l'article suivant: 

    A bientôt

    Alexis

     



    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni « tel quel » et il n'implique aucune responsabilité de la part de Microsoft. S'il vous plaît n'oubliez pas de « Marquer comme réponse » les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile l’accès aux solutions.


    samedi 27 novembre 2021 11:14
    Modérateur
  • Si votre environnement est bien à jour voici deux autres liens qui traitent du même souci et qui proposent une solution :

    A bientôt

    Alexis


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni « tel quel » et il n'implique aucune responsabilité de la part de Microsoft. S'il vous plaît n'oubliez pas de « Marquer comme réponse » les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile l’accès aux solutions.



    dimanche 28 novembre 2021 15:51
    Modérateur
  • Bonjour,

    Merci pour vos réponses.

    Tout est bien à jour, c'est depuis l'application de la CU 22 et des 2 correctifs que nous avons le problème.
    Aucune des informations fournies par Microsoft et par d'autres personnes sur des problèmes "similaires" à ce jour, règle notre problème.

    Une librairie bien particulière semble être la cause de notre problème :
    Exception message: Impossible de charger le type 'Microsoft.Exchange.Services.GlobalSettings' à partir de l'assembly 'Microsoft.Exchange.Services, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.

    DependentAssemblyGenerator ne corrige pas le problème.
    Le script EOMT m'informe qu’aucune faille n'a été trouvée.
    Le HealthChecker m'informe que tout est OK.

    Nous avons bien suivi vos liens, ces actions ont déjà été effectuées plusieurs fois, sans résoudre notre problème.

    Contrairement à beaucoup, nous n'avons qu'un problème sur OWA et non sur ECP.

    lundi 29 novembre 2021 10:51
  • Merci pour ce retour

    Pouvez vous essayer les solutions proposées dans le thread suivant ? 

    A bientôt

    Alexis


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni « tel quel » et il n'implique aucune responsabilité de la part de Microsoft. S'il vous plaît n'oubliez pas de « Marquer comme réponse » les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile l’accès aux solutions.

    lundi 29 novembre 2021 11:11
    Modérateur
  • Le certificat est encore valide pour un an (certificat de deux ans).

    Je n'ai pas refait de modifications spéciales du schéma :
        Exchange 2016 version     rangeUpper     objectVersion(Default)     objectVersion(Configuration)
        Exchange 2016 CU22            15334                     13242                                  16222
    Mes valeurs correspondent à celles spécifiées ci-dessus par Microsoft.
    Me conseillez-vous d'autres vérifications du schéma ?

    Lors de l’exécution du module de réécriture d'URL, celui-ci me spécifie "installé", 0 élément à installer.

    Les fichiers SharedWebConfig sont présents, ils ont déjà été reconstruits, sans résultat.

    lundi 29 novembre 2021 13:21
  • Merci pour ce retour

    Dans un premier temps j'essaierai de générer un nouveau certificat. 

    Vous pouvez également tester l'article MS suivant: 

    En ce qui concerne la version du Schéma AD elle semble ok :

    Source: Préparer Active Directory et les domaines pour Exchange Server

    A bientôt

    Alexis


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni « tel quel » et il n'implique aucune responsabilité de la part de Microsoft. S'il vous plaît n'oubliez pas de « Marquer comme réponse » les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile l’accès aux solutions.

    lundi 29 novembre 2021 13:55
    Modérateur
  • Vous pouvez également testé la solution proposée ci-dessous 

    Source: Error in ECP and OWA after update

    A bientôt

    Alexis


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni « tel quel » et il n'implique aucune responsabilité de la part de Microsoft. S'il vous plaît n'oubliez pas de « Marquer comme réponse » les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile l’accès aux solutions.

    lundi 29 novembre 2021 14:25
    Modérateur
  • Bonjour ncoutinho,

    Avez-vous avancé dans votre problématique ?

    N'oubliez pas de marquer comme réponse les propositions des intervenants qui vous ont amené à la solution du problème.

    Je vous remercie par avance pour votre retour.

    Cordialement,

    Alexis


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni « tel quel » et il n'implique aucune responsabilité de la part de Microsoft. S'il vous plaît n'oubliez pas de « Marquer comme réponse » les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile l’accès aux solutions.

    lundi 6 décembre 2021 06:46
    Modérateur