none
Changer image de l'utilisateur

    Discussion générale

  • Bonjour a tous,

    Je souhaite changer l'image ci-dessous:

    J'ai donc: 

    Créer une image au format .bmp qui ne fait pas plus de 128*128

    Mis en place une GPO qui copie :

    Source : \\XXXXX.yyy.local\Script\user.bmp

    Destination : %programdata%\Microsoft\User Account Pictures\user.bmp

    J'ai bien mis "Remplacer" et non pas Ajouter

    Activé la GPO : Appliquer l’avatar de compte par défaut à tous les utilisateurs

    Malgrès cela, le fichier n'est pas copié.Pourtant j'ai essayé de remplacer manuellement le user.bmp, et cela fonctionne normalement, mais quand je le fais en GPO, cela ne fonctionne pas.

    Une idée ?

    jeudi 17 août 2017 20:13

Toutes les réponses

  • Bonjour axel5i,

    Veuillez consulter l'article suivant :
    Personnalisation de Windows – Branding (partie Personnaliser l’écran d’ouverture de session de Windows).

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 18 août 2017 12:20
    Modérateur
  • Merci pour ton retour.

    J'ai bien fait tout cela, mais cela ne fonctionne toujours pas.

    J'ai l'impression que c'est la copie qui bloque car je me connecter avec un utilisateur sans droits admin.

    vendredi 18 août 2017 14:17
  • Il suffit de faire un clic droit propriété et voir l'onglet sécurité pour s'en assurer

    Les utilisateurs n'ont pas le droits de modifications donc si tu tentes de faire le remplacement de l'image dans la partie utilisateur de ta GPO, ca ne fonctionnera pas.Il faut utiliser la partie machine.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    vendredi 18 août 2017 14:23
  • Il suffit de faire un clic droit propriété et voir l'onglet sécurité pour s'en assurer

    Les utilisateurs n'ont pas le droits de modifications donc si tu tentes de faire le remplacement de l'image dans la partie utilisateur de ta GPO, ca ne fonctionnera pas.Il faut utiliser la partie machine.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    Sur quel répertoire, je dois faire propriétés ? Si c'est sur mon répertoire partagé, j'ai bien les droits en écriture.

    Sinon, ma GPO est bien une GPO "Ordinateur".

    vendredi 18 août 2017 14:39
  • Faites un rsop et vérifier déjà que la gpo s'applique correctement.

    Ensuite faites un gpupdate /force et vérifier l'état des alertes dans le journal des evenements.

    Normalement cela devrait vous donner l'axecdu peobleme et vous permettre d'identifier la solution.

    samedi 19 août 2017 08:57
  • Faites un rsop et vérifier déjà que la gpo s'applique correctement.

    Ensuite faites un gpupdate /force et vérifier l'état des alertes dans le journal des evenements.

    Normalement cela devrait vous donner l'axecdu peobleme et vous permettre d'identifier la solution.

    Quand j'ai fait un rsop, j'ai obtenu un message d'erreur (J'ai lancé le rsop depuis une session Utilisateur sans droits admin).

    Ce qui m'étonne c'est que j'ai très peu de résultats pour ma gpo ordinateur ou j'ai 4 copie de fichiers.


    • Modifié axel5i mercredi 23 août 2017 12:24
    samedi 19 août 2017 19:54
  • Faites un rsop et vérifier déjà que la gpo s'applique correctement.

    Ensuite faites un gpupdate /force et vérifier l'état des alertes dans le journal des evenements.

    Normalement cela devrait vous donner l'axecdu peobleme et vous permettre d'identifier la solution.

    Quand j'ai fait un rsop, j'ai obtenu un message d'erreur (J'ai lancé le rsop depuis une session Utilisateur sans droits admin).

    Ce qui m'étonne c'est que j'ai très peu de résultats pour ma gpo ordinateur ou j'ai 4 copie de fichiers.


    up
    • Modifié axel5i mercredi 23 août 2017 12:23
    mardi 22 août 2017 18:47
  • Il y a deux étapes pour que cette configuration fonctionne :

    1. la nouvelle image doit remplacer l'existante
    2. le poste doit être forcé à utiliser la nouvelle image

    Pour le point 1 :

    • vérifier que le fichier présent dans %programdata%\Microsoft\User Account Picutes soit le bon. Ce remplacement doit être initié depuis la stratégie computer, ce qui implique que le compte ordinateur doit pouvoir accéder aux partages (droits sur domain users ou domain computers)

    Pour le point 2 :

    • vérifier que la stratégie Computer Configuration / Administrative Templates / Control Panel / User Accounts / Apply the default user logon picture to all users soit activée.


    Cdt, Loïc V. - Active Directory Expert - Blog: http://ms-sec.fr






    mercredi 23 août 2017 05:36
  • Il y a deux étapes pour que cette configuration fonctionne :

    1. la nouvelle image doit remplacer l'existante
    2. le poste doit être forcé à utiliser la nouvelle image

    Pour le point 1 :

    • vérifier que le fichier présent dans %programdata%\Microsoft\User Account Picutes soit le bon. Ce remplacement doit être initié depuis la stratégie computer, ce qui implique que le compte ordinateur doit pouvoir accéder aux partages (droits sur domain users ou domain computers)

    Pour le point 2 :

    • vérifier que la stratégie Computer Configuration / Administrative Templates / Control Panel / User Accounts / Apply the default user logon picture to all users soit activée.


    Cdt, Loïc V. - Active Directory Expert - Blog: http://ms-sec.fr






    Merci pour ton retour.

    Point 1 : Mon fichier n'est même pas copié, je soupçonne un problème de droits (j'ouvre une session avec un compte utilisateur sans droits admin).

    Pourtant ma GPO est une GPO "Ordinateur"

    Point 2 : C'est bien activé.

    jeudi 24 août 2017 11:41
  • Normalement, sur la tentative de copie, l'échec doit générer une erreur dans le journal des évènements. Il faudrait vérifier. D'autre part, je remplacerait %programdata% par le vrai chemin (je ne suis pas sur que le système connaisse cette variable).

    Cdt, Loïc V. - NetSec Design - Blog: http://ms-sec.fr

    jeudi 24 août 2017 12:47
  • Normalement, sur la tentative de copie, l'échec doit générer une erreur dans le journal des évènements. Il faudrait vérifier. D'autre part, je remplacerait %programdata% par le vrai chemin (je ne suis pas sur que le système connaisse cette variable).

    Cdt, Loïc V. - NetSec Design - Blog: http://ms-sec.fr

    J'ai remplacé la valeur %programdata% par le chemin exact, mais aussi contrôlé le journal d'événements, et j'ai rien trouvé.

    Malgrès cela, cela ne fonctionne pas.

    dimanche 27 août 2017 16:59
  • Personne pour m'aider ?
    mardi 19 septembre 2017 20:21
  • Bonjour axel5i,

    Des solutions complémentaires sont proposées ici.
    Comme matteu31400 a marqué dans son commentaire: "Les utilisateurs n'ont pas le droits de modifications donc si tu tentes de faire le remplacement de l'image dans la partie utilisateur de ta GPO, ca ne fonctionnera pas.Il faut utiliser la partie machine." Votre compte doit disposer des droits nécessaires, pour pouvoir appliquer la variété des solutions déjà présentes.
    Peut-être le thread suivant vous sera aussi utile :
    Wallpaper in Windows 7 locked down by domain group policy?

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mercredi 20 septembre 2017 09:31
    Modérateur