none
Connecter une boite aux lettres Exchange a un autre user AD ? RRS feed

  • Question

  • Bonsoir,

    L'utilisateur Paul Lefebvre dispose d'un compte AD "user01" et d'une adresse mail : "paul.lefebvre@maboite.fr" (Exchange 2010)

    Un second compte AD "user02" lui a été affecté sans boîte aux lettres.

    Le but est d'associer la bal "paul.lefebvre@maboite.fr" au compte AD : "user02".

    1) Pouvez-vous me confirmer qu'il faut lancer la commande suivante :

    Connect-Mailbox -Identity "paul.lefebvre" -Database MBXDB01 -User user02 

    2) Quels sont les risques? Corruption de boite aux lettres si la taille est trop importante ? Y a t-il des bonnes pratiques pour éviter les "drames"?

    3) En supprimant le compte Ad "user01", je suppose que la boite aux lettres restera associée à user02 ?

    Merci !





    • Modifié Amstrad44 mardi 2 avril 2019 18:16
    mardi 2 avril 2019 18:06

Toutes les réponses

  • Bonsoir,

    1) Non,

    il faut d'abord désactiver la boite de "user1" avant de pouvoir l'affecter à un autre utilisateur qui ne doit PAS avoir de boite.

    disable-mailbox user01

    Ensuite, il faut forcer la mise à jour de ce statut sur la base contenant cette boite:

    clean-mailboxdatabase DatabaseQuiContenaitUser01

    Ensuite seulement, on peut réassocier cette boite à un nouvel utilisateur avec la commande connect-mailbox

    2) pas de risque de corruption. Les permissions sont bien réinitialisées pour le nouvel utilisateur.

    3) Si les opérations précédentes ont été réalisées. User01 n'a plus de boite.

    Si l'on utilise la commande "Remove-mailbox" en 1), alors le compte et la boite sont supprimés en une seule opération. Le compte "user01" n'est plus utilisable. En revanche, sa boite reste récupérable et connectable par défaut pendant 30 jours à tout autre compte.

    A bientôt,


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(85 MCPs). MCSA Office 365 http://base.faqexchange.info

    mardi 2 avril 2019 20:35
    Modérateur
  • Merci Thierry, j'avais bien lu qu''il fallait désactiver la boite/ Par contre, c'est le clean-mailbox que j'avais oublié ...

    Est-il possible de confirmer que ce n'est pas possible de le faire graphiquement via la console ? On a cherché, en vain..

    Je vais tenter les manips demain!

    Merci


    • Modifié Amstrad44 mercredi 3 avril 2019 01:47
    mercredi 3 avril 2019 01:40
  • Sur Exchange 2010, on peut connecter graphiquement la boite "désactivée" à un compte "sans boite".

    En revanche, la seule opération qu'il n'est pas possible de faire directement dans l'interface graphique est le "clean-mailbox".

    => En revanche, on peut démonter et remonter la banque d'info dans l'interface, ce qui provoquera la mise à jour du statut. (Si peu ou pas d'utilisateurs connectés à cette banque).

    Remarque, on peut aussi déplacer la boite dans une banque vide (ou créée pour l'occasion), afin de n'impacter personne d'autre.

    A+


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(85 MCPs). MCSA Office 365 http://base.faqexchange.info

    mercredi 3 avril 2019 06:44
    Modérateur
  • J'ai lancé les 3 commandes mais lorsque je lance le connect mailbox, j'ai le message d'erreur : "La boite aux lettres specifiée jean.dupont n'existe pas dans la base de données "x"...

    C'est comme si lorsque je desactive la boite, celle ci n'est plus trouvée dans la bdd... :-/

    mercredi 3 avril 2019 07:43
  • Le nom que vous utilisez ne correspond peut être pas !

    Vérifier la liste des boites déconnectées avec les commandes indiquées ici:

    https://practical365.com/exchange-server/reconnect-disconnected-mailbox-exchange-server-2010/

    Sinon, vous devez trouver dans l'interface graphique 2010 l'affichage des boites déconnectées...

    Il y aura l'option "reconnecter" sur la boite afin de sélectionner le compte recevant cette boite.

    A+


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(85 MCPs). MCSA Office 365 http://base.faqexchange.info

    mercredi 3 avril 2019 07:52
    Modérateur
  • Justement, après avoir désactivé la boite mail, elle n'apparait pas dans les bals deconnectées.

    Au moment de la désactivation, je reponds oui au message suivant :

    "La désactivation de la bal entrainera la suppression des propriétés Exchange dans l'objet Utilisateur Windows, et marquera la boite aux lettres pour qu'elle soit supprimée de la base de données. Si la boite aux lettre dispose d'une archive ou d'une archive distante, elle sera egalement marquée pour suppression. S'il s'agit d'une archive distante, la suppression sera definitive. Vous ne pourrez plus reconnecter cet utilisateur à l'archive distante."[O] Oui [T] Oui pour tout [N]..

    J'ai créé des nouvelles bals pour test et éviter de bloquer l'utilisateur et à chaque fois je ne la retrouve pas dans les boites deconnectées (que ce soit via l'interface graphique ou la ligne de commande).

    Merci pour votre aide!!:(

    mercredi 3 avril 2019 09:22
  • Justement, après avoir désactivé la boite mail, elle n'apparait pas dans les bals deconnectées.

    Au moment de la désactivation, je reponds oui au message suivant :

    "La désactivation de la bal entrainera la suppression des propriétés Exchange dans l'objet Utilisateur Windows, et marquera la boite aux lettres pour qu'elle soit supprimée de la base de données. Si la boite aux lettre dispose d'une archive ou d'une archive distante, elle sera egalement marquée pour suppression. S'il s'agit d'une archive distante, la suppression sera definitive. Vous ne pourrez plus reconnecter cet utilisateur à l'archive distante."[O] Oui [T] Oui pour tout [N]..

    J'ai créé des nouvelles bals pour test et éviter de bloquer l'utilisateur et à chaque fois je ne la retrouve pas dans les boites deconnectées (que ce soit via l'interface graphique ou la ligne de commande).

    Merci pour votre aide!!:(

    Il Bonjour,

    Pour les BAl de test , il faut que la BAL ne soit pas vide pour pouvoir la retrouver dans les BAl déconnectées


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    mercredi 3 avril 2019 09:38
    Modérateur
  • Alleluiaaaaaaaaaaaaaaa!!! ppfff des heures que je me prends la tête alors qu'il suffisait que j'adresse juste un mail!!

    C'est bon, elle apparait bien dans les deconnectées !

    MERCI !!!

    p.s: Dire que si j'avais voulu tester direct en prod, cela aurait fonctionné!

    mercredi 3 avril 2019 09:48
  • Bon... Après mon Connect-Mailbox, j'ai eu le message : "L'opération a été effectuée avec succès, mais la modification ne prendra effet qu'après la réplication Active Directory".

    1) Je me suis connecté avec l'user qui récupère la boite aux lettres. Quand je lance Outlook, j'ai : "Impossible d'ouvrir vos dossiers de messagerie par defaut. Vous devez vous connecter à Microsoft Exchange avec le profil actuel avant de pouvoir synchroniser vos dossiers avec votre fichier de données Outlook (.ost)."

    2) Dans la liste des bals désactivées, ma boite aux lettres y figure tjs.

    Quand j'ouvre OWA via le nouveau compte, j'ai le message : " Votre compte a été desactivé".

    Merci





    • Modifié Amstrad44 mercredi 3 avril 2019 12:59
    mercredi 3 avril 2019 12:21
  • Bonjour,

    est-ce que vous utilisez la commande "client-mailboxdatabase" après chaque désactivation de boite? (ou un démontage/remontage de la banque correspondante).

    Sinon, il faut attendre... que les données/Info AD soient mises à jour dans le cache d'Annuaire d'Exchange.

    A+


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(85 MCPs). MCSA Office 365 http://base.faqexchange.info

    mercredi 3 avril 2019 14:44
    Modérateur
  • Client ? Clean-mailboxdatabase plutôt ?

    J'en ai fait un après la desactivation de mon compte test(Disable puis clean-mailboxdatase et un connect).

    Cela fait plus de 5h que j'ai réalisé la manip pour une bal de 2 mails...:-/ et j'ai tjs "votre compte est désactivé" sous OWA.  Je crains qu'il n'y ait autrechose.

    - Il n'y a pas de logs qui permettraient d'avoir des infos ?

    - Le Get-mailboxStatistics du compte (initialement sans bal) me renvoie le display name et l'alias du compte qui était attachée à la bal initiale.

    - Comme la boite apparaissait tjs dans les "bals deconnectées", j'ai voulu (cette fois graphiquement) la connecter à un autre user. J'ai obtenu un échec qui m'indiquait qu'elle etait déjà connectée à l'utilisateur rattaché ce midi...

    Merci


    • Modifié Amstrad44 mercredi 3 avril 2019 15:33
    mercredi 3 avril 2019 15:25
  • Nouveau test : là j'ai refait un cleanmailboxdatabase, la connexion est ok!! youpiii

    donc il faut le faire aussi après un connect mailbox ?

    Merci beaucoup

    mercredi 3 avril 2019 15:36