none
Membres Groupes distributions Exchange 2010 RRS feed

  • Question

  • Bonjour,

    voici mon problème:

    Masquer tous les membres d'un groupe de distribution sous Exchange 2010, pour les autres membres.

    Par exemple une personne fait parti d'un grp Test1 ,Test2 et Test3.

    Je veux que cette personne ne soit pas visible que dans le grp Test1 , par les autres utilisateurs Exchange.

    j'èspère que je me suis bien expliqué?!

    Merci d'avance.

    jeudi 11 juillet 2013 14:47

Réponses

  • Bonjour

    vous créez le user dans le grp 1 avec l'option "Creating a Dynamic Distribution Group in Exchange 2007" meme chose que 2010

    http://www.youtube.com/watch?v=VsCxjebYmGE

    slts


    Partager c'est avancer : Votez!SVP

    lundi 15 juillet 2013 09:32
  • Ce n'est pas possible directement, vous pouvez cependant réaliser l'astuce suivante :

    • Créer une boite aux lettres au nom de votre groupe de distribution
    • Créer un groupe de distribution masqué dans l'AD
    • Ajouter le groupe de distribution en redirection de la boite aux lettres.

    Les utilisateurs ne verront que la partie boite aux lettres et non pas les membres distribués.

    Vous pouvez aussi créer un groupe de distribution dynamique à la place d'un groupe statique.


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr

    vendredi 12 juillet 2013 08:43
    Modérateur

Toutes les réponses

  • Ce n'est pas possible directement, vous pouvez cependant réaliser l'astuce suivante :

    • Créer une boite aux lettres au nom de votre groupe de distribution
    • Créer un groupe de distribution masqué dans l'AD
    • Ajouter le groupe de distribution en redirection de la boite aux lettres.

    Les utilisateurs ne verront que la partie boite aux lettres et non pas les membres distribués.

    Vous pouvez aussi créer un groupe de distribution dynamique à la place d'un groupe statique.


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr

    vendredi 12 juillet 2013 08:43
    Modérateur
  • Bonjour

    vous créez le user dans le grp 1 avec l'option "Creating a Dynamic Distribution Group in Exchange 2007" meme chose que 2010

    http://www.youtube.com/watch?v=VsCxjebYmGE

    slts


    Partager c'est avancer : Votez!SVP

    lundi 15 juillet 2013 09:32
  • Bonnjour TechExploit,

    des nouvelles svp?

    merci


    Partager c'est avancer : Votez!SVP

    mercredi 17 juillet 2013 13:17
  • Bonjour à tous,

    désolé de répondre que maintenant.

    j'ai mis ce dossier de coté ces derniers jours, pour des choses plus urgentes.

    je vais essayer de faire les tests soit demain soit début de semaine pro.

    Merci à ceux qui m'ont répondu.

    jeudi 18 juillet 2013 14:43
  • Salut à tous,

    Hier soir j'ai essayé de faire quelques tests par contre j'ai du mal à comprendre,Je suis vraiment novice sur Exchange......

    @Nabil-IT ,

    A voir ta solution est plus rapide que Bruce JDC.

    Mais si je pouvez avoir un peu plus d'explication.car j'ai fait des recherches sur les groupe de distribution dynamique, et j'ai bien lu noir sur blanc que cela permettait de masquer des adresses mails dans ce groupe mais aucune explications.

    Ou sinon un tableau avec plusieurs Attributs, mais aucun me semble convenir.Je ne retrouve plus le site.....

    @Bruce JDC,

    • Créer une boite aux lettres au nom de votre groupe de distribution

    Ok , tu parles bien du groupe existant dans lequel les mails des agents doivent être masqué?ou je dois d'abord créer un nouveau groupe?

    • Créer un groupe de distribution masqué dans l'AD

    Alors je savais faire ,masquer un utilisateur dans l'AD avec server 2003.Mais c'était il y a longtemps.j'ai fais des recherches sur le net, je n'ai pas trouvé la soluce.

    • Ajouter le groupe de distribution en redirection de la boite aux lettres.

    Je dois rediriger le groupe du 1er point ou le groupe masqué créé dans l'AD?

    Aussi comment redirige t-on un groupe de distribution vers une adresse mail.Ce que j'ai fait dans le grp de distrib, onglet "Adresses de messageries" j'ai ajouté l'adresse mail de la boite au lettre précédemment créée et la j'ai un message d'erreur:

    "L'adresse proxy "smtp:adresse mail" est déja utilisé ......"

    Merci encore pour l'aide apportée!

    vendredi 19 juillet 2013 08:12
  • Bonjour TechExploit

    désolé weekend vendredi et samedi

    Si je me trompe pas sur exchange 2003 il y avait effectivement l’option pour masquer les suer il fallait juste installer la console administration  Exchange sur une machine on trouver les attributs exchange sur les user sur la console AD,mais sur exchange 2010 je pense que ce n’est pas supporté d’où l’option di distribution dynamique

    imprime ecran sur la version exchnage 2003

    avez vous vue les liens

    http://technet.microsoft.com/fr-fr/library/bb123722(v=exchg.141).aspx

    http://technet.microsoft.com/fr-fr/library/bb124560(v=exchg.141).aspx

    http://www.youtube.com/watch?v=VsCxjebYmGE

    test fait sur un groupe

    TESTDYNAMICgrp@my domain,

    avec les user membres’Exchange.cst02 orn02 orn02 test et test 01’  ( user de test , l’ajout a été fait avec propriété du userèAnglet Custom Attributes… exemple attribue Admintest, Admintest1 & Admintest2

    j'espere que c'est claire

    mes salutations


    Partager c'est avancer : Votez!SVP

    dimanche 21 juillet 2013 09:29
  • imprime ecran du test


    Partager c'est avancer : Votez!SVP

    dimanche 21 juillet 2013 09:31
  • bonjour

    il y a une option mais se n'est pas supporté mais a testé comme meme :)

    http://exchangepedia.com/2007/11/how-to-hide-distribution-group-membership.html

    http://social.technet.microsoft.com/Forums/exchange/en-US/e261e4ef-6e57-4424-8782-cd3f1930898e/need-unique-name-when-hiding-distribution-group-members-in-exchange-2007

    en ligne de commande

    Add-ADPermission “Distribution Group Name” -user “User or Security Group Name” -Deny -AccessRights ReadProperty -Properties Member

    Get-ADPermission “Distribution Group Name” | where {$_.Properties -like “member”} | fl

    Remove-ADPermission “Distribution Group Name” -user “User/Security Group Name” -Deny -AccessRights ReadProperty -Properties Member


    Partager c'est avancer : Votez!SVP

    • Proposé comme réponse Nabil-IT lundi 22 juillet 2013 13:09
    dimanche 21 juillet 2013 09:35
  • désolé mais je ne peux pas copier plus deux images d'ou mes reponses :(


    Partager c'est avancer : Votez!SVP

    dimanche 21 juillet 2013 09:36
  • Bonjour TechExploit

    des news?

    merci


    Partager c'est avancer : Votez!SVP

    lundi 22 juillet 2013 13:09
  • Salut Nabil-IT,

    Déjà merci pour tes réponses.

    je vais bien lire tout ça et reposterai après mes tests.

    Cordialement,

    lundi 22 juillet 2013 13:31
  • A votre service :)

    Partager c'est avancer : Votez!SVP

    lundi 22 juillet 2013 13:33
  • Salut,

    donc j'ai testé un peu tout ça!

    1-quand j'utilise des groupes de distribution dynamique , je n'arrive pas à ajouter des personnes dans le groupe en utilisant un attribut commun.Les personnes n'apparaissent pas lorsque je clique sur "Aperçu" .

    2-je suis donc passé par la solution d'un groupe de distrib normal mais en jouant sur les autorisations dans l'AD, et le résultat est que si je mets "tout le monde" avec comme autorisation refuser de "lire membres", les membres de ce groupe sont toujours visible dans le webmail lorsque l'on double clique sur ce groupe.

    Mais quel est le rapport d'un groupe de distrib dynamique avec le fait que l'on peut masquer les personnes de ce groupe en jouant avec les attributs?

    Car j'ai bien compris le système d'attributs.Par exemple dans un gpr dyn , il n'y aura que les pers auquel j'ai ajouté le même attribut!!

    mercredi 24 juillet 2013 09:20
  • Salut tech

    avez vous essayer en ligne de commande

    http://exchangepedia.com/2007/11/how-to-hide-distribution-group-membership.html

    http://social.technet.microsoft.com/Forums/exchange/en-US/e261e4ef-6e57-4424-8782-cd3f1930898e/need-unique-name-when-hiding-distribution-group-members-in-exchange-2007

    en ligne de commande car sur mes lab's ça a bien fonctionné comme l'imrime ecran daté dimanche 21 juillet 2013 09:36 l'indique

    Add-ADPermission “Distribution Group Name” -user “User or Security Group Name” -Deny -AccessRights ReadProperty -Properties Member

    Get-ADPermission “Distribution Group Name” | where {$_.Properties -like “member”} | fl

    Remove-ADPermission “Distribution Group Name” -user “User/Security Group Name” -Deny -AccessRights ReadProperty -Properties Member


    Partager c'est avancer : Votez!SVP

    • Proposé comme réponse Nabil-IT jeudi 25 juillet 2013 08:51
    mercredi 24 juillet 2013 09:25
  • Voici ce que j'obtiens , en ligne de commande

    en double cliquant sur le groupe, je vois toujours le membre "membre de ce groupe"

    j'ai bien été vérifier dans l'AD , les autorisations effective du groupe AD "tout le monde", et ce gpr n'a aucun n'accès.Rien est coché.....

    mercredi 24 juillet 2013 13:45
  • Bonjour teck

    je vois sur ta commande -iuser 'tout le monde" essaye la commande avec le -user alphone brown

    Add-ADPermission “GRPDISTRIB” -user "alphone brown " -Deny -AccessRights ReadProperty -Properties
    Member

    SLTS


    Partager c'est avancer : Votez!SVP

    mercredi 24 juillet 2013 13:52
  • Je viens de faire un autre test.

    Au lieu d'utiliser le grp "tout le monde" je viens de faire la même chose avec le grp "Utilisateurs".Donc pareil ,vérification des autorisations effectives et rien n'est coché.

    en dble cliquant , dans le webmail, sur le grp je vois toujours le membre mais voici ce que j'obtiens dans les propriétés du groupe:

    Je précise bien qu'après pour vérifier dans le webmail, j'utilise ma propre adresse mail qui le nom AD fait bien parti du groupe "tout le monde" donc cela devrait fonctionner.

    Ah oui autre chose, je sais plus comment j'ai mis les autorisations une fois mais j'ai réussit à cacher le groupe de distri dans le webmail.c'est à dire que si on le cherchait en écrivant les 1ere lettres et en cliquant sur "vérifier les noms" il ne s'affchait pas.Je pense qu'en autorisation j'avais explicitement "refuser" à lire.

    OK j'essaie seulement avec Alphonse Brown.je te dis quoi tout de suite.....

    mercredi 24 juillet 2013 14:08
  • Ca fait exactement la même chose!

    mais en même temps je fais parti du groupe "Admin du domaine" donc je pense que c'est normal que je puisse lire le contenu vu que dans les autorisations AD du groupe de distrib je peux tout lire...

    Je recréé un autre utilisateur test.

    mercredi 24 juillet 2013 14:17
  • Bon j'ai recréé un utilisateur test tout simple.

    Pour les autorisations du groupe de distrib j'ai cliqué sur "avancé" ,dans l'onglet "Autorisations" j'ai décoché la case "Inclure les autorisations pouvant être héritées du parents de cet objet".

    Il me reste plus que :

    SELF

    Systeme

    Admin du Domaine

    Opérateurs de compte

    Grouped'accès d'autorisation windows

    J'ai ajouté "tout le monde" avec des autorisations spéciales explicites et j'en suis arrivé en me connectant sur le webmail avec mon utilisateur test , à ne plus voir le groupe.....

    En fait c'est une simple question d'autorisation, il faut juste trouver la bonne lol

    mercredi 24 juillet 2013 14:34
  • Bonjour

    donc c'est réglé ?

    slts


    Partager c'est avancer : Votez!SVP

    jeudi 25 juillet 2013 08:51
  • Salut Nabil-IT,
    Je cherche toujours la bonne combinaison des autorisations.
    Sinon une solution alternative est de cacher le groupe complet dans la GAL et la tout est caché.....

    En tout cas merci de ton aide !
    vendredi 26 juillet 2013 08:01