none
Requête valide ne s'exécutant pas dans report builder 3.0 RRS feed

  • Question

  • Bonjour,
    Je suis confronté à un problème bizarre,
    j'ai un serveur ssrs en mode intégré sharepoint et une grosse requête qui marche dans management studio, et dans le concepteur de requête de report builder, avec un temps d'exécution d'environ 1mn.
    le problème c'est que lorsque dans report builder, j'essai de créer le dataset (bouton ok dans le concepteur de requête), au bout de 35 seconde il renvoie le message d'erreur suivant :

    "Impossible de mettre à jour une liste de champs pour la requête. Vérifier que vous pouvez vous connecter à la source de données et que la syntaxe de votre requête est correcte"

    "ExecuteReader nécessite une connexion ouverte et disponible. La connexion est actuellement fermée."

    Je re précise que dans le concepteurs de requête lors de la création du dataset, la requête s'exécute, certes longuement (1 mn) mais elle s'exécute preuve qu'elle est valide et qu'une connexion est bien disponible

    Pouvez vous m'aider à décanter ce problème
    merci
    lundi 18 mars 2013 13:12

Réponses

  • Merci pour vos réponses, j'ai voulu faire un test avec 'SET FMTONLY ON;', mais avant et juste pour être sûre j'ai encore tenté de créer le dataset normalement, et la surprise ça marche de manière quasi instantané (moins d'une seconde). avez vous une idée de ce qui a pu se passer ?

    En tout cas merci pour votre aide

    mardi 19 mars 2013 14:44

Toutes les réponses