none
Exchange 2013 - Base de données des mailbox à 2 endroits RRS feed

  • Question

  • Bonjour,

    J'ai un problème sur mon serveur Exchange 2013 au niveau du stockage de la base de données mailbox.

    Dans l'interface d'administration de mon serveur, j'ai une seule base de données Exchange "Maibox Database xxxxxxxxxxx", emplacement "D:\Exchange\Mailbox Database xxxxxxxxxxx".

    Seulement depuis hier, mon disque C:\ est plein à plus de 90% et en cherchant j'ai vu un dossier "Maibox Database xxxxxxxxxxx" dans C:\Programmes\Microsoft Exchange\...

    Hors je ne veux surtout pas avoir de mailbox sur mon disque C:\.

    Avez-vous une idée d'ou pourrait venir ce dossier et comment faire pour tout basculer sur le D:\ ?

    Merci

    mardi 29 septembre 2015 13:19

Réponses

  • Après un deuxième coup d'oeil, il semblerait que ce soit uniquement des fichiers de logs à l'intérieur du disque C:\.

    Il y a plus de 30'000 fichiers de type "E0000088989.log", et quelques fichiers ".chk", ".jrs" et ".edb".

    Est-ce que quelqu'un peut m'expliquer ce que sont ces fichiers exactement et comme purger ces logs si c'est possible.

    Merci

    Il s'agit des journaux de transaction de la base.

    Veuillez vérifier si la base est toujours active dans la configuration (voir mon post précédent), si ce n'est pas le cas, vous pourrez supprimer tout cela.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    • Marqué comme réponse arc_jsc jeudi 1 octobre 2015 07:08
    mardi 29 septembre 2015 13:49
  • Est-ce que vous avez une sauvegarde de votre serveur Exchange qui est faite régulièrement ? (sauvegarde avec agent Exchange, ou Windows Backup ou Veeam)

    En fait, lorsqu'une sauvegarde correcte de votre serveur est faite, les journaux de transaction sont purgés.

    Si cette sauvegarde n'existe plus, les fichiers sont conservés.

    La solution est donc : une bonne sauvegarde


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    • Marqué comme réponse arc_jsc jeudi 1 octobre 2015 07:08
    mardi 29 septembre 2015 14:37

Toutes les réponses

  • Bonjour,

    Je pense qu'il s'agit de la Mailbox Database par défaut (celle installée par le Setup d'Exchange) qui n'a pas du être supprimée convenablement.

    Veuillez vérifier d'abord si cette Mailbox Database est encore connue d'Exchange ou non :

    Get-MailboxDatabase|fl

    Vérifiez qu'il n'y ait pas de trace de cette Mailbox Database, sinon :

    Get-MailboxDatabase "Mailbox xxxxxxxx"|Remove-MailboxDatabase

    Puis supprimez le dossier sur le disque.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    mardi 29 septembre 2015 13:37
  • Après un deuxième coup d'oeil, il semblerait que ce soit uniquement des fichiers de logs à l'intérieur du disque C:\.

    Il y a plus de 30'000 fichiers de type "E0000088989.log", et quelques fichiers ".chk", ".jrs" et ".edb".

    Est-ce que quelqu'un peut m'expliquer ce que sont ces fichiers exactement et comme purger ces logs si c'est possible.

    Merci

    mardi 29 septembre 2015 13:44
  • Après un deuxième coup d'oeil, il semblerait que ce soit uniquement des fichiers de logs à l'intérieur du disque C:\.

    Il y a plus de 30'000 fichiers de type "E0000088989.log", et quelques fichiers ".chk", ".jrs" et ".edb".

    Est-ce que quelqu'un peut m'expliquer ce que sont ces fichiers exactement et comme purger ces logs si c'est possible.

    Merci

    Il s'agit des journaux de transaction de la base.

    Veuillez vérifier si la base est toujours active dans la configuration (voir mon post précédent), si ce n'est pas le cas, vous pourrez supprimer tout cela.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    • Marqué comme réponse arc_jsc jeudi 1 octobre 2015 07:08
    mardi 29 septembre 2015 13:49
  • Bonjour,

    Déjà, merci pour votre réponse.

    Alors j'ai executé la commande :

    Get-MailboxDatabase|fl

    Et j'ai eu toute les infos sur la base mailbox.

    J'ai retenu ces 2 informations :

    EdbFilePath : D:\Exchange\Mailbox Database 1113331577\Mailbox Database.edb.

    .

    .LogFolderPath: C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database 1113331577

    Donc c'est bel et bien les fichiers de logs qui sont stockés sur le C:\.

    C'est bizzare parce que ce serveur Exchange tourne depuis ~2 ans et nous n'avons pas eu de problèmes pour l'instant. Et dans les 30Go de fichiers de logs les plus vieux datent du 27.08.2015 donc 1 mois.

    D'ou peut provenir cette hausse de la taille des logs ?

    EDIT: Oui la base est active, c'est la seule et unique sur le serveur.


    • Modifié arc_jsc mardi 29 septembre 2015 14:03
    mardi 29 septembre 2015 14:01
  • Est-ce que vous avez une sauvegarde de votre serveur Exchange qui est faite régulièrement ? (sauvegarde avec agent Exchange, ou Windows Backup ou Veeam)

    En fait, lorsqu'une sauvegarde correcte de votre serveur est faite, les journaux de transaction sont purgés.

    Si cette sauvegarde n'existe plus, les fichiers sont conservés.

    La solution est donc : une bonne sauvegarde


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    • Marqué comme réponse arc_jsc jeudi 1 octobre 2015 07:08
    mardi 29 septembre 2015 14:37
  • Merci pour la réponse.

    Alors oui nous effectuons des sauvegarde avec Symantec BackupExec. En cherchant je viens de voir que l'agent Symantec n'est pas démarré sur le serveur Exchange ce qui pourrait expliquer ce problème.

    Par contre du côté du serveur de backup, il n'y a eu aucune alerte de la part de Symantec, ce qui est étrange.

    Je vais essayer de réactiver l'agent et je vous dirai ce qu'il en est.

    Merci pour l'aide en tout cas ;)

    mardi 29 septembre 2015 14:47
  • Bonjour,

    Alors le problème venait bel et bien des backups.

    Enfaite c'était pas l'agent mais le logiciel BackupExec complet qui avait planté.

    BackupExec n'avait pas lancé les tâches automatiques de backups et les transaction logs n'étaient effacés.

    Après un backup, les fichiers ont été effacés et tout est rentré dans l'ordre.

    Merci encore
    jeudi 1 octobre 2015 07:07