locked
[Résolu] Parametres d'impression par defaut ne restent pas RRS feed

  • Question

  • Bonjour à tous,

    Je rencontre un problème un peu déroutant.... Je suis dans une infrastructure Xenapp 6.5 et des serveurs TSE 2008 r2

    Je possède également un serveur d'impression sur lequel toutes mes imprimantes sont déclarées.

    Sur tous mes serveur RDS les drivers correspondants sont installés. Je ne rencontre ce problème que sur UN SEUL de mes serveurs. Tout est ok sur les autres.

    Lorsque je déclare une imprimante sur mon serveur d'impression, je procéde comme suis :

    Je créé le port, je créé l'imprimante puis je l affecte au port en précisant le drivers (PCL6 for universal print de Ricoh).

    Je répertorie l'imprimante dans l'annuaire et j'affecte les paramètres par défaut que je souhaite (en l’occurrence Noir et Blanc et et je DESACTIVE le recto/verso).

    J'affecte ensuite mes imprimantes a ma GPO citrix pour que les users voient leur imprimante remonté s'ils en ont besoins.

    Comme je vous le disait, sur tous mes autres serveurs, aucun problème.... mes users récupèrent l'imprimante et les parametres que j'ai définit par defaut sur mon serveur d'impression sont bien hérités.... si l utilisateur change les parametres sur son imprimante dans sa session, ceux-ci changent bien et sont conservés.

    Sur le serveur qui me pose problème :

    Ce ne sont pas les paramètres que j'ai définit comme parametre par defaut sur le serveur d'impression qui sont redescendus dans mes sessions user (en l'occurence la couleur et le Recto/verso sont systématiquement activés)... Si je change ces parametres et que je valide... ils sautent systématiquement tout de suite (lorsque je rouvre les options d'impression de l'imprimante tout de suite apres, ils sont repassé a couleur et R/V..).. pire... j'ai l'impression que ces parametres viennent "ecraser" les parametres sur le serveur d'impression ! Lorsque je retourne sur l'imprimante en question et que je clic sur "définir les parametres d'impression par défauts" Cela sautent également parfois....

    Lorsque je monte l'une de ces imprimantes posant probleme sur l'un des serveurs "sains" là aucun probleme... j'hésite bien des parametres par défaut définis sur le serveur d'impression et un utilisateur peut les changer et ils sont bien conservés....

    J'ai deja comparé toutes les valeurs du driver impliqué se trouvant dans "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3\PCL6 Driver for Universal Print" et tout semble correcte....

    J'espere que quelqu'un aura une idée.... 

    Merci pour votre aide :)



    • Modifié Nocturnis jeudi 24 mars 2016 10:50
    mercredi 16 mars 2016 16:52

Réponses

  • Bonjour,

    Le probleme est reglé.

    Pour information, j ai reinstallé le driver universel citrix client sur mon serveur xenapp et tout est rentré dans l ordre suite a un reboot... 

    Ok pour l'install de pdf creator

    Ok pour la recupération des parametres d'impression établis par défaut sur le serveur d'impression et la modification des parametres par les utilisateurs directemetn sur l'imprimante.

    Merci pour votre aide.

    • Marqué comme réponse Emile Supiot jeudi 24 mars 2016 11:27
    jeudi 24 mars 2016 10:49

Toutes les réponses

  • Bonjour Nocturnis,

    Avez-vous bien vérifié que le serveur qui pose problème est bien affecté par votre GPO ?

    Cordialement,

    Emile


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    jeudi 17 mars 2016 14:13
  • Hello

    Est-ce que vous avez utilisé l'utilitaire "Print Detective" sur vos serveurs Citrix afin de voir si vous aviez des soucis d'incompatibilité (ou non) avec vos drivers ?

    On utilise ici aussi des imprimantes Ricoh, les Universal Driver PCL6 de Ricoh, sous du XenApp 6.5 sur Windows 2008 R2. Le souci est que ces drivers ne sont pas signalés comme étant des pilotes "Citrix Ready". Donc on peut s'attendre à des comportements erratiques...

    Là par exemple je vous montre le résultat du scan effectué par PrintDetective en lui demandant de montrer que les drivers "non-Citrix".

    Est-ce que vous avez une configuration Citrix spécifique pour les imprimantes ?

    Florent


    jeudi 17 mars 2016 14:16
  • Bonjour,

    Merci pour vos réponses.

    Oui mes GPO sont bien appliqués (vérifié via GPresult).

    Effectivement le driver ressort aussi de mon coté lorsque je passe PrintDetective et que je filtre les pilotes Non natif Citrix.... mais encore une fois il fonctionne tout a fait correctement sur mes autres serveurs Xenapp...

    Non jen'ai pas de particularité dans mon infra... il s'agit d'une infra XA 6.5 classique. De plus ce probleme est apparue recement... avant je n'avais aucun probleme meme sur ce serveur.... il semble etre apparue consécutivement au deploiement de nouvelles imprimantes (toutes RICOH).

    J'ai effectué un nettoyage de tous les drivers et les aient resintallé sur le serveutr Xenapp en cause mais rien n y fait... meme lorsque je desinstall le driver Ricoh et que j'utilise le drivers universal citrix (qui est utilisé lorsque que les drivers specifiques ne sont pas installé sur le serveur) et bien le probleme persiste : lorsque je change les parametres R/V ou couleur, ils sautent tout de suite et ne sont pas conservés.... je penses donc que le probleme ne se trouvep as coté drivers....

    Je ne sais pas si ca peut aider mais, depuis, lorsque j'essai de reinstaller pdf creator, j'ai l'erreur suivante :

    Install printerport:
     Portname : pdfcmon
     Result: Success
    
    InstallMonitor:
     Monitorname : pdfcmon
     Environment : Windows x64
     Result: Error 1722 = Le serveur RPC n’est pas disponible
    
    Install printerdriver for WinXP2k3:
     Drivername : PDFCreator
     Environment : Windows x64
     Result: Error 1722 = Le serveur RPC n’est pas disponible
    
    InstallPrinter:
     Printername: PDFCreator
     Drivername : PDFCreator
     Portname   : pdfcmon
     Result: Error 1722 = Le serveur RPC n’est pas disponible
    
    No printer has been installed!
    
    Printerstatus after installing:
    Spooler service: is running

    Pourtant le service spooler et RPC sont bien démarrés....

    Merci.


    • Modifié Nocturnis vendredi 18 mars 2016 13:01
    jeudi 17 mars 2016 15:40
  • Bonjour,

    Pour information je viens d'avoir le support Ricoh qui n'a pas su resoudre le probleme... pour eux l'incident se trouve coté base de registre....

    Personne n'a d'idées ? :)

    mardi 22 mars 2016 15:51
  • Bonjour,

    Le probleme est reglé.

    Pour information, j ai reinstallé le driver universel citrix client sur mon serveur xenapp et tout est rentré dans l ordre suite a un reboot... 

    Ok pour l'install de pdf creator

    Ok pour la recupération des parametres d'impression établis par défaut sur le serveur d'impression et la modification des parametres par les utilisateurs directemetn sur l'imprimante.

    Merci pour votre aide.

    • Marqué comme réponse Emile Supiot jeudi 24 mars 2016 11:27
    jeudi 24 mars 2016 10:49