locked
RESOLU - Probleme Hyper-V: VM qui reboot regulierement RRS feed

  • Question

  • Bonjour,

    J'ai un serveur Windows 2008 Standart hebergeant 2 VMs sous Linux.

    A intervalle regulier (tout les 5 à 10 jours), mes VM rencontrent l'erreur suivante:

    ******

    Log Name:      Microsoft-Windows-Hyper-V-Worker-Admin
    Source:        Microsoft-Windows-Hyper-V-Worker
    Date:          02/12/2011 14:22:43
    Event ID:      18560
    Task Category: None
    Level:         Critical
    Keywords:     
    User:          NETWORK SERVICE
    Computer:      TOTO.mycompany.fr
    Description:
    'TOTO' was reset because an unrecoverable error occurred on a virtual processor that caused a triple fault. If the problem persists, contact Product Support. (Virtual machine ECABAD42-B1FF-455A-9666-55F6F0AD6D10)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Hyper-V-Worker" Guid="{51ddfa29-d5c8-4803-be4b-2ecb715570fe}" />
        <EventID>18560</EventID>
        <Version>0</Version>
        <Level>1</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2011-12-02T13:22:43.028Z" />
        <EventRecordID>713</EventRecordID>
        <Correlation />
        <Execution ProcessID="3564" ThreadID="3608" />
        <Channel>Microsoft-Windows-Hyper-V-Worker-Admin</Channel>
        <Computer>TOTO.mycompany.fr</Computer>
        <Security UserID="S-1-5-20" />
      </System>
      <UserData>
        <VmlEventLog xmlns:auto-ns2="http://schemas.microsoft.com/win/2004/08/events" xmlns="http://www.microsoft.com/Windows/Virtualization/Events">
          <VmName>MANTIS2</VmName>
          <VmId>ECABAD42-B1FF-455A-9666-55F6F0AD6D10</VmId>
        </VmlEventLog>
      </UserData>
    </Event>

    *******

    annoncant:

    'TOTO' was reset because an unrecoverable error occured on a virtual processor that caused a triple fault. If the problem persists, contact Product Support. (Virtual machine ECABAD42-B1FF-455A-9666-55F6F0AD6D10).

     

    Auriez-vous une idée pour la résolution de ce problème?


    mercredi 7 décembre 2011 09:44

Réponses

  • Bonjour,

     

    Après des tests de basculement sur un autre serveur de virtualisation, le problème vient du serveur hebergeant les VM qui n'est pas completement compatible avec de la virtualisation.

    Suite au changement de serveur, le problème ne semble pas se reproduite.

    Merci de vos réponses en tout cas.

    mardi 13 décembre 2011 16:19

Toutes les réponses

  • Bonjour,

    Pour vous orientez un peu, essayez de jeter un coup d'eoil sur ce thread 

     http://social.technet.microsoft.com/Forums/eu/winserverhyperv/thread/376cb83c-ed16-493a-a993-73ee27cb259c

    Bonne chance


    Best Regards Don't forget to mark it as answer if it helps
    mercredi 7 décembre 2011 10:43
    Auteur de réponse
  • Bonjour,

     

    Petite précision quant à ce problème, les VMs en question hebergent des serveurs sous Ubuntu 11.

    Je n'ai pour l'instant toujours pas de solution, si ce n'est le fait que le problème se produit sur des systèmes Ubuntu hébergés sous Hyper-V.

    Je suis entrain de voir pour faire différents tests, et éventuellement migrer le serveur sur une distribution Red Hat.

    Etant donné que c'est un serveur de prod permettant à une cinquantaine de personnes de travailler, les patchings et solutions envisagées se font avec prudence.

     

    lundi 12 décembre 2011 12:16
  • En effectuant des recherches sur le net, votre probleme est constaté avec les VM sous linux. Pas d'expert en virtualisation recommande aux personnes concernées de contacter le support de Microsoft pour résoudre ce problème.

    Bonne chance


    Best Regards Don't forget to mark it as answer if it helps
    lundi 12 décembre 2011 14:33
    Auteur de réponse
  • Merci de votre réponse, je vais ouvrir un ticket auprès du support, et je tiens au courant de la solution proposé.

     

    Cordialement

    lundi 12 décembre 2011 16:29
  • Bonjour,

     

    Après des tests de basculement sur un autre serveur de virtualisation, le problème vient du serveur hebergeant les VM qui n'est pas completement compatible avec de la virtualisation.

    Suite au changement de serveur, le problème ne semble pas se reproduite.

    Merci de vos réponses en tout cas.

    mardi 13 décembre 2011 16:19
  • Bonsoir,

    à propos de machines non compatibles avec la virtualisation, il est important de noter que Microsoft ne supporte QUE de la mémoire ECC sur les serveurs HyperV.

    Cordialement,


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    mardi 13 décembre 2011 20:55