none
[Résolu]:Désinstaller pilote avant redémarrage PC RRS feed

  • Question

  • Bonjour,

    DELL Optiplex 5070 disque Toshiba SSD, suite à une mise à jour de pilote via Windows update, le secteur de boot semble corrompu, le message "boot device not found" s'affiche.

    Je soupçonne un des pilotes (Cf. image), car tous les PC dont ces update étaient en attente de redémarrage se trouvent dans le même cas de figure.

    Est-il possible de desinstaller les dits-pilotes avant que le PC ne redémarre ?

    Comment procéder pour trouver à quels périphériques ces pilotes sont rattachés ?

    Merci.

    Cdlt.

    Fred.

     



    mardi 28 janvier 2020 14:52

Réponses

  • Sur le 5070 équipé d'un disque SSD, j'ai connecté le disque dur non SSD du 3020 (et booté sur celui-ci) sur lequel j'ai pu récupéré l'image disque système avant redémarrage + crash du 5070.

    Ainsi, j'ai pu recréer une image disque (Veeam) d'un 5070 sans les pilotes suspects que j'ai (après avoir démonté le disque non SSD, donc le disque SSD devient le disque principal du 5070) restauré sur ce même 5070.

    mercredi 12 février 2020 15:22

Toutes les réponses

  • Bonjour,

    j'ai déjà effectué ces manip sans succès .

    Pour les PC qui n'ont pas encore redémarré, comment désinstaller des maj en attente de redémarrage ?

    Merci.

    Cdlt.

    Fred.

    vendredi 31 janvier 2020 12:35
  • Bonjour,

    Avez-vous essayé de lancer l'outil de réparation du système au démarrage? Voir aussi la partie "Réparer Windows 10 avec un support d’installation de Windows 10" dans le lien ci-dessous:

    Vérifiez également si vous avez un point de restauration.

    Sinon pour ce qui concerne désinstaller une mise à jour pilote avant son redémarrage requis, je ne sais pas si c'est possible mais par contre, vous pouvez désinstaller le pilote en question depuis le Gestionnaire des périphériques, ou bien, dans Paramètres>Mises à jour & Sécurité>Afficher votre historique des mises à jour, désinstallez les mises à jour souhaitées.

    Si vous rencontrez souvent des problèmes des pilotes avec vos PCs à cause des mises à jour Windows, je vous suggère de désactiver la mise à jour des pilotes en suivant le tutoriel ci-dessous une fois que le système est installé:

    Ne pas oublier de mettre à jour vos pilotes à l'aide du site constructeur.

    Cordialement,
    SAAD Youssef
    ___________________

    Prière de ne pas oublier de marquer les réponses utiles comme solution, en vous remerciant!

    WebSite: PrajwalDesai/youssef-saad


    vendredi 31 janvier 2020 13:14
  • Bonjour JuraMB,

    Est-ce que les conseils ont été utiles? Si ces messages vous ont aidé, s'il vous plaît de les marquer comme réponse.    
    Si vous avez trouvé une autre solution, veuillez la partager avec la communauté afin que les utilisateurs autres que l'interrogateur puissent en bénéficier.

    Merci d'avance pour votre retour.

    Cordialement,

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votreproblème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 4 février 2020 15:25
  • Bonjour,

    diverses tentatives depuis les CD de restauration, outils de réparation Windows, sans succès.

    L'historique des maj Windows ne montre que les maj d'OS et appli, mais pas les maj de pilotes.

    Cdlt.

    Fred.

    mardi 4 février 2020 15:38
  • Bonjour,

    testé également, sans succès.

    Cdlt.

    Fred.

    mardi 4 février 2020 15:39
  • Bonjour Fred,

    Avez-vous essayé de désinstaller les pilotes concernés depuis le Gestionnaire des périphériques comme indiqué plus haut?

    Cordialement,

    _________________________

    Youssef Saad | Blog LinkedIn | Twitter

    Prière de ne pas oublier de marquer les réponses utiles comme solution, en vous remerciant !

    mardi 4 février 2020 21:13
  • Bonjour,

    non pas encore, car comment déterminer à quel périphérique se rattache les pilotes ?

    par ex. "Intel-system-4/8/20149 12:00:00 am 30.100.1915.1" comment trouver le périphérique correspondant ?

    Cdlt.

    Fred.

    mercredi 5 février 2020 07:26
  • Bonjour

    Si je comprends bien, vous avez plusieurs PC qui ne bootent plus à cause de MAJ de drivers, et qui indiquent ce message : "Boot Device Not Found"

    Personnellement, je serais vraiment surpris que ce soit à cause de la MAJ d'un driver. (D'un Bios, oui, éventuellement.)

    Pour le Bios, voir : https://www.dell.com/support/home/fr/fr/frbsdt1/drivers/driversdetails?driverid=8k64m&oscode=wt64a&productcode=optiplex-5070-desktop

    - Avez-vous essayé une réparation du démarrage avec un support d'installation de Windows ?

    - Vous avez des HDD en MBR ou en GPT ?

    - Et quand vous tapez F2, quelle est la réponse ?

    PS : Et ce qui me surprend aussi, c'est le 1er driver "Intel" de votre image, censé avoir été créé en juillet 1968 !


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/





    • Modifié Georges News mercredi 5 février 2020 08:54 Ajout PS
    mercredi 5 février 2020 08:23
  • Bonjour

    Bonjour,

    Si je comprends bien, vous avez plusieurs PC qui ne bootent plus à cause de MAJ de drivers, et qui indiquent ce message : "Boot Device Not Found"

    Oui

    Personnellement, je serais vraiment surpris que ce soit à cause de la MAJ d'un driver. (D'un Bios, oui, éventuellement.)

    Non c'est bien un pb de maj de driver Windows, car lorsque je restaure une image disque (Veeam) d'un autre PC identique sur les PC concernés, ceux-ci redémarrent sans aucun message d'erreur.

    Et je pense que c'est un pilote/update lié aux disques durs SSD, car lorsque je démarre via un CD de restauration en ligne de commande, tous les fichiers des partitions sont accessibles.

    Pour le Bios, voir : https://www.dell.com/support/home/fr/fr/frbsdt1/drivers/driversdetails?driverid=8k64m&oscode=wt64a&productcode=optiplex-5070-desktop

    - Avez-vous essayé une réparation du démarrage avec un support d'installation de Windows ?

    Déjà essayé sans succès.

    - Vous avez des HDD en MBR ou en GPT ?

    Disque dur GPT SSD.

    - Et quand vous tapez F2, quelle est la réponse ?

    ==> accès au BIOS.

    PS : Et ce qui me surprend aussi, c'est le 1er driver "Intel" de votre image, censé avoir été créé en juillet 1968 !

    Moi aussi.


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/






    mardi 11 février 2020 10:51
  • Bonjour.

    OK pour vos infos. Dont : "- Avez-vous essayé une réparation du démarrage avec un support d'installation de Windows ?" => Déjà essayé sans succès.

    Je suppose que depuis le bios (par F2), vous ne voyez donc pas le SSD.

    Là, je ne vois plus trop quoi vous conseiller.


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/



    • Modifié Georges News mardi 11 février 2020 11:14 Ajout test par bios
    mardi 11 février 2020 11:09
  • Bonjour,

    si le disque SSD est bien visible depuis le BIOS.

    Ce que je fais ce matin:

    précédemment, avant de rebooter un des PC (Dell Optiplex 5070), j'avais effectuer une image disque Windows sur un serveur réseau.

    Restauration de l'image disque via un CD de retauration Windows sur un Dell Optiplex 3020 (disque dur non SSD) ==> le PC démarre normalement.

    Installation de Veeam Agent ==> sauvegarde PC.

    Je vais tenter via un cd de boot Veeam de restaurer la nouvelle image vers l'optiplex 5070.

    Je tiendrai informé le post, à suivre...

    Cdlt.

    Fred.

    mercredi 12 février 2020 09:10
  • Bonjour

    Vous dites : "si le disque SSD est bien visible depuis le BIOS"

    Si "boot device not found" => Alors, ça voudrait dire que ce serait votre partition cachée censée être "active" et nécessaire au boot, qui serait abîmée.

    PS : Avez-vous essayé en désactivant le SECURE BOOT du Bios ?


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/



    • Modifié Georges News mercredi 12 février 2020 09:50 ajout PS
    mercredi 12 février 2020 09:38
  • Bonjour,

    oui déjà essayé en désactivant le secure boot au niveau BIOS ==> sans succès.

    Cdlt.

    Fred.

    mercredi 12 février 2020 10:05
  • OK, donc mauvaise piste ce "Secure Boot"

    Ce que vous pourriez essayer, c'est le AOEMI sur le support bootable de Hiren’s BootCD PE x64.

    Voir ce tuto => http://dechily.org/Forum_Aski/viewtopic.php?f=63&t=2409

    - Je viens de faire une capture d'AOMEI sur mon dual boot W7/W10 en MBR :

    On voit bien que la partition de 100Mb est celle active


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/

    mercredi 12 février 2020 10:33
  • Suite.

    Le même HDD vu par "Macrorit Partition Extender" :

    On y voit même mieux quelle est la "partition active" qui sert au boot


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/

    mercredi 12 février 2020 11:20
  • Ok, je vais tester.

    Pour info:

    après avoir restauré l'image disque Veeam effectuée sur l'Optiplex 3020 vers l'Optiplex 5070 ==> même message d'erreur "inacessible boot device".

    Démontage disque dur Optiplex 3020, remontage sur l'Optiplex 5070 ==> après ajustements par Windows, le Pc démarre.

    Donc, c'est bien en rapport avec un pilote de gestion du disque SSD ou du contrôleur pour ce type de disque, ou pilote intel rapid storage (?) qui provoque l'erreur.

    Cdlt.

    Fred.

    mercredi 12 février 2020 12:31
  • La solution:

    depuis l'Optiplex 5070, disque SSD alimenté, mais boot depuis le disque dur non SSD de l'Optiplex 3020, lancement Windows  update + Dell Command Update.

    Récupération DriverStore Explorer afin de supprimer les pilotes:

    AMD Driver update for Pci bus,

    Intel -system 10.1.16.7,

    Intel Corporation System 30.100.1915.1,

    Intel Corporation SCSI Adapter 15.9.8.1050,

    Redémarrage, Windows update, image disque Veeam.

    Démontage disque dur non SSD, restauration image disque Veeam ==> le PC boot de nouveau !!!

    Par contre, je ne sais toujours pas quel pilote dans la liste provoque le dysfonctionnement.

    Merci à tous pour vos contributions.

    Cdlt.

    Fred.

    mercredi 12 février 2020 14:32
  • > Donc, c'est bien en rapport avec un pilote de gestion du disque SSD ou du contrôleur pour ce type de disque, ou pilote intel rapid storage (?) qui provoque l'erreur

    Je trouve cette déduction assez audacieuse, mais admettons

    Car déjà, ces deux CM ont des bios très différents :

    - Version: 1.2.1 du 26 Nov 2019 pour l'un => https://www.dell.com/support/home/fr/fr/frbsdt1/product-support/product/optiplex-5070-desktop/driversVersion (29,7 Mo)

    - et Version: A20 du 19 Jun 2019 pour l'autre => https://www.dell.com/support/home/fr/fr/frbsdt1/product-support/product/optiplex-3020-desktop/drivers (4,77 Mo)


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/




    mercredi 12 février 2020 14:35
  • "Démontage disque dur non SSD, restauration image disque Veeam ==> le PC boot de nouveau !!!"

    Tant mieux si l'affaire est désormais résolue, même si ces explications me paraissant nébuleuses.

    Je ne vais pas être plus royaliste que le roi !

    Bonne continuation.


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/

    mercredi 12 février 2020 15:07
  • Sur le 5070 équipé d'un disque SSD, j'ai connecté le disque dur non SSD du 3020 (et booté sur celui-ci) sur lequel j'ai pu récupéré l'image disque système avant redémarrage + crash du 5070.

    Ainsi, j'ai pu recréer une image disque (Veeam) d'un 5070 sans les pilotes suspects que j'ai (après avoir démonté le disque non SSD, donc le disque SSD devient le disque principal du 5070) restauré sur ce même 5070.

    mercredi 12 février 2020 15:22
  • Info complémentaire:

    Le pilote fautif = Intel Corporation SCSI Adapter 15.9.8.1050 du 31/07/2019 sur le périphérique Intel Chipset SATA/PCIe RST Premium controler.

    Une fois celui-ci mis à jour par la version 17.7.0.1006 du 07/08/2019, le PC redémarre correctement.

    Cdlt.

    Fred.

    • Proposé comme réponse Georges News lundi 17 février 2020 16:47
    lundi 17 février 2020 15:32
  • Bonjour

    OK. Merci du retour d'info.

    (C'était donc bien un driver foireux imposé par Windows Update ! C'est très rare, mais ça arrive parfois, la preuve. Ca se passait donc après la 1ère phase du boot)

    Bonne continuation.

    PS : A priori, Intel propose du plus récent encore  (Version 17.8.0.1065 du 17/01/2020)=> https://downloadcenter.intel.com/fr/download/29339/Intel-Rapid-Storage-Technology-Intel-RST-User-Interface-and-Driver?v=t

    PS2 : Et je vois que le Catalogue MU ne l'intègre pas encore => https://www.catalog.update.microsoft.com/Search.aspx?q=intel+corporation+-+scsiadapter


    Ex-helpeur de Community. Désormais sur http://dechily.org/Forum_Aski/




    lundi 17 février 2020 16:18