none
Mise en oeuvre adfs RRS feed

  • Question

  • bonjour a tous,

    voila je galere pour mettre en place adfs pour un lab.

    le but est de l utiliser pour rds via WAP.

    J ai trouve plein de tuto mais ca marche pas a chaque fois..

    jamais un access a l, interface web adfs.

    je cherche une personne qui a deja installer adfs et qui aurait un lien pour un tuto.

    pour infos.

    1 serveur dc 2019

    1 serveur rds avec tout les roles rds.

    1serveur adfs membre du domaine.

    1 certificat genere via lets encrypt ou un certificat fait avec mon Ca du serveur dc 2019.

    Merci pour votre aide

    mardi 14 avril 2020 10:05

Réponses

Toutes les réponses

  • Bonjour Olivier,

    As tu vue cet article : https://blog.tmurphy.org/2015/06/securing-rd-gateway-with-web.html

    J'avais testé avec ce tuto et cela à marcher pour moi, par contre il te manque un serveur dans ton déploiement.

    Il te faut le serveur ADFS et le serveur proxy ADFS qui doit avoir le rôle WAP. Ton authentification va passer par ce serveur.

    Si cela peut t'aider : https://rdr-it.com/ad-fs-installation-et-configration/

    Romain

    mardi 14 avril 2020 11:28
  • bonjour romain,

    j ai tester mais j avais quand meme des erreurs.tuto bien fait je le lis depuis plusieurs jours deja.

    Erreur parefeu et une erreur sur une ligne du tuto.

    et l enregistrement ne doit il pas etre un cname au lieu d un A ?

    la j ai refais mon serveur adfs , et ca passe hors le problème de pare-feu, que j ai corriger a la mano.

    je poursuis avec le waf via ton tuto.

    merci a toi


    mardi 14 avril 2020 13:30
  • bonjour,

    peux tu me dire ou doit pointer le nat sur le serveur WAp ou adfs.

    parc que je tourne un peu en rond.

    un site iis qui tourne sur monsite.test.fr

    un adfs qui tourne sur monadfs.test.fr\adfs\ls\etc.. port 443 ip local 172.16.0.40

    et mon wap sur 172.16.0.41

    si tu peux m aiguiller merci

    ps: partie sans authentification

    mardi 14 avril 2020 16:45
  • Ta nat doit pointer vers le WAP et lui contactera l'adfs pour l'authentification, adfs été toujours la bête noire des solutions Microsoft, je te conseille de bien lire un bouquin a fin de mieux comprendre, car moi aussi j'avais commencé avec les tutos mais ce n'est pas du tout évident la configuration et le résultat n'est jamais le même.

    mardi 14 avril 2020 19:04
  • bonjour,

    merci pour l info quel bouquin as tu lu.

    j ai chercher un peu partout et rien trouve.

    a chaque fois c est l explication adfs mais pas de mise en oeuvre.

    bete noir oui oui je confirme.

    bonne soirée

    mardi 14 avril 2020 19:07
  • J'ai lu le 70-412 un bon bouquin, y a plein de sujets dedans à maîtriser, il me semble que cela existe aussi au 70-742, bon l'explication est bonne et tu comprends vraiment bien et tu montes vites en compétences,

    Cependant le tp était bien mais incomplet hhhh ils se sont arrêtés à la partir waf je me rappelle bien j'étais dég hhhh mais j'ai cherché et je comprenais mieux les tuto et videos sur le net et je l'ai adapté à mes cas, je te signale que cette partie rien que l'adfs m'avait prix presque 3 semaines de travail acharné pour la maîtriser, mais ca vaut le coup.


    • Modifié M dakhama mardi 14 avril 2020 19:22
    mardi 14 avril 2020 19:19
  • Bonjour Olivier,

    Pour quelles raisons tu souhaites passer par ADFS ? pour le SSO ?

    Si tu souhaites de la sécurité, je te conseille plutôt des solutions comme F5 ou Kemp qui sont des reverses proxy avec une couche sécurité.

    ADFS et WAP apporte juste une solution d'authentification.

    Dommage que MS est arrêté ISA et Forefront :(

    Romain 

    mercredi 15 avril 2020 12:31
  • bonjour,

    oui effectivement je cherche du reverse proxy avec authentification.

    et aussi essaye adfs et wap.

    un des problème est que lors de l installation les règles de par feu sont pas mis en place automatiquement.

    En fait elles sont la mais non active,  c est pour ca que je galérai, j ai bugguer sur le pare-feu.

    Par contre toujour un souci avec la publication.

    ex:

    iis sur un serveur dc pour test (bien sur), access via le net par moniis.toto.fr

    la c est ok avec redirection port 80 dans mon parfeu.

    pour le publier:

    je mets url externe:moniis.toto.fr

    mais l interne je met quoi.

    par default il me mets moniis.toto.fr.

    si je mets toto.mondomaine.adds , il me dit que les deux adresse sont differentes?

    le je vois pas.

    ps: pour info mon adfs est ok via wap, la page adfs/ls/etc.. s affiche..

    merci

    mercredi 15 avril 2020 17:01
  • bon

    c est ok pour moi en mode pass-trough.

    je refais en entier la manip pour etre ok.

    merci

    mercredi 15 avril 2020 18:07