locked
DLL introuvables... RRS feed

  • Question

  • Bonjour
    J'ai développé une application sous Windows Xp SPE et Visual C++ SP1.
    Lorsque je deploie mon application sur un PC neuf (lui aussi sous XP SP3) un message d'erreur m'indique qu'on mon application ne peut se lancer et dans dependancy Walker je trouve qu'il me manque les DLL suivante :
    IESHIMS.dll et WER.dll
    avez vous une idée de ce que je peux faire ?
    Merci d'ava,nce
    • Déplacé swapnilpBanned mercredi 3 février 2010 20:43 Forum Consolidation (Origine :Windows XP – Déploiement)
    mardi 9 juin 2009 08:18

Réponses

  • Bonjour,

    Le problème est que sur une machine de dev avec visual tout fonctionne correctement.
    L'analyse des dependances avec dependancy walker indique que ces dll manquantes sont chargees par ieframes.dll...
    J'ai lu sur quelques forums que cette dependance avait ete change dans les derniers updates de windows, avec ie 8 ???
    Bref je suis plutôt perdu. L'installation du package de redistributuion visual ne corrige aps non plus le pb. Je vais tenter de faire installer les dernières mises a jour windows sur les machines cibles pour voir si ca corrige le problème mais ca ne me parait pas vraiment une bonne solution.
    merci
    jeudi 11 juin 2009 07:01
  • Salut,

    Tu es sur la bonne voie.

    Apparemment la mise à jour des systèmes résolut les problèmes :  http://social.msdn.microsoft.com/Forums/en-US/vsx/thread/6bb7dcaf-6385-4d24-b2c3-ce7e3547e68b (Anglais)

    Tiens-nous au courant.

    Cordialement.


    Roxana Panait, MSFT
    vendredi 26 juin 2009 11:16

Toutes les réponses

  • Bonjour,

    tu as essayé d'utiliser le mode debogage de Visual Studio pour repérer les dépendances ?
    Freddy ELMALEH aka "bigstyle" -- Consultant Freelance pour Active IT -- MVP Windows Server - Directory Services
    mercredi 10 juin 2009 21:30
  • Bonjour,

    Le problème est que sur une machine de dev avec visual tout fonctionne correctement.
    L'analyse des dependances avec dependancy walker indique que ces dll manquantes sont chargees par ieframes.dll...
    J'ai lu sur quelques forums que cette dependance avait ete change dans les derniers updates de windows, avec ie 8 ???
    Bref je suis plutôt perdu. L'installation du package de redistributuion visual ne corrige aps non plus le pb. Je vais tenter de faire installer les dernières mises a jour windows sur les machines cibles pour voir si ca corrige le problème mais ca ne me parait pas vraiment une bonne solution.
    merci
    jeudi 11 juin 2009 07:01
  • Salut,

    Tu es sur la bonne voie.

    Apparemment la mise à jour des systèmes résolut les problèmes :  http://social.msdn.microsoft.com/Forums/en-US/vsx/thread/6bb7dcaf-6385-4d24-b2c3-ce7e3547e68b (Anglais)

    Tiens-nous au courant.

    Cordialement.


    Roxana Panait, MSFT
    vendredi 26 juin 2009 11:16