none
Connecter une VM a internet RRS feed

  • Question

  • Bonjour a tous,

    pour se faire il m'es impossible de créer un vSwitch externe ( toutes manœuvre sur les cartes réseaux provoque un redémarrage du serveur) alors je l'es connecter en NAS ( partage de connexion entre la carte réseau physique et virtuelle) toutes les configuration ip sont en DHCP.

    a première vu tous marche bien j'arrive à accéder à internet a partir de la VM et j'accède à la VM via internet.

    mais après le redémarrage du serveur, la configuration à été modifier ( configuration ip )

    les machine récupère des adresses IP qui ne sont pas du même réseau que la machine hôte

    avec des réseau non identifier, que puis je faire pour connecter à nouveau la VM à internet

    je vous remercie d'avance pour votre réponse

    bien cordialement

    mercredi 8 février 2017 09:58

Réponses

  • les pilotes sont bien mis a jours !! 

    au démarrage du serveur le pont a été créer mais le réseau est toujours pas identifier !!! et la vm n'est toujours pas connecter !! pareil pour son adressage ip, il s'agit bien des adresse APIPA 

    en faite je ne comprend pas la raison de ces redémarrage, est c que ça me fait toujours revenir a cette réponse : commutateur externe

    Bonjour,

    à chaque redémarrage du serveur un ensemble d'erreur est généré, parmi celle la j'ai l'erreur event id 219 : le driver d’un périphérique à été mal chargé en raison d’un dysfonctionnement du périphérique comme expliquer ci dessous :

    https://social.technet.microsoft.com/wiki/contents/articles/3164.event-id-219-windows-kernel-pnp.aspx

    Pour l’action recommandée par la communauté Microsoft :

    Vérifiez auprès du fabricant de votre appareil si un pilote de périphérique mis à jour est disponible (ce qui n’est pas le cas du moment tous les périph sont mis à jours  la on parle des cartes réseaux) 

    En vérifiant dans le site de hp pour les serveur HP Proliant BL460c G6,  j’ai trouvé que dans la série de serveur BL, Windows server 2016 est pris en charge à partir de la génération 8

    http://h17007.www1.hpe.com/us/en/enterprise/servers/supportmatrix/windows.aspx

    et pour la mise  à jour du pilote de la carte réseau pour Windows server 2016 ne pout pas se faire aussi parce que les mise a jours sont disponible  jusqu’à Windows server 2012 R2

    http://h20565.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=3884100

    voila c'est les réponses que j'ai pu m'apporté, si vous avez d'autre piste pour que je puisse le faire sous ce serveurs je vous remercie de m'y orienté.

    Merci a tous 

    bien cordialement 



    merci 




    • Modifié Racha_SD mercredi 8 février 2017 14:39
    • Marqué comme réponse Racha_SD lundi 13 février 2017 07:49
    mercredi 8 février 2017 13:11

Toutes les réponses

  • Bonjour, 

    on peut avoir la topologie et les captures de la configuration IP? (pour la bonne compréhension)

    Merci, a+


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 10:11
  • alors le partage de connexion à été fait entre la carte ethernet et vthernet pour la carte ethernet elle as une config ip fixe par contre vethernet ainsi que la vm qui es connecter dont en dhcp !!

    je travail sous Windows sevrer 2016 et hyper v 

    j'espère que c'est mieux expliquer !


     
    • Modifié Racha_SD mercredi 8 février 2017 10:29
    mercredi 8 février 2017 10:27
  • Quand vous utiliser l'option partager, Windows fixe une adresse réseau. donc pour votre réseau vEthernet vous devrez attribuer les adresses faisant partie de la plage réseau qu'appartient à l'adresse IP Fixé par windows. 

    Merci, a+


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 10:33
  • comment je pourrais connaitre la plage d'adresse ip qui es attribuer par la machine hôte quand je fait le partage de connexion?


    mercredi 8 février 2017 10:39
  • après avoir partager la connexion, faite clique-droit sur la NIC vEthernet = Propriété = détail et faite la capture de la fenêtre. 

    merci, a+


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 10:42
  • 

    mercredi 8 février 2017 10:48
  • avez déjà partager la connexion de la carte Ethernet à la carte vEthernet ? 


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 10:51
  • le partage est bien fait, vous pouvez le voir dans la première capture !! 

    oui je l'est déja fait avec cette même config et ça as bien marché mais une fois que le serveur redémarre ça ne marche plus !

    au redémarrage du serveur  la machine hôte et la vm sont se trouve sur deux réseau différent !! d'ou la question : comment puis je savoir d'ou la VM récupère ces adresses autrement dit qu'elle serveur dhcp qui repond a ces requêtes?   


    • Modifié Racha_SD mercredi 8 février 2017 10:59
    mercredi 8 février 2017 10:58
  • dans la VM, faite

    ipconfig /all


    et chercher la ligne 

    DHCP Server

    et trouver l’équipement qui a l'adresse IP. celui qui fait le DCHP.

    Merci, a+

     

    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 11:02
  • je vous remercie pour vos réponse !!

    en faite au niveau des VM le serveurs DHCP n'apparais pas, parce que quand je vérifier sur la machine hôte ça  me renvoie le serveur dhcp utilisé par la carte vEthernet, mais cela ne répond pas à la question d'ou j'obtiens l'adresse ip de la VM ?

    • Modifié Racha_SD mercredi 8 février 2017 11:26
    mercredi 8 février 2017 11:12
  • L'adresse IP que tu obtiens c'est une adresse APIPA 

    https://fr.wikipedia.org/wiki/Automatic_Private_Internet_Protocol_Addressing

    Merci, a+


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    • Marqué comme réponse Racha_SD mercredi 8 février 2017 11:42
    • Non marqué comme réponse Racha_SD mercredi 8 février 2017 11:42
    mercredi 8 février 2017 11:31
  • je vous remercie pour votre réponse !

    dans ce cas comment puis je la connecter à internet !! 

    mercredi 8 février 2017 11:38
  • avec un pont 

    Ouvrez le Centre Réseau et partage 

    A droite, cliquez sur :
    -> Modifier les paramètres de la carte
     
    Sélectionnez les 2 connexions souhaitées en maintenant la touche CTRL
     
    Clic droit sur une des connexions :
    -> Connexions de pont

    Merci, a+


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 11:51
  • quand j'ai essayer de créer le pont que vous m'avez suggérer, le serveur à redémarrer a nouveau !!

    en faite toute manœuvre qui touche au paramètres des cartes réseaux provoque un redémarrage du serveur même quand je travail avec les carte qui ne son pas branché !!!

    merci 
    mercredi 8 février 2017 12:12
  • il faut faire la mise a jour de vos pilote, 

    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    mercredi 8 février 2017 12:47
  • les pilotes sont bien mis a jours !! 

    au démarrage du serveur le pont a été créer mais le réseau est toujours pas identifier !!! et la vm n'est toujours pas connecter !! pareil pour son adressage ip, il s'agit bien des adresse APIPA 

    en faite je ne comprend pas la raison de ces redémarrage, est c que ça me fait toujours revenir a cette réponse : commutateur externe

    Bonjour,

    à chaque redémarrage du serveur un ensemble d'erreur est généré, parmi celle la j'ai l'erreur event id 219 : le driver d’un périphérique à été mal chargé en raison d’un dysfonctionnement du périphérique comme expliquer ci dessous :

    https://social.technet.microsoft.com/wiki/contents/articles/3164.event-id-219-windows-kernel-pnp.aspx

    Pour l’action recommandée par la communauté Microsoft :

    Vérifiez auprès du fabricant de votre appareil si un pilote de périphérique mis à jour est disponible (ce qui n’est pas le cas du moment tous les périph sont mis à jours  la on parle des cartes réseaux) 

    En vérifiant dans le site de hp pour les serveur HP Proliant BL460c G6,  j’ai trouvé que dans la série de serveur BL, Windows server 2016 est pris en charge à partir de la génération 8

    http://h17007.www1.hpe.com/us/en/enterprise/servers/supportmatrix/windows.aspx

    et pour la mise  à jour du pilote de la carte réseau pour Windows server 2016 ne pout pas se faire aussi parce que les mise a jours sont disponible  jusqu’à Windows server 2012 R2

    http://h20565.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=3884100

    voila c'est les réponses que j'ai pu m'apporté, si vous avez d'autre piste pour que je puisse le faire sous ce serveurs je vous remercie de m'y orienté.

    Merci a tous 

    bien cordialement 



    merci 




    • Modifié Racha_SD mercredi 8 février 2017 14:39
    • Marqué comme réponse Racha_SD lundi 13 février 2017 07:49
    mercredi 8 février 2017 13:11
  • le problème vient de l'incompatibilité de matériel avec le système windows 2016. 

    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    dimanche 12 février 2017 09:26
  • Pour qu'une VM se connecte à Internet, il faut que sa connexion réseau soir liée à un switch virtuel externe créé dans Hyper-V.

    Pour ma part, je commencerais par chercher pourquoi le serveur redémarre lorsque tu manipules les cartes réseaux. As tu regardé dans l'observateur d'événements les erreurs à ce sujet ?

    mardi 14 février 2017 11:14
  • Bonjour,

    oui j'ai bien vérifier dans l'observation des événements les erreurs spécifier après chaque redémarrage une suite d'event id est afficher en relation avec l'erreur dont l'event id 219, qui es spécifier lorsqu'il y a une erreur de chargement d'un driver, 

    j'ai bien mis a jour les driver !! (automatiquement parce que quand j'ai essayer de le faire manuellement le serveurs a redémarrer à nouveau ) 

    en vérifiant dans le site du constructeur du serveur j'ai trouvé qu'il supporte jusqu'à windows server 2012 

    mais la question qui s'impose, st ce que je ne peut pas utiliser ce serveur pour évaluer la version windows server 2016 !! est ce que je peut qualifier l'erreur d'une incompatibilité matériel  ?

    mardi 14 février 2017 11:24