none
Error creating search index components

    Question

  • Hi

    I am setting up Search on a new SP2013 farm using this article. My setup is different in that respect that I have two combined web/app servers and two dedicated search servers (called IDX1 and IDX2).

    When running the script to create the index components, it fails:

    New-SPEnterpriseSearchIndexComponent : Cannot bind parameter 'RootDirectory' to the target. Exception setting "RootDirectory": "Could not find a part of the path ...

    The reason is apparently that the script that is running on the CA-server is looking for the locations for the primary and replica copies on the local server rather than on the two IDX-servers.

    How can I change the script in order to tell it to look on specific servers?

    And what security permissions are nescessary in the index directories?

    Thanks,

    Jakob

    mercredi 24 juillet 2013 09:19

Réponses

  • Hi J.Rohde,

    This is an know issue.

    Cannot bind parameter 'RootDirectory' to the target. Exception setting ""RootDirectory"": ""Could not find a part of the path 'd:\index4'."

    Workaround    You can create the new index component using the following procedure instead:

    $host02 = (Get-SPServer"<Name of server>").Name

    $ssa = Get-SPEnterpriseSearchserviceApplication

    $t = $ssa.ActiveTopology.Clone()

    $ic = (New-Object Microsoft.Office.Server.Search.Administration.Topology.IndexComponent $host02,1);

    $ic.RootDirectory =""d:\index4"

    $t.AddComponent($ic)"

     

    Thanks,

    Jack


    Jack Gao
    TechNet Community Support

    dimanche 28 juillet 2013 03:47
    Modérateur

Toutes les réponses

  • Hi J.Rohde,

    This is an know issue.

    Cannot bind parameter 'RootDirectory' to the target. Exception setting ""RootDirectory"": ""Could not find a part of the path 'd:\index4'."

    Workaround    You can create the new index component using the following procedure instead:

    $host02 = (Get-SPServer"<Name of server>").Name

    $ssa = Get-SPEnterpriseSearchserviceApplication

    $t = $ssa.ActiveTopology.Clone()

    $ic = (New-Object Microsoft.Office.Server.Search.Administration.Topology.IndexComponent $host02,1);

    $ic.RootDirectory =""d:\index4"

    $t.AddComponent($ic)"

     

    Thanks,

    Jack


    Jack Gao
    TechNet Community Support

    dimanche 28 juillet 2013 03:47
    Modérateur
  • Missing 

    Set-SPEnterpriseSearchTopology -Identity $t

    vendredi 1 juin 2018 13:55