locked
Problème redémarrage automatique WSUS RRS feed

  • Discussion générale

  • Bonjour,

    Je rencontre un problème très pénalisant

    J'utilise un serveur WSUS sur 2008 avec des stations de travail en Windows 7.

    Une GPO configure les stations de travail.

    Tout fonctionne très bien SAUF : que les PC redémarre automatiquement après les mise à jour... cela est vraiment problématique pour les utilisateurs.

    Je constate également que les mises à jour ne se font pas en temps et en heure comme précisé dans la GPO...

    Voici les paramètres de cette GPO :

    Pouvez-vous m'aider, je désespère un peu...

    Merci d'avance !!!!

    mercredi 13 mai 2015 08:13

Toutes les réponses

  • Voici les paramètre de la GPO : (j'arrive pas à insérer des images dans le forum...)

    - Pas de redémarrage automatique : ACTIVE

    - Configuration de service de mise à jour : option 4 - planifiée pour les mercredi à 23 heures

    - autorisé les non administrateurs : ACTIVE

    mercredi 13 mai 2015 08:18
  • Salut,

    As tu créés un groupe sur wsus avec tous les pc ?

    mercredi 13 mai 2015 08:30
  • La GPO s'applique à tous les ordinateurs du domaines

    (un filtre WMI exclu le serveur...)

    Tous les PC sont visibles dans la console de gestion de WSUS.

    La communication avec les serveur fonctionne très bien.

    C'est juste le redémarrage qui pose problème.

    Merci d'avance...

    mercredi 13 mai 2015 08:34
  • Personne pour  plus d'idée  ???!!!

    JJacques

    jeudi 14 mai 2015 08:05
  • Bonjour,

    Avez-vous vérifié que les paramètres du GPO sont bien appliqués sur les postes ?

    Pour vous en assurer, depuis un contrôleur de domaine, lancez gpmc.msc, et lancez un Résultats de stratégie de groupe pour un poste posant problème.

    Pour information, le paramètre "Pas de redémarrage automatique avec des utilisateurs (...)" ne s'appliquent que dans le cas où des utilisateurs sont connectés sur la machine.
    De plus, dans cette configuration, l'utilisateur se voit proposer un redémarrage, et une mauvaise séquence de touches lors de l'affichage de ce message peut provoquer le redémarrage.



    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 09:24
  • Bonjour,

    Je confirme que les GPO s'appliquent bien aux postes de travail (avec GPResult /r) et avec la console gpmc.msc
    En allant voir dans Regedit des postes, tous les paramètres sont bien renseignés pour le Windows Update.

    Et NoAutoRebootWithLoggedOnUsers a bien la valeur 1 !!!

    Je sais vraiment pas d'où vient ce problème...

    Le bouton "reporter" de la fenêtre de redémarrage est grisé et impossible donc d'annuler ou reporter le redémarrage...

    JJacques

    vendredi 15 mai 2015 09:31
  • Je suppose que vous n'avez pas configuré le paramètre de stratégie "Délai de redémarrage pour les installations planifiées".
    Ce paramètre a les propriétés suivantes :

    • Si Désactivé ou Non configuré : un redémarrage planifié se produira au bout de 15 minutes
    • Si Activé : vous pouvez planifier le redémarrage automatique au bout de X minutes (X à définir dans la stratégie)

    Ce paramètre s'applique automatiquement du moment que vous choisissez de planifier l'installation des mises à jour.

    Vous devez donc configurer ce paramètre, et laisser 60 minutes (ou plus) à vos utilisateurs avant que le redémarrage automatique ne se produise.

    En parallèle, un peu de formation à vos utilisateurs pour leur indiquer comment agir lorsque la notification apparaît.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 09:37
  • Le problème est que le bouton "reporter" n'est pas accessible, il est grisé !!!!!

    JJacques

    vendredi 15 mai 2015 09:39
  • Si j'active ce paramètre, le bouton "reporter" devient accessible ??

    JJacques

    vendredi 15 mai 2015 09:42
  • Quel bouton "reporter"? Vous parlez de la possibilité pour l'utilisateur de reporter le redémarrage automatique?

    Comment indiqué dans le post précédent, si vous choisissez d'effectuer une installation planifiée (option 3), le redémarrage est obligatoirement planifié.

    Vous avez la possibilité de choisir la durée de grâce avant le reboot automatique avec le paramètre "Délai de redémarrage pour les installations planifiées".

    Le bouton "reporter" est disponible dans le cas d'installation à la demande de l'utilisateur (options 2 et 3) : l'utilisateur déclenche l'installation manuellement, et Windows lui propose de reporter le redémarrage.

    Si vous choisissez une installation planifiée, le reboot est obligatoirement planifié.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 09:43
  • - Quel bouton "reporter"? Vous parlez de la possibilité pour l'utilisateur de reporter le redémarrage automatique?

    Oui il s'agit bien de ce bouton.

    - Comment indiqué dans le post précédent, si vous choisissez d'effectuer une installation planifiée (option 3), le redémarrage est obligatoirement planifié.

    L'installation planifié est l'option 4, pas 3 ??!!

    Et quand vous dites obligatoirement, on ne peut le reporter alors ?

    C'est spécifié dans aucune aide ou forum...

    Et du coup l'option "ne pas redémarrer si un utilisateur est connecté" n'a aucun sens, dans les explications ils disent que c'est pour les installations planifiées (option 4)... !

    - Le bouton "reporter" est disponible dans le cas d'installation à la demande de l'utilisateur (options 2 et 3) : l'utilisateur déclenche l'installation manuellement, et Windows lui propose de reporter le redémarrage.

    On parle alors de l'option 3 !!

    Bon le problème avec cette option est que l'utilisateur peut ne pas effectuer les mises à jours...

    Mes postes s'éteignes tous avec un shutdown en tache planifié le soir déployé par GPO.

    Serait-t-il possible alors de forcer l'installation de ces mises à jour avant ou avec le shutdown ?


    JJacques

    vendredi 15 mai 2015 11:57
  • Pardon pour le numéro d'option : c'est une erreur de frappe. L'installation planifiée est bien l'option 4.

    Quand je dis obligatoirement, c'est qu'il n'y a pas de possibilité de report pour l'utilisateur*.

    L'élément de stratégie "Délai de redémarrage pour les installations planifiées" permet de gérer le délai de redémarrage.

    En effet, lors de l'utilisation de l'option 4, le redémarrage est planifié immédiatement après l'installation (c'est une deadline).

    L'option "Ne pas redémarrer si un utilisateur est connecté" : 

    • Si non configurée ou Désactivé : une fois l'installation des mises à jour terminée, l'utilisateur est averti que l'ordinateur redémarrera dans 5 minutes.
    • Si Activé : une fois l'installation des mises à jour terminée, l'utilisateur est averti* qu'il faut redémarrer. Et un compteur de 15 minutes avant un redémarrage automatique démarre.
      Ce compteur de 15 minutes est modifiable au travers de la stratégie "Délai de redémarrage pour les installation planifiées".

    *Pour que l'utilisateur soit avertit du redémarrage et qu'il ait la possibilité de le reporter (1 seule fois), il faut que le paramètre de stratégie "autoriser les non-administrateurs à recevoir les notifications de mise à jour" soit activé.

    Pour une meilleure gestion des mises à jour automatiques, l'idéal est d'utiliser SCCM (System Center Configuration Manager), qui permet d'établir (entre autres), une fenêtre de maintenance et, du coup, permet de forcer les installations et redémarrage pendant ces périodes.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 12:45
  • Bon, je vais mettre l'option sur 3 et voir comment je peux forcer l'installation des mises à jour...

    JJacques

    vendredi 15 mai 2015 13:12
  • autre idée a essayer : mettre les mises à jour le soir à 17 heures.

    si une mise à jour est manquée (poste éteint) je reporte la mise à jour à la prochaine date planifiée

    (option Replanifier les installations planifiées = désactivé)

    A voir...


    JJacques

    vendredi 15 mai 2015 13:51
  • C'est la moins mauvaise solution.

    Pour ma part, j'utiliserai l'option 4 à 17h00 en programmant un délai de redémarrage de 4 heures.

    En parallèle, j'informe mes utilisateurs de choisir "Installer les mises à jour et éteindre" en quittant le travail. S'ils le font, tant mieux. S'ils ne le font pas, à 21h le reboot installera les mises à jour.

    Le script de 23h effectuera l'extinction du poste.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 13:56
  • comment faites-vous un reboot programmé ?

    JJacques

    vendredi 15 mai 2015 14:03
  • Je l'ai déjà écrit au moins 2 fois : "Délai de redémarrage pour les installation planifiées"


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 14:09
  • ah oui pardon j'ai zappé ce paramètre !!

    problème je n'ai que 30 min max avec ce paramètre...


    JJacques

    vendredi 15 mai 2015 14:12
  • Dans ce cas, mise à jour à 18h30, délai = 30 minutes.

    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    vendredi 15 mai 2015 14:26
  • c'est fait... faut attendre les prochaines mises à jour maintenant...

    à moins qu'il est possible de tester sans avoir des mises à jour de Windows ?!


    JJacques

    vendredi 15 mai 2015 14:38
  • Bonjour,

    Tu peux forcer la détection des mises à jour sans attendre le prochain schedule :

    > cmd.exe en tant qu'Admin depuis un poste clt (W7)

    > saisir : wuauclt /ResetAuthorization /DetectNow

    Merci de nous informé des résultats

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    vendredi 15 mai 2015 18:58
  • Bonjour à tous,

    Visiblement le problème semble résolu (je dis semble car il n'y a pas de grosse MAJ en ce moment)

    En tout cas, les PC ne reboot plus en plein milieu de la journée.

    Donc pour résumer,

    J'ai mis les mises à jour le soir à 17h (extinction des postes à 20h).

    Si une mise à jour est loupée (PC éteint), reporter la mise à jour à la prochaine date et non lors du prochain allumage du PC.

    Voilà tout !


    JJacques

    vendredi 29 mai 2015 11:32
  • Bonjour, jjacques68,

    Je vous remercie d'avoir partagé la solution du problème avec la communauté du forum.

    Cordialement,
    Téodora

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    dimanche 31 mai 2015 18:55
  • Bonjour

    je vous partage ma gpo pour les machines afin d'appliquer les mises a jours san,s redémmarage  et aussi cette gpo s'applique avec les optiosn au admin de uploader puis selectionné et installer apres si cela vous convient us version :(


    Partager c'est avancer : Votez!SVP

    lundi 1 juin 2015 13:41
  • Re-bonjour,

    Bon ben visiblement ça marche pas.

    Je continue à avoir des reboot après quelques minutes du démarrage.

    Lors de ces démarrages, il continue à chercher les mise à jour sur le serveur WSUS.

    Il semble ne pas tenir compte du paramètre de reporter les mises à jours à la date suivante...

    Je me demande si cela ne vient pas du fait que le serveur est un server 2008 (et non R2) qui fait pour gérer des postes XP-Vista. Notre parc est en Windows 7.


    JJacques

    vendredi 12 juin 2015 13:52
  • bonjour

    vous pouvez partager svp l'imprime ecrans de vos parametres ?

    merci


    Partager c'est avancer : Votez!SVP

    mercredi 17 juin 2015 10:49
  • Bonjour, voici mes paramètres :

    je précise juste que je viens de changer "configuration de la mise à jour" et de le mettre sur 3 pour voir si j'ai encore ces redémarrages...

    Mais lors de mes explications ci-dessus, il était sur 4, installation planifié.

    Le problème vient bien des PC qui sont restés éteins le soir. Le lendemain, si on allume ce PC, il me fait de suite l'installation des mises à jour, et donc reboot automatiquement après.

    Si les PC restent allumer, l'installation se passe le soir sans que cela ne dérange.


    JJacques

    mercredi 17 juin 2015 17:10
  • Bonjour, jjacques68,

    Le thread est-il toujours actuel?
    Merci de nous tenir au courant.

    Cordialement,
    Téodora

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 30 juin 2015 22:03
  • Bonjour, Le problème n'est toujours pas réglé. J'attends toujours de l'aidé, idées ou remarques à ce sujet. Merci !!

    JJacques

    mercredi 1 juillet 2015 04:32