none
Unable to stop incremental crawl for few content source on SharePoint 2013 on-premise

    Question

  • Hi,

    We have enterprise search setup on SharePoint 2013 on-premise environment. We are using Business Data Connectivity service for getting data from external source. Crawl on content source related to external data  is running from past few days and are not getting stopped. To stop the crawl we tried below steps:

    1. Tried to stop from CAà Search Service Application
    2. Stopped SharePoint Server Search 15 service by selecting “Set First Failure and Second Failure to “Take no action”” in properties
    3. Recycled App Pool
    4. Tried to stop all crawl using PowerShell “http://www.sharepointdiary.com/2015/05/force-stop-sharepoint-search-crawl-using-powershell.html

    But unfortunately we are unable to stop the crawl.

    Please share your ideas/thoughts to achieve.

    Regards,

    Sudheer


    Thanks & Regards, Sudheer

    lundi 11 juin 2018 14:46

Toutes les réponses

  • Hi Sudheer,

    How many servers exist in your SharePoint farm?

    You need to stop the “SharePoint Server Search 15” on all the SharePoint servers in the farm.

    You can also try the following cmdlet to stop the instance of a search service. You need to run it on each server in the farm.

    stsadm -o osearch -action stop


    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    mercredi 13 juin 2018 02:41
    Modérateur
  • Hi,

    Thanks for response.

    There are 2 web front end server, 2 search server, 2 application server and 2 SQL server in the farm.

    We have stopped SharePoint Server Search 15 service on both the search server but unfortunately we are still unable to stop crawl for content source related to BDC. Stopping service on all server  you mean on WFE, application and SQL server as well ?

    Regards,

    Sudheer


    Thanks & Regards, Sudheer

    mercredi 13 juin 2018 05:43
  • Hi,

    please clear config cache on all servers, then compare the results.

    Check the logs, try to get more information about this issue.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    lundi 18 juin 2018 07:57
    Modérateur