none
Synchronization failed on Upstream WSUS 3.0 on Windows 2003 SP2

    Question

  • Hi,

    Since april 5, we have synchronization failed with our Upstream WSUS 3.0 on Windows 2003 SP2.

    The error reported in the SoftwareDistribution.log is as follows:

    2018-04-09 11:04:40.395 UTC Warning WsusService.27 WebServiceCommunicationHelper.ProcessWebServiceProxyException ProcessWebServiceProxyException found Exception was WebException. Action: Retry. Exception Details: System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host

    We have another Upstream WSUS 3.0  server on Windows 2008 with the same configuration proxy server and credentials and the synchronization to Microsoft Update is OK.

    Any suggestion please ?

    Luis


    • Modifié LuisOLI lundi 9 avril 2018 12:37
    lundi 9 avril 2018 11:37

Toutes les réponses

  • Thanks for posting this. We also are in the exact same situation, our upstream WSUS 3.0 on 2003 SP2 failing with the above error.

    It appears MS may have made some changes around March 9 which impacted WSUS synchronizations running on 2003 server?

    lundi 9 avril 2018 14:03
  • Hi LuisOLI,

    Try installing KB4039929. That worked for us (for now - someone else said their synch issue resurfaced a couple weeks after installing this).

    lundi 23 avril 2018 16:59
  • Hi,

    There is no server 2003 in my environment. So not many ideas.

    I suggest you try to install the KB4039929 as KCSteele said.


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    mardi 24 avril 2018 01:53
  • Hi KCSteele,

    We have exactly the same situation from 27th March. Then after installing KB4039929, server sync for several days and it is failing again. The strange thing is that when I install KB now it is going to sync only one time and then it is failing again.



    • Modifié gregguz jeudi 3 mai 2018 13:47
    jeudi 3 mai 2018 13:46
  • Bump, broken.... Is all still yet another undocumented problem once again NOT provided by Microsoft. They're about as useful as Windows for Workgroups 3.11 these days. 
    lundi 7 mai 2018 11:18
  • We assumed that it was changed from April due to TSL problem.
    It surely syncs when installing KB 4039929.
    What should I do if I stop after a few days?
    mercredi 9 mai 2018 06:04
  • Hi,

    I've found that installing the KB4039929 works for the very next manual synchronization. However, at least in our situation, any subsequent automatic synchronizations still fail. Manual is hit or miss, I believe 1 out of the 4 last manual syncs I have done since my last post here, I have not had to reinstall the KB4039929 immediately beforehand. The other 3 times the manual sync failed until I reinstalled KB4039929. 

    So if it stops after a few days, reinstall KB4039929 and then try a manual sync - works in our case.

    • Proposé comme réponse hanzou1976 mercredi 9 mai 2018 23:46
    mercredi 9 mai 2018 16:14
  • It is written that reinstallation of KB 4039929
    Is there no deletion and everyone in restoration doing?
    mercredi 9 mai 2018 23:46
  • Always after synchronization
    KB4039929 is setting in WSUS-database, table dbo.tbConfigurationB, 
    column MUUrl, value 'https://update.microsoft.com/v6'. 
    Then synchronisation works. After synchronisation, 
    this value is automaticaly updated to
    'https://sws1.update.microsoft.com'. With updated value, it is not working again
    I hope to rewrite it every time
    https://sws1.update.microsoft.com Is it broken?
    jeudi 10 mai 2018 04:02
  • Fixed with https://support.microsoft.com/en-us/help/948963/an-update-is-available-to-add-support-for-the-tls-rsa-with-aes-128-cbc

    Updates W2K3 rsaenh.dll and is working fine with scheduled synchronizations.

    • Proposé comme réponse daroy jeudi 14 juin 2018 10:49
    • Non proposé comme réponse daroy jeudi 14 juin 2018 10:55
    • Proposé comme réponse daroy jeudi 14 juin 2018 10:55
    dimanche 3 juin 2018 04:01
  • Fixed with https://support.microsoft.com/en-us/help/948963/an-update-is-available-to-add-support-for-the-tls-rsa-with-aes-128-cbc

    Updates W2K3 rsaenh.dll and is working fine with scheduled synchronizations.

    This fixed our problem.
    jeudi 14 juin 2018 11:05