locked
Windows server 2K8 Core - Commande introuvable config firewall. RRS feed

  • Question

  • Bonjour,

    Je viens de débuter dans l'utilisation de Windows Serveur 2008 R2 et je rencontre quelques difficultés lors de la création de mon bac à sable (j'utilise un livre qui me guide dans l'utilisation).

    J'ai donc un serveur windows 2008 R2 en installation minimale (core) en  français et donc uniquement l'invite de commande.

    Je n'arrive pas à activer la règle dans le firewall pour permettre les réponses ICMP et l'accès au partages réseau.

    J'ai trouvé un article sur le support microsoft (http://www.microsofttranslator.com/BV.aspx?ref=CSSKB&lo=SS&from=en&to=fr&a=http://support.microsoft.com/kb/947709/en-us?fr=1) mais la traduction est nulle et donc, la commande ne fonctionne pas.

    Voici la commande en question que j'aurai besoin mais en français :
    netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=Yes

    Voici ce que j'ai essayé de rentrer mais sans succès :

    netsh advfirewall firewall set rule group="Partage de fichiers et d'imprimantes" new enable=yes

    et donc voici les messages d'erreurs :

    Aucune règle ne correspond aux critères spécifiés

    Est ce quelqu'un pourrait m'indiquer la syntaxe correcte pour que cette commande fonctionne ?

    Merci d'avance.

    vendredi 24 août 2012 08:55

Réponses

  • j'ai trouvé une solution.

    J'ai passé mon serveur en anglais avec la KB974587 fournie sur le site officiel puis j'ai ouvert le menu [b]control intl.cpl[/b], changé la langue puis essayé la commande anglais : netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes

    Et là.. c'est pris en compte et j'ai toutes les modifs que je voulais. J'ai ensuite re-changé en français.

    PS : en français, la commande ne fonctionnait tjrs pas.

    lundi 3 septembre 2012 17:00
  • netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes

    Utiliser des " et pas des '

    lundi 27 août 2012 15:17

Toutes les réponses

  • Ce n'est pas très propre, mais si vous voulez juste le nom du group, vous pouvez faire un netsh advfirewall firewall show rule name=all et retrouver le nom du groupe.

    Avez vous essayé avec le nom anglais "File and Printer Sharing" ? A noter, l'apostrophe ' n'a pas besoin d'être doublé dans netsh.

    vendredi 24 août 2012 09:58
  • Merci à toi de bien vouloir m'aider.

    Je ne fais que suivre un ouvre intitulé "Windows Server 2008 : Installation, configuration, gestion et dépannage. 2éme edition" de chez Eni.

    Malheureusement, la commande est incorrecte dans le script qui est fourni. C'est pour ça que je cherche une solution pour avancer un peu. J'ai même essayé de contacter l'auteur mais sans réponse de sa part.

    Quand j'essaye la commande :

    netsh advfirewall firewall set rule group='File and Printer Sharing' new enable=yes

    J'obtiens :

    Impossible de spécifier le groupe avec d'autres conditions d'identification.

    vendredi 24 août 2012 11:36
  • Vous utilisez bien un compte administrateur pour lancer la commande?
    lundi 27 août 2012 08:14
  • Oui, je suis bien avec le compte administrateur :)
    lundi 27 août 2012 14:14
  • netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes

    Utiliser des " et pas des '

    lundi 27 août 2012 15:17
  • j'ai trouvé une solution.

    J'ai passé mon serveur en anglais avec la KB974587 fournie sur le site officiel puis j'ai ouvert le menu [b]control intl.cpl[/b], changé la langue puis essayé la commande anglais : netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes

    Et là.. c'est pris en compte et j'ai toutes les modifs que je voulais. J'ai ensuite re-changé en français.

    PS : en français, la commande ne fonctionnait tjrs pas.

    lundi 3 septembre 2012 17:00