none
Envoi de mail impossible (erreur 16025/205) RRS feed

  • Question

  • Bonjour,

    Je viens de mettre en place un serveur Exchange mais l'envoi de mail est impossible, les messages vont directement vers la case brouillon. L'Active Directory (qui est sans DNS) et l'Exchange sont sur le même serveur

    Le serveur est directement avec WAN avec une IP publique. Les DNS sont ceux de Google (8.8.8.8 et 8.8.4.4). 

    Sur l'interface administration, j'ai bien configuré les DNS de la carte réseau.

    Dans le journal d'event, Windows m'affiche deux erreurs à chaque envoi de mail :

    ID 16035 : Aucun serveur DNS n'a pu être récupéré de la carte réseau %1. Vérifiez si l'ordinateur est connecté à un réseau et si la cmdlet Get-NetworkConnectionInfo renvoie des résultats.

    ID 205 : Aucun serveur DNS n'a pu être récupéré à partir de la carte réseau %1. Vérifiez que l'ordinateur est connecté à un réseau et que la fonction Get-NetworkConnectionInfo renvoie des résultats.

    Pourtant, la résolution nslookup se fait bien à partir du serveur Exchange.

    Avez-vous une idée?

    Merci.

    lundi 11 mai 2015 14:23

Réponses

  • L'Active Directory (qui est sans DNS) et l'Exchange sont sur le même serveur

    La bonne pratique est :

    • installer AD avec DNS
    • installer Exchange sur un autre serveur que l'AD

    Je suis persuadé que cela fonctionnera mieux après (et en plus que cela ne fonctionnera jamais dans cette configuration).


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    lundi 11 mai 2015 14:37
    Modérateur
  • A : le nom du serveur Exchange (exemple : mail.domain.com)

    MX : le FQDN du serveur Exchange (exemple : mail.domain.com)

    SRV : _autodiscover._tcp.domain.com -> mail.domain.com port 443

    Je vous conseille de verrouiller le pare-feu de ces 2 machines pour n'exposer que le port 443 du serveur Exchange et uniquement le port 53 de l'AD à Internet (si le DNS de l'AD est le DNS publique pour votre domaine publique) sinon je ne donne pas 1 semaine à vos machines....


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    lundi 11 mai 2015 15:05

Toutes les réponses

  • L'Active Directory (qui est sans DNS) et l'Exchange sont sur le même serveur

    La bonne pratique est :

    • installer AD avec DNS
    • installer Exchange sur un autre serveur que l'AD

    Je suis persuadé que cela fonctionnera mieux après (et en plus que cela ne fonctionnera jamais dans cette configuration).


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    lundi 11 mai 2015 14:37
    Modérateur
  • Bonjour,

    Outre les bonnes pratiques, ma configuration ne peut pas être fonctionnelle ?

    lundi 11 mai 2015 14:46
  • +Bruce JDC

    Il est fortement récommandé d'utiliser la configuration mentioné par Bruce JDC, 

    et je vous propose de jeter un coup d'oueil sur ce lien afin de vérifier les DNS qui peux etre deployer avec Exchange. https://support.microsoft.com/en-us/kb/2269838


    vote if you think useful

    lundi 11 mai 2015 14:57
  • Je vais de ce pas installer l'AD/DNS et l'Exchange sur des serveurs différents.

    Comme l'AD/DNS et l'Exchange seront en WAN avec des IP publiques pour une phase de test (risqué mais je n'ai pas le choix), quels sont les enregistrements MX,CNAME et A que je dois rentrer dans le DNS ?

    Merci pour vos réponses.

    Cordialement.

    lundi 11 mai 2015 15:02
  • Non, vous configuration ne peut pas fonctionner car le serveur doit être en mesure de pouvoir interroger son propre DNS (127.0.0.1) pour la résolution DNS nécessaire à Active Directory (ce qui n'est pas le cas avec les DNS 8.8.8.8 et 8.8.4.4).

    Comme l'a indiqué Bruce, vous devez avoir :

    • un serveur AD avec DNS
    • un serveur Exchange avec une connexion LAN sur le même réseau que l'AD. DNS principal = IP de l'AD

    Je ne vous conseille pas d'exposer directement le serveur Exchange à Internet, mais de passer par l'intermédiaire d'un routeur/firewall (pour des raisons évidentes de sécurité).

    PS : je suppose que vous êtes sous Windows Server 2008 ou 2012 ? Dans ce cas, vous avez la possibilité d'activer le rôle Hyper-V et de créer 2 VM (1 pour l'AD, 1 pour l'Exchange) pour être dans les bonnes pratiques.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    lundi 11 mai 2015 15:02
  • A : le nom du serveur Exchange (exemple : mail.domain.com)

    MX : le FQDN du serveur Exchange (exemple : mail.domain.com)

    SRV : _autodiscover._tcp.domain.com -> mail.domain.com port 443

    Je vous conseille de verrouiller le pare-feu de ces 2 machines pour n'exposer que le port 443 du serveur Exchange et uniquement le port 53 de l'AD à Internet (si le DNS de l'AD est le DNS publique pour votre domaine publique) sinon je ne donne pas 1 semaine à vos machines....


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr

    lundi 11 mai 2015 15:05
  • Une dernière question : Je sais que les bonnes pratiques ne le conseillent pas, mais je possède une seule licence 2012R2 Standard et non une Datacenter. C'est pour cela que je suis obligé de mettre l'AD et le serveur mail sur le même serveur  n'ayant pas le budget pour acheter une seconde licence. Cela peut-il fonctionner ?

    Merci pour vos précieux conseils. Je reviendrai vers vous pour vous informer de la finalité du projet.

    Cordialement.

    lundi 11 mai 2015 15:16
  • Cela peut-il fonctionner ?

    Peut-être, mais probablement pas.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 12 mai 2015 08:16
    Modérateur
  • En suivant vos conseils, tout marche bien à présent. Merci pour vos conseils :)

    Bonne journée.


    mardi 19 mai 2015 08:29