locked
MDT Windows PE Clavier en français AVANT lancement du Script LiteTouch.vbs RRS feed

  • Discussion générale

  • Bonjour,

    JE vous explique mon problème, j'utilise la technique de l'exe compilé décrite dans ce post :http://itbloggen.se/cs/blogs/micke/archive/2011/01/26/password-or-pin-code-protect-mdt-2010-litetouch.aspx

    Elle consiste à compiler un exe avec autoIT pour ajouter une boîte de message avec la possibilité d'entrer un code, si le code n'est pas bien entré, je reboot la machine.

    Mon problème est que l'executable se lance avant le script LiteTouch.vbs et le clavier n'est pas tout de suite en français, du coup, quand la personne veut taper le code, le clavier est en anglais.

    J'ai bien essayé de modifié le unnatend_PE_X64.xml dans Templates mais cela change rien.

    Bien entendu, j'ai bien configuré le bootstrap.ini :

    KeyboardLocalePE=100c:0000100c

    Sinon j'avais pensé à faire du DISM, mais je trouve un peu lourd et surtout cela va être écrasé dès qu'on update le partage.

    Voici le fichier en question :

     

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
     <settings pass="windowsPE">
     <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
      <Display>
      <ColorDepth>16</ColorDepth>
      <HorizontalResolution>1024</HorizontalResolution>
      <RefreshRate>60</RefreshRate>
      <VerticalResolution>768</VerticalResolution>
      </Display>
    		<RunSynchronous>
    		<RunSynchronousCommand wcm:action="add">
       <Description>Lite Touch PE</Description>
       <Order>1</Order>
       <Path>x:\CleanSetupInProgress.cmd</Path>
      </RunSynchronousCommand>
      <RunSynchronousCommand wcm:action="add">
       <Description>Lite Touch PE</Description>
       <Order>2</Order>
       <Path>wscript.exe X:\Deploy\Scripts\LiteTouch.wsf</Path>
      </RunSynchronousCommand>
      </RunSynchronous>
    	</component>
     <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SetupUILanguage>
      <UILanguage>fr-FR</UILanguage>
      </SetupUILanguage>
      <InputLocale>100C:0000100C</InputLocale>
      <SystemLocale>fr-CH</SystemLocale>
      <UILanguage>fr-FR</UILanguage>
      <UserLocale>fr-CH</UserLocale>
     </component>
     </settings>
    </unattend>

    Merci de votre aide.


    MCITP Enterprise Administrator / Server Administrator
    vendredi 18 février 2011 13:55

Toutes les réponses