none
Problème de processus depuis màj CRM Dynamics Online - Automn 2013 RRS feed

  • Question

  • Bonjour,

    Nous venons de passer à la dernière version du CRM Microsoft Dynamics Online (Automn 2013) et depuis celle-ci, les workflows que j'avais paramétré pour mes opportunités ne fonctionnent plus.

    J'avais paramétrer un premier workflow qui permettait d'automatiser la probabilité de l'opportunité en fonction de la phase de vente (nous avons défini comme phase de vente le SPANCO Suspect, Prospect, Approche, Négociation, Commande et Order).
    Deuxième workflow paramétré : le calcul du revenu pondéré en fonction du revenu estimé et de la probabilité.

    Avant tout fonctionnait très bien, et était automatique dès qu'on enregistrait l'opportunité.
    Je pense que le problème provient de mon premier workflow, celui des probabilités et plus particulièrement dans l'identification de la phase de vente car désormais les phases de vente se trouve au niveau du ruban supérieur des opportunités.

    Ma question : comment j'identifie le bon nom du champ correspondant aux phases de vente du ruban ? Car quand je vais dans l'option "Formulaire" des opportunités, le ruban supérieur n'apparaît pas. Comment je paramètre mon workflow en fonction des données de ce ruban, c'est à dire le processus de vente des Opportunités ?

    Merci beaucoup à ceux qui pourront m'aider !



    jeudi 21 novembre 2013 17:46

Réponses

  • Bonjour,

    Les phases de ventes ne correspondent pas à un champ de l'entité. Comme un workflow peut se déclencher sur l'événement de modification d'un champ, vous devez créer au moins un champ.

    Une solution possible est de créer un champ pour chaque étape de type Deux options avec les valeurs : Marquer comme terminé et Terminé. Ce champ dans une phase de vente permettra d'identifier si l'étape est terminée avant de passer à l'étape suivante et surtout de déclencher le workflow.


    Philippe

    Blog : Dynamics CRM pour les francophones/for French speakers

    • Marqué comme réponse NathalieHoch mercredi 4 décembre 2013 15:52
    lundi 25 novembre 2013 17:59
  • Juste pour vous dire que ça fonctionne à nouveau.

    Je me suis basée sur ce que vous m'aviez dit mais plutôt que faire un champ pour chaque étape j'ai tout simplement créé un nouveau champ Phase de vente avec un groupe d'options qui reprend les différentes étapes de la vente. Bon c'est vrai que ça reprend les mêmes informations deux fois mais au moins mes probabilités sont changées automatiquement et le calcul pondéré de chaque opportunité fonctionne !

    Merci pour votre réponse.

    • Marqué comme réponse NathalieHoch mercredi 4 décembre 2013 15:52
    mercredi 4 décembre 2013 15:51

Toutes les réponses

  • Bonjour,

    Les phases de ventes ne correspondent pas à un champ de l'entité. Comme un workflow peut se déclencher sur l'événement de modification d'un champ, vous devez créer au moins un champ.

    Une solution possible est de créer un champ pour chaque étape de type Deux options avec les valeurs : Marquer comme terminé et Terminé. Ce champ dans une phase de vente permettra d'identifier si l'étape est terminée avant de passer à l'étape suivante et surtout de déclencher le workflow.


    Philippe

    Blog : Dynamics CRM pour les francophones/for French speakers

    • Marqué comme réponse NathalieHoch mercredi 4 décembre 2013 15:52
    lundi 25 novembre 2013 17:59
  • Bonjour,

    Merci pour votre retour. Je vais essayé cela. Je reviendrai pour dire si ça a fonctionné. Merci

    Nathalie

    mardi 26 novembre 2013 09:14
  • Juste pour vous dire que ça fonctionne à nouveau.

    Je me suis basée sur ce que vous m'aviez dit mais plutôt que faire un champ pour chaque étape j'ai tout simplement créé un nouveau champ Phase de vente avec un groupe d'options qui reprend les différentes étapes de la vente. Bon c'est vrai que ça reprend les mêmes informations deux fois mais au moins mes probabilités sont changées automatiquement et le calcul pondéré de chaque opportunité fonctionne !

    Merci pour votre réponse.

    • Marqué comme réponse NathalieHoch mercredi 4 décembre 2013 15:52
    mercredi 4 décembre 2013 15:51