none
Message is not RFC compliant; missing both "From" and "Sender" headers RRS feed

  • Discussion générale

  • Bonjour,

    Je viens vers vous pour une question sur un message de retour l'on a quand mes clients envoyent des messages vers certains domaines.

    Le message d'erreur est le suivant:
    www.nomdedomainedistant.fr a rejeté votre message aux adresses de messagerie suivantes : adresse du destinataire
    www.nomdedomainedistant.fr a généré cette erreur :
    Message is not RFC compliant; missing both "From" and "Sender" headers

    Notre configuration est la suivante: CAS/HUB en NLB & MBX en DAG le tout en Exchange SP1 R5

    Qu'est ce que j'ai raté dans la configuration de mon serveur de messagerie qui pourrait générer ce type de retour ?

    D'avance Merci pour votre aide & votre retour.
    Cordialement
    Philippe

    lundi 16 avril 2012 13:37

Toutes les réponses

  • Bonjour,

    Cela vient du fait que vos messages de NDR (non delivery) ne possedent pas d'expediteur, le serveur distant n'autorise donc pas la remise du message au destinataire car il n'y a pas d'adresse d'expediteur.

    Cela ne correspond donc pas à la norme RFC.

    Quel version d'Exchange utilisez vous ?

    Cordialement,


    Yohan LEFEVRE

    lundi 16 avril 2012 14:41
  • Bonjour,

    Merci pour ce retour.

    Tous les serveurs de messagerie sont en Exchange 2010 SP1 R5.

    Ou puis-je corriger cela dans ma configuration de notre système de messagerie ?

    D'avance Merci pour votre aide & votre retour.
    Cordialement
    Philippe

    lundi 16 avril 2012 14:46
  • Bonjour,

    Pour les utilisateurs Outlook, Exchange envoit toujours des messages comportants ces champs "From" et/ou "Sender" !

    La seule chose qui pourrait manquer dans la configuration, c'est le compte PostMaster@votreDomaine.Extension défini sur le connecteur d'envoi. Mais même dans ce cas, il n'y a pas de raison d'avoir ce type de message "FRC not compliant".

    En revanche, de nombreux scanners (outils de type scan to mail ) ne sont effectivement pas aux normes RFC. Par défaut, Exchange les refusent. Si l'on a désactivé ces vérifications, il peut arriver Exchange "relaye" ces messages vers Internet, bien qu'ils ne soient pas conformes.

    A+


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info

    lundi 16 avril 2012 14:50
    Modérateur
  • Bonjour,

    Ouvrez un Exchange Management Shell en tant qu'Administrateur et entrez la commande  suivante :

    Set-TransportConfig -ExternalPostmasterAddress postmaster@contoso.com

    remplacez "postmaster@contoso.com" par une adresse e-mail de votre choix en correspondance avec un de vos noms de domaine.

    Cordialement,


    Yohan LEFEVRE - MCTS / MCP

    lundi 16 avril 2012 14:50
  • Vous trouverez également des informations supplémentaires à l'adresse suivante :

    http://msundis.wordpress.com/2010/04/21/configure-postmaster-microsoft-exchange-recipient-and-ndr-forwarding-in-exchange-server-2007-and-2010/

    Cordialement,


    Yohan LEFEVRE - MCTS / MCP

    lundi 16 avril 2012 14:51
  • Quand je regarde depuis une EMC, le connecteur d'envoi qui est défini dans notre organisation, il y a bien un nom FQDN d'indiqué.

    Par contre quand je fais un Get-TransportConfig, il n'y a pas d'adresse.

    Cela ne devait pas être la même ??

    Sinon je peux la renseigner par le bias de la commande powershell

    D'avance Merci pour votre retour.
    Cordialement
    Philippe

    lundi 16 avril 2012 15:49
  • avez vous exécuter la commande : Set-TransportConfig -ExternalPostmasterAddress adresse@votredomaine.com ?

    Yohan LEFEVRE - MCTS / MCP

    lundi 16 avril 2012 15:52
  • Bonjour

    J'ai effectué la commande Set-TransportConfig -ExternalPostmasterAddress adresse@mondomaine.com qui est passé sans problèmes.

    Pour Thierry, nos serveurs CAS/HUB sont équipés de Forefront Protection for Exchange 2010 qui est l'outil de scan de nos mails + le service Anti-Spam fourni par notre fournisseur d'accès Internet .

    Il y a t'il un option que j'aurais raté sous FPE ? Je vais également regardé sur notre console AntiSpam de notre fournisseur et vous tiens au courant.

    Merci pour votre retour & pour votre aide.

    Cordialement
    Philippe

    mercredi 18 avril 2012 09:32
  • Bonjour,

    J'ai effectué la commande "Set-TransportConfig -ExternalPostmasterAddress adresse@mondomaine.com" ce matin chez un de mes clients, qui rencontrait le même problème que vous. Depuis plus de soucis, avez vous re-essayer de reproduire le problème depuis le passage de la commande ? normalement ces mails devrait être étiquetté avec le sender défini, et vous ne devriez plus avoir le problème.


    Yohan LEFEVRE - MCTS / MCP

    mercredi 18 avril 2012 13:13
  • Bonjour,

    J'ai demandé à mes utilisateurs de faire un nouvel essai & j'attends leurs retours.

    Pour ma part, cela que j'ai fait a été concluant.
    Cordialement
    Philippe

    mercredi 18 avril 2012 14:13
  • Je viens d'avoir le retour de mon utilisatrice, le test est non concluant ...

    J'ai de nouveau le même message d'erreur.

    Si vous avez une autre idée je suis preneur.

    D'avance Merci pour votre aide & votre retour.
    Cordialement
    Philippe

    mercredi 18 avril 2012 15:07
  • Auriez-vous par hasard, un firewall qui analyse les trames SMTP ? j'ai un client qui disposait d'un firewall Arkoon qui rencontrait le même problème.

    Yohan LEFEVRE - MCTS / MCP

    mercredi 18 avril 2012 15:14
  • Bonjour,

    Nous avons un firewall de chez Palo Alto qui analyse tous nos flux et comment avez-vous résolu votre problème ? Une configuration sur le firewall? 

    Moi que je fais un test, le message est bien reçu. Par contre, quand mon utilisatrice fait un essai, j'ai le message d'erreur.
    Essayé la supression du contact, le mode cache désactivé, par webmail : idem  

    Et là ....

    D'avance Merci pour votre aide.

    Cordialement
    Philippe

    vendredi 20 avril 2012 08:58
  • Effectivement nous avions dans le firewall changer les paramètres afin que ce dernier laisse passer les messages qui ne sont pas "RFC Compliant" uniquement depuis le serveur Exchange.

    Par contre je ne comprends pas que ca marche pour vous mais pas pour votre utilisatrice ?

    Si je comprends bien, si vous envoyez tous les deux un message à la même adresse e-mail, vous recevez un message de non retour, tandis que votre utilisatrice non ?

    Si cela ne concerne qu'un seul et unique domaine, il sera peut être possible alors qu'on essaye quelque tours de passe passe, en ajoutant un "domaine distant" sur votre serveur exchange et en bougeant quelques paramètres.

    Cordialement,


    Yohan LEFEVRE - MCTS / MCP

    vendredi 20 avril 2012 09:04
  • Tu pensais quel "tour de passe passe" ??

    Une commande Powershell en particulier ?

    Pour info, je viens de regarder dans le suivi des messages, et sur le même serveur CAS, mon message passe et pas le sien.

    D'avance Merci.
    Philippe

    vendredi 20 avril 2012 10:07
  • Peux-tu me fournir une capture d'écran ou les logs des deux suivis de messages ?

    Yohan LEFEVRE - MCTS / MCP

    vendredi 20 avril 2012 10:14
  • Et voilà

    vendredi 20 avril 2012 11:24
  • il me faudrait plus d'informations, pouvez vous me donner les messages en entier ?

    vous devriez normalement pouvoir exporter les logs,

    Cordialement,


    Yohan LEFEVRE - MCTS / MCP

    vendredi 20 avril 2012 11:26
  • Tu utilises quelle commande powershell pour cela ?

    get-messagetrackinglog -Recipients:@mondomaine.fr -Start "04/16/2012 00:00:00" -End "04/20/2012 11:58:00"

    Ou une autre ?

    Cordialement
    Philippe

    vendredi 20 avril 2012 13:18