locked
Migration ESXI (free) vers Hyper v-2 : configuration des disques de la baie SAN RRS feed

  • Question

  • Bonjour à tous,

    J'ai actuellement dans mon infra 2 serveurs ESXi 5 dont 1 qui est en prod.

    Je dois les migrer vers hyper-v 2 (ou 3 si c'est plus simple).

    Les Mv sont hébergés sur une Baie SAN (10 disques en RAID 6 dont 2 en spare). La baie SAN dispose de 2 contrôleurs FC.

    Ma question est de savoir comment je configure ma baie SAN dans Windows 2008.

    A ce jour, j'ai un datastore de 1.40 To + un datastore de 30 go qui sont configurés sur la baie.

    Dans Windows, (gestion des disques), j'ai bizarrement 2 disques de 1.4 to qui sont détectés.

    • Le 1er est en état Inconnu et Hors connexion
    • LE 2nd est en état de base et hors connexion

    1er question :

    1 - Je ne comprends pas pourquoi Windows me détecte 2 disques de 1.4 TO.

    2- Dois- je laisser Windows gérer mes unités de disques ou faut-il passer par un logiciel ?

    J'ai lu qu'il fallait passer par le connecteur iscsi mais je n'arrive pas à le faire fonctionner. Il ne détecte pas la baie SAN.

    Cordialement

    lundi 14 janvier 2013 10:55

Réponses

  • A ne pas monter tes bais en iscsi si tu est en prod. Si Windows tag tes volume, alors il ne seront plus utilisable en esxi, et possiblement pas utilisable dans Windows non plus.

    Donc avant tout je conseil de faire tes backup et surtout des clone des serveur, avec des outil comme acronis ou ghost.

    1) question pour toi. Qu'elle est la marque de ton SAN ? 

    Si c'est un dell, tu peu prendre le iSCSI de microsoft, ou bien lui de Dell, et dans les securité de tes LUN tu doit donner soit l'IP de ton serveur, ou l'IQN de ton serveur.

    Mais, comme tu voit, la réponse dépand de te technologie. Je connais tres bien les Dell\Equalogic, mais je connais pas les EMC en exemple.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    mardi 15 janvier 2013 02:44
  • Bonjour,

    A mes connaissence vous devez utiliser NTFS pour formater les disques, si c'est une cible iSCSI de Microsoft. MS ne peut pas monter VMFS
    il est utilisable uniquement par ESX en tant que magasin de données, et le plus souvent sur ​​un LUN.


    Best regards Bourbita Thameur Microsoft Certified Technology Specialist: Windows Server 2008 R2,Server Virtualizaton

    mardi 15 janvier 2013 10:53
    Auteur de réponse
  • Pour tes VM, il existe encore une question pour moi.

    Tes LUN sont crée dans ton ESXi et monter comme des disque durs locaux a tes VM ou bien tu en utilisent directement en iSCSI de l'intérieur de la VM ?

    La bonne méthode est pour moi si c'est via le ESXi, mais sa implique que ta LUN de 1.4G doit rester a on tant que tu na pas migrer. A tu assez d'espace si tu met plus petit l'espace de snapshot en exemple pour te monter un autre LUN pour Hyper-V ?

    Je ne connais pas hyper-v, mais a voir si tu a besoin d'une version d'OS qui supporte du clustering si tu pointe deux Windows sur le meme HDD. (un autre usagers du forum peut me corriger :) )


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    • Marqué comme réponse Anthony Leduc mardi 22 janvier 2013 11:22
    mercredi 16 janvier 2013 02:48
  • Bonjour à tous,

    La conversion des VM ESXI vers Hyper-v est terminée. Le programme de Microsoft fonctionne bien.

    J'ai modifié le type de host agent de la baie SAN de VMWARE vers Win2003/win2008  non-clustered.

    J'ai préféré choisir ce mode car je n'ai pas encore pris le temps de me former sur les outils de clustering de Windows. Je vais me monter une plate-forme de test avant. Et puis peut-être que j'en apprendrai plus aux techdays sur ce sujet.

    Du coup, dans le gestionnaire de disque, j'ai formaté la 1ere partition de 1.4 TO en ntfs et la seconde partition de 1.4 To refuse de se formater, ce qui est normal.

    L'outil isci refuse de découvrir la baie san et j'ai également testé avec la fonctionnalité de gestionnaire de baie san et c'est pareil puisqu'il vérifie la présence du protocole VDS et je n'ai pas trouvé comment l'activer sur la baie SAN. Pour le moment, ce n'est pas grave...

    Au final, la migration Esxi vers hyper-v s'est faite finalement en douceur...Cela a été transparent pour les users. J'ai juste activé l'option "Execute Disable Bit" sur le x3650 au niveau du bios. Sans cela, hyper-v refuse de démarrer les VM.

    Prochaine migration Windows 7 vers Windows 8 pour mon poste perso. Cela sera certainement plus facile ;-)

    Un grand merci pour votre aide
    mardi 22 janvier 2013 10:15

Toutes les réponses

  • J'avoue ne pas avoir tout compris :

    les ESX tournent encore apparement

    le volume de 1,4To est-il utilisé par les ESX ? Le volume n'est pas déja formaté en VMFS ?

    Avez-vous une carte FC dans votre serveur ? Quel connectique utilisez vous ?

    lundi 14 janvier 2013 21:26
  • A ne pas monter tes bais en iscsi si tu est en prod. Si Windows tag tes volume, alors il ne seront plus utilisable en esxi, et possiblement pas utilisable dans Windows non plus.

    Donc avant tout je conseil de faire tes backup et surtout des clone des serveur, avec des outil comme acronis ou ghost.

    1) question pour toi. Qu'elle est la marque de ton SAN ? 

    Si c'est un dell, tu peu prendre le iSCSI de microsoft, ou bien lui de Dell, et dans les securité de tes LUN tu doit donner soit l'IP de ton serveur, ou l'IQN de ton serveur.

    Mais, comme tu voit, la réponse dépand de te technologie. Je connais tres bien les Dell\Equalogic, mais je connais pas les EMC en exemple.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    mardi 15 janvier 2013 02:44
  • Bonjour à vous et merci pour vos réponses.

    Tout d'abord, mes excuses je n'ai pas pris le temps de créer une topo vous présentant l'architecture de stockage.

    Ce sera peut-être plus clair :

    La marque de la baie SAN est IBM DS3400. Les disques sont effectivement formatés en vmfs.

    Le volume 1.4 To est effectivement en cours d'utilisation. Mais pourquoi Windows m'en voit 2 ?

    J'ai 2 cartes FO sur chaque contrôleurs SAN (je dispose de 2 ontrôleurs)

    Les 2 serveurs X3650 disposent de cartes Fo qui sont relies aux cartes FO des contrôleurs SAN.

    En allant dans le gestionnaire de la baie SAN (Ds storage manager)  j'ai vu hier, qu'il était possible de configurer le host type de la baie, actuellement en VMware vers du Windows 2008. Peut-être que l'initialisateur Iscsi verra la baie SAN ensuite ?

    Pour éviter de tout perdre, car effectivement comme le souligne P Barth, le 1er serveur (Ibm X3650) n'est pas en production et j'ai installé dessus Hyper-v 2 et le 2nd X3650 contient ESXI qui est en production.

    Pour le moment, j'essaye de convertir les MV ESXI au format hyper-v en utilisant l'outil Microsoft Virtual Machine Converter.

    Je vais ensuite vérifier qu'elles démarrent sur le hyper-v qui sert de test.

    Il va falloir que je m'arme de patience pour le moment, le temps de faire le transfert et la conversion.

    Merci pour vos réponses de nouveaux.

    mardi 15 janvier 2013 10:37
  • Bonjour,

    A mes connaissence vous devez utiliser NTFS pour formater les disques, si c'est une cible iSCSI de Microsoft. MS ne peut pas monter VMFS
    il est utilisable uniquement par ESX en tant que magasin de données, et le plus souvent sur ​​un LUN.


    Best regards Bourbita Thameur Microsoft Certified Technology Specialist: Windows Server 2008 R2,Server Virtualizaton

    mardi 15 janvier 2013 10:53
    Auteur de réponse
  • Pour tes VM, il existe encore une question pour moi.

    Tes LUN sont crée dans ton ESXi et monter comme des disque durs locaux a tes VM ou bien tu en utilisent directement en iSCSI de l'intérieur de la VM ?

    La bonne méthode est pour moi si c'est via le ESXi, mais sa implique que ta LUN de 1.4G doit rester a on tant que tu na pas migrer. A tu assez d'espace si tu met plus petit l'espace de snapshot en exemple pour te monter un autre LUN pour Hyper-V ?

    Je ne connais pas hyper-v, mais a voir si tu a besoin d'une version d'OS qui supporte du clustering si tu pointe deux Windows sur le meme HDD. (un autre usagers du forum peut me corriger :) )


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    • Marqué comme réponse Anthony Leduc mardi 22 janvier 2013 11:22
    mercredi 16 janvier 2013 02:48
  • Oui. Il me reste une machine à convertir en hyper-v.

    C'est terriblement long. 6 heures de conversion pour une MV de 100 go. Le logiciel télécharge la MV en local puis conversion puis envoi vers un hyper-v de test. Si une de ces étapes échoue alors il faut tout recommencer.

    jeudi 17 janvier 2013 08:31
  • Bonjour à tous,

    La conversion des VM ESXI vers Hyper-v est terminée. Le programme de Microsoft fonctionne bien.

    J'ai modifié le type de host agent de la baie SAN de VMWARE vers Win2003/win2008  non-clustered.

    J'ai préféré choisir ce mode car je n'ai pas encore pris le temps de me former sur les outils de clustering de Windows. Je vais me monter une plate-forme de test avant. Et puis peut-être que j'en apprendrai plus aux techdays sur ce sujet.

    Du coup, dans le gestionnaire de disque, j'ai formaté la 1ere partition de 1.4 TO en ntfs et la seconde partition de 1.4 To refuse de se formater, ce qui est normal.

    L'outil isci refuse de découvrir la baie san et j'ai également testé avec la fonctionnalité de gestionnaire de baie san et c'est pareil puisqu'il vérifie la présence du protocole VDS et je n'ai pas trouvé comment l'activer sur la baie SAN. Pour le moment, ce n'est pas grave...

    Au final, la migration Esxi vers hyper-v s'est faite finalement en douceur...Cela a été transparent pour les users. J'ai juste activé l'option "Execute Disable Bit" sur le x3650 au niveau du bios. Sans cela, hyper-v refuse de démarrer les VM.

    Prochaine migration Windows 7 vers Windows 8 pour mon poste perso. Cela sera certainement plus facile ;-)

    Un grand merci pour votre aide
    mardi 22 janvier 2013 10:15