locked
Appliquer la stratégie d'une OU utilisateur sur une OU serveur RRS feed

  • Question

  • Bonjour,

    Je travail sur un Active directory assez vaste, mais je rencontre un problème pour l'application d'une stratégie sur une OU de serveur RDS.

    Je résumerai l'arborescence ainsi :


    Domaine.ltd

                       ----ENTITE

                                       -----SITExY

                                                     -------Utilisateurs

                                                                 GPO

                                                     -------Ordinateurs

                                                     -------Serveurs


                        ------ENTITE

                                           -------Serveurs RDS

                                                        GPO

    J'ai donc déjà des GPO qui fonctionnent sur mes serveurs RDS.

    Dans les OU utilisateurs j'ai également des GPO qui connecte des lecteurs locaux.

    Je voudrais que la GPO de ces utilisateurs soit appliquée lorsqu'un utilisateur se connecte sur un serveur RDS pour récupérer ses lecteurs locaux. Or cela ne fonctionne que de manière aléatoire, un utilisateur sur 10.

    Ai-je manqué quelque chose ? Je pense que ma logique est bonne pourtant. Comment auriez vous procédé ?

    vendredi 18 janvier 2013 09:19

Réponses

  • Quand tu définis le loopback processing, tu dois spécifier si tu souhaites Fusionner les paramètres ou les Remplacer.

    Dans ton cas, si je te suis bien , il faudrait que tu les Fusionnes pour permettre aux GPOs users d'être appliquées à la fois depuis la GPO RDS et depuis la GPO de l'OU Users de l'utilisateur.

    Est-ce que c'est bien ce à quoi tu penses ? Et si oui c'est bien ce paramètre qui est en place dans ton loopback processing ?Si oui, est-ce que le souci se pose sur des paramètres définis sur les 2 GPOs mais n'ayant pas les memes valeurs ?

    Dans tous les cas RSOP.MSC devrait t'aider à y avoir plus clair ;-)


    Freddy ELMALEH - Active IT (Active IT)
    Consultant Freelance (Architecte AD, Infrastructure, Audit de sécurité, audit de sites web, tests d'intrusion, etc.)
    MVP Windows Server - Directory Services
    MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
    Bibliographie (Administration avancée sous Windows 2008 R2, La sécurité sous Windows 7, etc.)
    FaceBook Twitter LinkedIn

    vendredi 18 janvier 2013 09:49
  • Mais j'aurai imaginé que les GPO de l'OU utilisateur serait appliqué quelque soit le serveur sur lequel il se connecte.

    Les GPO utilisateurs lié à un utilisateur s'appliqent quelque soit le site. Il peut s'agir d'un problème de réplication AD (certains DC n'ont pas mis à jour correctement le SYSVOL).

    Il peut aussi s'agir d'un problème d'ordre : les gpo sont appliquées dans un certain ordre, hors lors de la déclaration du "loopback processing", on peut la déclarer en "fusion" ou en "remplacement". Dans le premier cas tous les paramètres utilisateurs sont appliqués, puis la GPO loopback "écrase" le résultat uniquement avec son paramétrage. Dans le cas "remplacement", il n'y a pas d'execution de la partie Utilisateur normal, seul la partie Utilisateur de la GPO loopback s'applique.

    • Marqué comme réponse DaAl.Co vendredi 18 janvier 2013 10:06
    vendredi 18 janvier 2013 09:51
  • Je te l'avais dit juste au dessus mais ce n'est pas bien grave ;-)

    "Quand tu définis le loopback processing, tu dois spécifier si tu souhaites Fusionner les paramètres ou les Remplacer."


    Freddy ELMALEH - Active IT (Active IT)
    Consultant Freelance (Architecte AD, Infrastructure, Audit de sécurité, audit de sites web, tests d'intrusion, etc.)
    MVP Windows Server - Directory Services
    MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
    Bibliographie (Administration avancée sous Windows 2008 R2, La sécurité sous Windows 7, etc.)
    FaceBook Twitter LinkedIn

    • Marqué comme réponse DaAl.Co vendredi 18 janvier 2013 10:33
    vendredi 18 janvier 2013 10:18

Toutes les réponses

  • Hello,

    tu as mis en place le paramètre de "loopback processing" sur ton RDS pour appliquer les paramètres utilisateurs rattachés à la GPO Ordinateur de ton RDS ? : http://support.microsoft.com/kb/231287

    A bientôt


    Freddy ELMALEH - Active IT (Active IT)
    Consultant Freelance (Architecte AD, Infrastructure, Audit de sécurité, audit de sites web, tests d'intrusion, etc.)
    MVP Windows Server - Directory Services
    MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
    Bibliographie (Administration avancée sous Windows 2008 R2, La sécurité sous Windows 7, etc.)
    FaceBookTwitterLinkedIn


    vendredi 18 janvier 2013 09:32
  • En effet le "loopback processing" est activé, et cela fonctionne parfaitement pour la GPO placée dans l'OU des serveurs RDS.

    Par contre pour la GPO de l'OU utilisateur elle ne s'applique pas. En effet j'ai un grand nombre de sites, et les utilisateurs autorisé à se connecter sur les serveurs RDS le sont par adhérence à un groupe spécifique. Mais j'aurai imaginé que les GPO de l'OU utilisateur serait appliqué quelque soit le serveur sur lequel il se connecte.

    Je ne sais pas si je suis assez clair

    vendredi 18 janvier 2013 09:42
  • Quand tu définis le loopback processing, tu dois spécifier si tu souhaites Fusionner les paramètres ou les Remplacer.

    Dans ton cas, si je te suis bien , il faudrait que tu les Fusionnes pour permettre aux GPOs users d'être appliquées à la fois depuis la GPO RDS et depuis la GPO de l'OU Users de l'utilisateur.

    Est-ce que c'est bien ce à quoi tu penses ? Et si oui c'est bien ce paramètre qui est en place dans ton loopback processing ?Si oui, est-ce que le souci se pose sur des paramètres définis sur les 2 GPOs mais n'ayant pas les memes valeurs ?

    Dans tous les cas RSOP.MSC devrait t'aider à y avoir plus clair ;-)


    Freddy ELMALEH - Active IT (Active IT)
    Consultant Freelance (Architecte AD, Infrastructure, Audit de sécurité, audit de sites web, tests d'intrusion, etc.)
    MVP Windows Server - Directory Services
    MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
    Bibliographie (Administration avancée sous Windows 2008 R2, La sécurité sous Windows 7, etc.)
    FaceBook Twitter LinkedIn

    vendredi 18 janvier 2013 09:49
  • Mais j'aurai imaginé que les GPO de l'OU utilisateur serait appliqué quelque soit le serveur sur lequel il se connecte.

    Les GPO utilisateurs lié à un utilisateur s'appliqent quelque soit le site. Il peut s'agir d'un problème de réplication AD (certains DC n'ont pas mis à jour correctement le SYSVOL).

    Il peut aussi s'agir d'un problème d'ordre : les gpo sont appliquées dans un certain ordre, hors lors de la déclaration du "loopback processing", on peut la déclarer en "fusion" ou en "remplacement". Dans le premier cas tous les paramètres utilisateurs sont appliqués, puis la GPO loopback "écrase" le résultat uniquement avec son paramétrage. Dans le cas "remplacement", il n'y a pas d'execution de la partie Utilisateur normal, seul la partie Utilisateur de la GPO loopback s'applique.

    • Marqué comme réponse DaAl.Co vendredi 18 janvier 2013 10:06
    vendredi 18 janvier 2013 09:51
  • Merci !!!! Merci Bruce JDC, tu es un génie !!

    Il s'agit exactement de cela, après avoir passé le paramètre à fusionner tout est parfait !!!

    Merci également Freddy pour ton aide

    vendredi 18 janvier 2013 10:07
  • Je te l'avais dit juste au dessus mais ce n'est pas bien grave ;-)

    "Quand tu définis le loopback processing, tu dois spécifier si tu souhaites Fusionner les paramètres ou les Remplacer."


    Freddy ELMALEH - Active IT (Active IT)
    Consultant Freelance (Architecte AD, Infrastructure, Audit de sécurité, audit de sites web, tests d'intrusion, etc.)
    MVP Windows Server - Directory Services
    MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
    Bibliographie (Administration avancée sous Windows 2008 R2, La sécurité sous Windows 7, etc.)
    FaceBook Twitter LinkedIn

    • Marqué comme réponse DaAl.Co vendredi 18 janvier 2013 10:33
    vendredi 18 janvier 2013 10:18
  • Il s'agit en effet de la même réponse à quelques minutes d'intervalles :)
    vendredi 18 janvier 2013 10:26
  • :D

    T'as été plus rapide ! 


    Freddy ELMALEH - Active IT (Active IT)
    Consultant Freelance (Architecte AD, Infrastructure, Audit de sécurité, audit de sites web, tests d'intrusion, etc.)
    MVP Windows Server - Directory Services
    MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
    Bibliographie (Administration avancée sous Windows 2008 R2, La sécurité sous Windows 7, etc.)
    FaceBook Twitter LinkedIn

    vendredi 18 janvier 2013 10:35