none
EXCHANGE : Souci de création de mails lorsqu'un DC est éteint RRS feed

  • Question

  • Bonjour,

    J'ai un exchange 2007 sur Win 2003 R2 avec 2 dcs sur win 2008 R2.

    Lorsqu'un de ces DCs est éteint, exchange ne va pas chercher dans l'autre DC.

    J'ai cette erreur : Le service de liste d'adresse du serveur exchange n'a pas pu répondre. Cela peut etre du à une erreur de configuration de stratégie de liste d'adresses ou d'adresse de messagerie.

    J'ai ensuite une erreur 8026 dans l'event viewer, l'annuaire renvoit l'erreur [0x51]

    Dans les parametres systeme du transport hub du serveur, je vois bien les deux DCs.

    C'est assez handicapant car quand le DC02 est injoignable, on ne peut presque plus rien faire.

    Merci pour votre aide.

    cordialement,

    Alex.

    lundi 21 décembre 2015 16:11

Réponses

  • Il serait peut être intéressant de forcer l'utilisation du DC1 sur ton serveur Exchange.

    Nous pourrons alors voir le comportement du serveur à l’arrêt du DC2.

    • Marqué comme réponse waaalex lundi 4 janvier 2016 08:58
    mardi 29 décembre 2015 07:45
  • Il y a plusieurs articles qui explique la méthode.

    Pour ma part, je n'ai jamais réalisé cette action sur une version 2007.

    http://msexchangeguru.com/2010/05/09/hardcoding-domaincontroller-exchange2007/

    http://exchangeserverpro.com/how-to-use-a-specific-domain-controller-in-the-exchange-2007-management-shell/

    • Marqué comme réponse waaalex lundi 4 janvier 2016 08:57
    mardi 29 décembre 2015 12:41

Toutes les réponses

  • Il faudrait deja s'assurer de l'état de bonne santé du serveur qui n'est pas utilisé par Exchange, vous avez pour cela différentes commandes, mais un DCDIAG est un bon départ.

    Vous pouvez ensuite vérifier les événements côtés Exchange et DC, en particulier les evenements de type MSExchangeADTopology.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 22 décembre 2015 09:12
    Modérateur
  • Dcdiag sur le serveur qui n'est pas pris en compte :

    ---------------------------------------------------------

    Domain Controller Diagnosis

    Performing initial setup:
       Done gathering initial info.

    Doing initial required tests
       
       Testing server: Default-First-Site\SRV-DC01
          Starting test: Connectivity
             ......................... SRV-DC01 passed test Connectivity

    Doing primary tests
       
       Testing server: Default-First-Site\SRV-DC01
          Starting test: Replications
             ......................... SRV-DC01 passed test Replications
          Starting test: NCSecDesc
             ......................... SRV-DC01 passed test NCSecDesc
          Starting test: NetLogons
             ......................... SRV-DC01 passed test NetLogons
          Starting test: Advertising
             ......................... SRV-DC01 passed test Advertising
          Starting test: KnowsOfRoleHolders
             ......................... SRV-DC01 passed test KnowsOfRoleHolders
          Starting test: RidManager
             ......................... SRV-DC01 passed test RidManager
          Starting test: MachineAccount
             ......................... SRV-DC01 passed test MachineAccount
          Starting test: Services
             ......................... SRV-DC01 passed test Services
          Starting test: ObjectsReplicated
             ......................... SRV-DC01 passed test ObjectsReplicated
          Starting test: frssysvol
             ......................... SRV-DC01 passed test frssysvol
          Starting test: frsevent
             ......................... SRV-DC01 passed test frsevent
          Starting test: kccevent
             ......................... SRV-DC01 passed test kccevent
          Starting test: systemlog
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/22/2015   10:32:51
                (Event String could not be retrieved)
             ......................... SRV-DC01 failed test systemlog
          Starting test: VerifyReferences
             ......................... SRV-DC01 passed test VerifyReferences
       
       Running partition tests on : DomainDnsZones
          Starting test: CrossRefValidation
             ......................... DomainDnsZones passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... DomainDnsZones passed test CheckSDRefDom
       
       Running partition tests on : ForestDnsZones
          Starting test: CrossRefValidation
             ......................... ForestDnsZones passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... ForestDnsZones passed test CheckSDRefDom
       
       Running partition tests on : Schema
          Starting test: CrossRefValidation
             ......................... Schema passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... Schema passed test CheckSDRefDom
       
       Running partition tests on : Configuration
          Starting test: CrossRefValidation
             ......................... Configuration passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... Configuration passed test CheckSDRefDom
       
       Running partition tests on : get
          Starting test: CrossRefValidation
             ......................... get passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... get passed test CheckSDRefDom
       
       Running enterprise tests on : get.com
          Starting test: Intersite
             ......................... get.com passed test Intersite
          Starting test: FsmoCheck
             ......................... get.com passed test FsmoCheck
    -------------------------------------------------------------------------------------------------

    Je n'ai aps d'évenements MSExchangeADTopology sur les serveurs.

    Merci pour votre aide.

    mardi 22 décembre 2015 09:43
  • Sur ton serveur Exchange, tu as bien les 2 serveur DC définis comme serveur DNS ?
    mardi 22 décembre 2015 13:39
  • Oui tout a fait.
    mardi 22 décembre 2015 14:12
  • Il serait peut être intéressant de forcer l'utilisation du DC1 sur ton serveur Exchange.

    Nous pourrons alors voir le comportement du serveur à l’arrêt du DC2.

    • Marqué comme réponse waaalex lundi 4 janvier 2016 08:58
    mardi 29 décembre 2015 07:45
  • D'accord. comment puis-je forcer l'utilisation de ce DC sur Exchange?
    mardi 29 décembre 2015 08:26
  • Il y a plusieurs articles qui explique la méthode.

    Pour ma part, je n'ai jamais réalisé cette action sur une version 2007.

    http://msexchangeguru.com/2010/05/09/hardcoding-domaincontroller-exchange2007/

    http://exchangeserverpro.com/how-to-use-a-specific-domain-controller-in-the-exchange-2007-management-shell/

    • Marqué comme réponse waaalex lundi 4 janvier 2016 08:57
    mardi 29 décembre 2015 12:41
  • i tried this

    http://exchangeserverpro.com/how-to-use-a-specific-domain-controller-in-the-exchange-2007-management-shell/

    for only in the session.

    I forced the preferred domain controler and added a new mailbox. It was ok.

    Then,

    I've disable DC02 and retry to add a new mailbox.

    It works too....

    I don't understand but it seems to work.

    Merci beaucoup.

    Cordialement,

    alex

    lundi 4 janvier 2016 08:57