locked
lien OWA externe ne fonctionne pas RRS feed

  • Discussion générale

  • Bonjour,

    J'ai un problème avec le OWA (Exchange2007), les utilisateurs ne peuvent pas y accéder à leurs boite mail de l’extérieur car le lien externe ne fonctionne pas  sachant que dans l'entreprise sa fonctionne bien ( si le même lien URL interne et externe). en utlise TMG.

    personne à une aidée sur la source du problème.

    merci d'avance pour votre aide.

    vendredi 12 octobre 2012 10:21

Toutes les réponses

  • Bonjour,

    Aurais tu plus de détails sur ton implémentation ?

    • Configuration de la règle de publication (Web Listener, Authentification, etc.)
    • Placement du serveur TMG 2010
    • etc.

    En bref, tout ce qui pourrait nous être utile pour identifier la source du problème.

    Tu trouveras sinon un guide pour la publication OWA 2007 avec TMG 2010 (en anglais) à cette adresse : http://www.isaserver.org/tutorials/publishing-outlook-web-access-microsoft-forefront-tmg.html

    Cordialement.

    vendredi 12 octobre 2012 13:33
  • Bonjour MarOKNard,

    Suivant ce qui je vu sur le guide que tu ma donné ce n'est pas la même chose chez nous, par exemple sur le guide ils utilise l'authentification de base :


    Dans la configue de notre exchange 2007 c'est l'authentification basée sur des formule qu'est utilisée :


    sachant que je suis nouveaux dans cette entreprise il mon dit que la messagerie externe utilise l'adresse public 81.52.166.131 j'ai remarqué que le ping à cette adresse ne passe pas de l’extérieur, en a d'autre adresse public qui se ping depuis l’extérieur comment je fait pour que la messagerie utilise une autre adresse (par exemple : 81.52.166.141 ?).

    Merci d'avance

    mardi 16 octobre 2012 09:15
  • Pour l'authentification côté Exchange, nous voyons sur ton screenshot que la case Authentification de base est grisée mais cochée, cette méthode est donc bien active sur le répertoire pour pouvoir faire de la délégation de base avec TMG 2010.

    Concernant le ping, il est possible que votre firewall refuse le ping sur cette IP, ce qui ne serait alors pas forcément une piste.

    Plusieurs questions :

    • l'URL externe configurée côté Exchange est elle la bonne ?
    • Owa en interne est il en HTTP ou HTTPS ?
    • Quelle est la configuration côté TMG? Redirection vers du HTTP ou HTTPS ?
    • Quelle est la configuration du web listener et du certificat côté TMG ?

    Essayes également  la procédure suivante pour voir si tes requêtes depuis l'extérieur arrivent jusqu'au TMG :

    • Mets toi sur un point d'accès Internet externe à ton entreprise (ou change ton fichier host pour faire pointer le webmail sur ton IP publique)
    • Regardes quelle est ton ip publique  (En utilisant par exemple http://www.myipaddress.com/show-my-ip-address/)
    • Vas dans le menu Log and Reports > Logs de TMG et fait un filtre par IP cliente (ton IP publique), tu peux sinon simplement faire un filtre sur le nom de la règle utilisée.
    • Lance le logging et essayes de te connecter au webmail pour voir les requêtes qui arrivent et les messages d'erreurs éventuels

    Si tu as des soucis avec la fonctionnalité de logging, ce lien en explique le fonctionnement : http://www.isaserver.org/tutorials/tmg-back-basics-part2.html


    • Modifié MarOKNard mardi 16 octobre 2012 10:08
    mardi 16 octobre 2012 10:07
  • Bonjour MarOKNard,

    ci-dessous les réponse :

    • l'URL externe configurée côté Exchange est elle la bonne ? URL interne et externe c'est le même : https://mail.sovac.dz/owa
    • Owa en interne est il en HTTP ou HTTPS ? en HTTPS 
    • Quelle est la configuration côté TMG? Redirection vers du HTTP ou HTTPS ? comment je puisse voir ça (aucune idée je sui nouveau sur tmg) ?
    • Quelle est la configuration du web listener et du certificat côté TMG ? comment je puisse voir ça (aucune idée je sui nouveau sur tmg) ?

    Essayes également  la procédure suivante pour voir si tes requêtes depuis l'extérieur arrivent jusqu'au TMG :

    • Mets toi sur un point d'accès Internet externe à ton entreprise (ou change ton fichier host pour faire pointer le webmail sur ton IP publique) de mon domicile
    • Regardes quelle est ton ip publique  (En utilisant par exemple http://www.myipaddress.com/show-my-ip-address/) j'ai eu ip : 74.125.189.18
    • Vas dans le menu Log and Reports > Logs de TMG et fait un filtre par IP cliente (ton IP publique), tu peux sinon simplement faire un filtre sur le nom de la règle utilisée. c'est fait (un filtre par ip address )
    • Lance le logging et essayes de te connecter au webmail pour voir les requêtes qui arrivent et les messages d'erreurs éventuels

    Si tu as des soucis avec la fonctionnalité de logging, ce lien en explique le fonctionnement : http://www.isaserver.org/tutorials/tmg-back-basics-part2.html j'ai lancé et j'ai essayé de se connecter à owa. mais après vérification j'ai pas trouvé mon ip address j'ai trouvée beaucoup d'adresse mail pas la miènne,est ce que c'est logique ?

    Merci d'avance

    mercredi 17 octobre 2012 12:08
  • Concernant le filtre, ce que tu me dis est bizarre, es tu sûr de bien avoir validé le filtre avant le lancer le logging?

    Concernant le paramétrage, je te conseil vraiment de suivre le premier lien que je t'ai indiqué, celui-ci te montrera le paramétrage de ces éléments, et du même coup, tu verras ce qui est actuellement fait sur ton infrastructure.

    jeudi 18 octobre 2012 15:28
  • Bonjour MarOKNard,

    J'ai vérifie la règle SMTP sur le TMG, est ce que si suffisant que l'autorisation de Protocol SMTP est de serveur Exchange (EX1) a externe et interne et réseau local ? ou bien il faut aussi ajouter la règle de l’extérieur (Internet) vers le serveur Exchange (ex1) ? sachant que le OWA est accessible à l’intérieur de l'entreprise, le problème d'accès vers OWA est juste de l’extérieur .


    samedi 20 octobre 2012 20:30
  • Bonjour,

    as-tu utilisé l'assistant de publication de serveur de messagerie présent dans TMG ?

    Il fait "presque" tout tout seul... Il faut juste ne pas se tromper dans la configuration de l'authentification. Il faut aussi importer le certificat utilisé par Exchange dans TMG.

    Après création, il faut tester la règle de publication (bouton test dans la règle), et corriger afin que le site interne doit accessible, et que les authentifications configurées correspondent.

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSA Windows Server 2012 (73 MCPs). https://mvp.support.microsoft.com/profile=CE2B565B-B13D-4C24-B04D-F0D5766D14A1 http://www.faqexchange.info

    dimanche 21 octobre 2012 14:28