none
SharePoint Hates Me : User Profile Service and the related synchronization job won't run on servers causing workflow emails to fail

    Question

  • Good Day,

    Let me start with the disclaimer... I have no understanding of SharePoint Administration and Development.

    That being said I am overseeing a SharePoint2013 farm with 5 windows server 2008 R2 Standard VM servers.

    We had two workflows developed which appear to now appear unable to send emails. Our vendor says they believe the issue is related to our User Profile Service not properly synching with AD. As a result the workflows are not sending any emails and the system is not actively pointing out any email failure. 

    Reviewing the Application Logs however I do get the below error. 

    Log Name:      Application
    Source:        Microsoft-SharePoint Products-SharePoint Foundation
    Date:          6/11/2018 1:10:38 PM
    Event ID:      6398
    Task Category: Timer
    Level:         Critical
    Keywords:      
    User:          FCPBS\sql_admin
    Computer:      ShareApp1-Farm1.fcpbs.com
    Description:
    The Execute method of job definition Microsoft.Office.Server.Search.Administration.CustomDictionaryDeploymentJobDefinition (ID e09e1e02-462d-42d6-94fb-eecb78c33290) threw an exception. More information is included below.

    Failed to run flow Microsoft.CustomDictionaryDeployment. Correlation Id: 0c20709e-4c6d-209c-d7c6-ff1cd5bccd23.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6FB7E0CD-52E7-47DD-997A-241563931FC2}" />
        <EventID>6398</EventID>
        <Version>15</Version>
        <Level>1</Level>
        <Task>12</Task>
        <Opcode>0</Opcode>
        <Keywords>0x4000000000000000</Keywords>
        <TimeCreated SystemTime="2018-06-11T17:10:38.604602700Z" />
        <EventRecordID>1096051</EventRecordID>
        <Correlation ActivityID="{0C20709E-4C6D-209C-D7C6-FF1CD5BCCD23}" />
        <Execution ProcessID="3136" ThreadID="3256" />
        <Channel>Application</Channel>
        <Computer>ShareApp1-Farm1.fcpbs.com</Computer>
        <Security UserID="S-1-5-21-184864492-3598561692-3887875508-5643" />
      </System>
      <EventData>
        <Data Name="string0">Microsoft.Office.Server.Search.Administration.CustomDictionaryDeploymentJobDefinition</Data>
        <Data Name="string1">e09e1e02-462d-42d6-94fb-eecb78c33290</Data>
        <Data Name="string2">Failed to run flow Microsoft.CustomDictionaryDeployment. Correlation Id: 0c20709e-4c6d-209c-d7c6-ff1cd5bccd23.</Data>
      </EventData>
    </Event>

    your assistance would be appreciated.

    lundi 11 juin 2018 17:44

Toutes les réponses

  • That event log error is unrelated, so we can ignore it. Do you see profiles in the UPSA? If so, do you see email addresses associated with accounts that are supposed to receive email from the workflow? What type of workflow is it, 2010 or 2013?

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    lundi 11 juin 2018 18:00
    Modérateur
  • Getting some help like directly involving someone who can actually trace the issue and possibly resolve is a better option. There could be multiple reasons why those emails failed. It could be SMTP, change in user profile application, McAfee blocking traffic or others. 

    Share from ULS logs if you can find new info like Trevor said those logs are not related to the issue at hand. 

      
    lundi 11 juin 2018 18:24
  • Hi,

     

    How are you today? Is there any update or any other assistance I could provide on this issue?

     

    Best regards,

    Ethan Liu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    mercredi 13 juin 2018 08:43
  • Thank you all I was able to correct the issue by reviewing the below link

    https://blogs.technet.microsoft.com/meamcs/2013/02/18/sharepoint-20102013-user-profile-synchronization/

    After double checking the farm accounts access I was able to rerun the profile synchronization which this time populated the user profiles.

    Thank you all. 

    jeudi 14 juin 2018 12:20
  • I was able to get it working. I really appreciate your efforts
    jeudi 14 juin 2018 12:21
  • thank you
    jeudi 14 juin 2018 12:21
  • thank you
    jeudi 14 juin 2018 12:22