locked
Intégration pilotes Win RE / Win 2008 pour restauration BMR RRS feed

  • Question

  • Bonjour,

    Je dispose d'un serveur sous Windows 2008 R2 avec un controleur USB 3 spécifique dont les pilotes ne sont pas inclus dans le DVD Win 2008 R2.

    Je suis en phase de test du process de restauration de sauvegarde.

    Ces dernières sont faites via la sauvegarde Windows sur un disque de type RDX.

    J'ai les pilotes INF sous la main, lorsque je boot en WinRE et que je lance un drvload [controleur.inf] mon RDX est accessible.

    J'aimerai éviter cette étape manuelle, pour cela j'ai intégré mes pilotes aux images de démarrage WinRE via le WAIK 3 et le script suivant :

    dism /mount-wim /wimfile:"C:\RemoteInstall\wim_file\x64\images\install.wim" /mountdir:"C:\RemoteInstall\mnt" /index:1
    dism /image:"C:\RemoteInstall\mnt" /add-driver /driver:"C:\RemoteInstall\add_drivers\rusb3hub.inf" /forceunsigned
    dism /image:"C:\RemoteInstall\mnt" /get-drivers
    dism /unmount-wim /mountdir:"C:\RemoteInstall\mnt" /commit

    Le /get-drivers me confirme bien que les pilotes inf ont été intégrés aux fichiers boot.wim et install.wim, cependant lorsque je démarre sur le DVD (auquel j'ai intégré les images wim modifiées - j'ai controlé les dates / tailles). Mes périphériques USB branchés sur ce contrôleur ne sont pas reconnus.

    En résumé :

    - avec drvload cela fonctionne, donc pilote adapté au controleur / à l'OS
    - pilotes intégrés via dism ne fonctionnent pas.

    Questions :

    Existe t il un log des pilotes chargés par WinRE ?
    Existe t il un paramétrage de la Sauvegarde Windows pour permettre d'utiliser les disques RDX comme des disques dur internes et bénéficier de toutes les fonctionnalités (car via l'USB la sauvegarde est limitée à une seule image complète).

    Merci




    jeudi 26 décembre 2013 15:47

Toutes les réponses

  • Bonjour,

    Pas de visite, ni de réponse depuis décembre, le thread fonctionne t il ?

    jeudi 27 février 2014 07:36
  • Bonjour,

    Pas de visite, ni de réponse depuis décembre, le thread fonctionne t il ?

    Y a t il quelqu'un ici ?
    lundi 19 mai 2014 12:32
  • Bonjour Michel,

    Je viens de voir votre post. Essayons de cerner le problème.

    Avec ces commandes DISM :

    dism /mount-wim /wimfile:"C:\RemoteInstall\wim_file\x64\images\install.wim" /mountdir:"C:\RemoteInstall\mnt" /index:1
    dism /image:"C:\RemoteInstall\mnt" /add-driver /driver:"C:\RemoteInstall\add_drivers\rusb3hub.inf" /forceunsigned
    dism /image:"C:\RemoteInstall\mnt" /get-drivers

    Vous montez l'image, vous ajouter vos drivers et vous constatez qu'ils ont bien été ajoutés à l'image à l'aide de Get-Drivers.

    en revanche quand vous lancez dism /unmount-wim /mountdir:"C:\RemoteInstall\mnt" /commit pour démonter l'image, mais je pense que les modifications apportées (ajout de drivers) ne sont pas prises en comptes.

    De mémoire DISM ne sait pas sauvegarder sur DVD, essayez de booter plutôt sur une Clé USB ou lieu d'un DVD, copiez d'abord les sources du DVD sur une clé USB bootable, faites les mêmes modifs (pour intégrer les drivers) démonter l'image et rebooter en bootant sur la clé USB. Notez le résultat

    Tenez moi au courant.

    A+

    HK. 


    Hicham KADIRI | Just Another IT Guy


    lundi 19 mai 2014 18:10
  • Bonjour et merci pour cette réponse.

    J'ai monté l'install.Wim du CDROM que j'avais gravé.
    Le Get_Drivers me donne les informations suivantes :

    .../...

    Nom publié : oem2.inf Nom du fichier d'origine : rusb3hub.inf Boîte de réception : Non Nom de la classe : USB Nom du fournisseur : Renesas Electronics Date : 10/05/2012 Version : 3.0.20.0 Nom publié : oem3.inf Nom du fichier d'origine : rusb3xhc.inf Boîte de réception : Non Nom de la classe : USB Nom du fournisseur : Renesas Electronics Date : 10/05/2012 Version : 3.0.20.0 L'opération a réussi.

    Les drivers sont bien intégrés au média et à l'image.

    Ce que je ne comprends pas c'est pourquoi ces drivers ne se chargent pas, alors qu'avec un drvload ces mêmes fichiers me permettent de faire fonctionner le contrôleur USB 3 et aux périphériques connectés correctement.

    Je vais tester en intégrant un drvload dans le startnet.cmd.
    Ca devrait me permettre de charger de manière automatique les pilotes sur un WinPE, mais ... pas sur un WinRE.

    Existe t il des logs qui se créent lors de l'exécution en ce qui concerne le chargement des pilotes ?

    En recherchant dans le lecteur virtuel nous devrions bien pouvoir trouver l'explication ?

    Merci

    mardi 20 mai 2014 15:36
  • Bonjour Michel,


    Je pense que la méthode la plus simple consiste à intégrer votre driver sur une image de boot WinPE (winpe.wim).

    j'ai déjà utilisé cette méthode il y'a quelques temps et je n'ai pas eu de problème.

    En gros, vous intégrer le driver de la même manière à votre image winpe.wim (à l'aide des commandes DISM que vous avez utilisé pour l'install.wim)

    Vous bootez sur l'iso WinPE (version modifié avec driver integré) et le driver sera chargé au démarrage, c certain.

    Tenez moi au courant.

    A+

    HK.



    Hicham KADIRI | Just Another IT Guy

    mardi 20 mai 2014 19:16
  • Bonjour,

    J'ai besoin du WinRE, car l'objectif n'est pas simplement d'accéder au contrôleur mais bien de l'utiliser pour restaurer une sauvegarde Windows Backup en mode BMR.

    Il me faut donc l'accès a l'utilitaire de restauration de Windows (présent dans le WinRE).

    mercredi 21 mai 2014 06:41
  • Bonjour Michel,

    Je ne penses pas pouvoir réellement répondre à votre question cependant je peux peut-être vous éclaircir !

    Je suis actuellement en train d'installer un serveur de sauvegarde Microsoft DPM et nous rencontrons beaucoup de soucis au niveau de la restauration BMR sur un serveur physique.

    J'ai rencontré comme vous un pb de pilote après avoir restauré ma sauvegarde BMR seulement sur un disque USB.

    Ce disque fut très bien reconnu par mon image WinRE que j'ai créer et mise à disposition sur mon serveur WDS. Tous les pilotes nécessaires sont installé dans mon image. La restauration depuis un lecteur physique sur un serveur est pour moi non compatible, il faudrait que vous testiez (si possible) de mettre votre sauvegarde sur un répertoire partagé et y accéder via la console "restauration du système" de votre image WinRE!

    J'espère avoir pu vous éclaircir .

    Tenez moi informé.

    Bon courage .



    mercredi 4 juin 2014 13:15