none
Problème de validation de configuration avant création Cluster

    Question

  • Bonjour,

    voici ma config:

    OS W2016Serv serveur contrôleur de domaine, hyperV, 2 VMs W2016, 1 nom de domaine sous l'OS

    1 routeur wifi netgear wndr3700v2 avec réservation d'adresses dont 1 en dhcp pour le DNS (elle ne change jamais...)

    Mon problème est le suivant:

    Après avoir créer 2 initiators des 2 VMs liés entre eux qui pointent sur 3 disques vhdx iSCSI, impossible de valider la configuration avant création du cluster.

    D'ailleurs sous les propriétés de l'initiateur, si je met mon adresse cible (celle de mon serveur physique 2016), la connexion rapide ne fonctionne pas et je n'ai aucune cible disponible.Tout est blanc et rien n'est détecté.

    Ma config logiciel OS + VMs est la suivante:

    OS: 192.168.1.X / VM1: 192.168.1.Y / VM2: 192.168.1.Z / passerelle OS vers @routeur netgear / DNS : @OS W2016 à chaque VM (cela permet d'atteindre le domaine pour les VMs)

    Je peux pinger de partout chaque machine physique ou virtuelle de cette manière mais la validation ne passe pas.

    J'ai l'erreur : La fonctionnalité Clusteing de basculement n'est pas installée sur le serveur "VMx", un comble car toutes les fonctionnalités sont installées , sur les 2 VMs alors que je les sélectionne !.....

    Comprends pas, l'assistant voit bien le domaine et les 2 VMs du point de vue Gestionnaire du cluster de basculement sur l'OS physique mais après j'ai l'erreur, et veuillez utiliser le gestionnaire de serveur pour installer la fonctionnalité.

    J'ai cherché de partout , impossible de savoir d'où ça vient, l'observateur d'évènement n'est pas explicite sur ce problème...

    Merci par avance.

    lundi 20 mai 2019 16:53

Toutes les réponses

  • Bonjour, pour commencer j'aimerai juste comprendre votre configuration.

    Vous n'avez qu'un seul serveur Physique qui héberge un contrôleur de domaine et Hyper-v?

    Vous souhaitez monter du stockage iSCSI sur les 2 vMS présentent sur l'HYPERV? C'est bien ça?

    Cordialement.

    mardi 21 mai 2019 08:09
  • Bonjour, oui je veux monter stockage sur les 2 VMs qui seront en cluster.

    Mais je me demande si j'ai pas la manip à l'envers car j'ai mes 3 disques créés sur l'OS hôte physique W2016 et les initiateurs aussi

    Cordialement.

    mardi 21 mai 2019 21:26
  • Bonsoir,

    si je comprends bien, les initiateurs devraient être créés sur les serveurs virtuels.

    Le target iCSCI devrait être défini sur le serveur physique, ainsi que les volumes/disques iSCSI.

    Dans ce cadre là, le cluster doit être configuré à partir et avec les 2 serveurs virtuels.

    Est-ce bien le cas?

    A+


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(86 MCPs). MCSA Office 365,Microsoft 365 Certified: Messaging Administrator Associate,Modern Desktop Administrator Associate http://base.faqexchange.info

    mardi 21 mai 2019 22:02
  • Ben à priori oui mais je vais sur la VM2 et je vais dans le gestionnaire de cluster et j'essaie de créer et là l'ai l'erreur pas de fonctionnalité de cluster installée alors qu'elle l'est partout !

    Je ne comprends plus.

    mercredi 22 mai 2019 17:48
  • Bonjour,

    quand je vais sur les 2 VM et le gestionnaire de cluster, pour la validation je sélectionne l'hote physique OS2016SERV, et j'ai l'erreur:

    "Vous n'avez pas de privilèges d'administration sur le serveur".

    On est bien d'accord que les target iSCSI de stockage sont sur le serveur physique, ou est-ce un choix au départ soit sur les VM ou l'hote.

    Sachant que je n'ai qu'une carte réseau physique, le reste est le lien virtuel vers cette carte

    jeudi 23 mai 2019 09:43
  • Bonjour,

    Dans un premier temps, la gestion du cluster n'a pas besoin de gérer l'aspect "disque".

    Le serveur physique ne fait pas partie du cluster des 2 VMs, et n'a donc pas à être utilisé dans la validation...

    Par ailleurs, il faut utiliser un compte  "admin du domaine" pour garantir les droits d'accès à tous les serveurs.

    A+


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(86 MCPs). MCSA Office 365,Microsoft 365 Certified: Messaging Administrator Associate,Modern Desktop Administrator Associate http://base.faqexchange.info

    jeudi 23 mai 2019 09:49
  • Alors je viens de refaire selon cette méthode:

    Création d'un disque "target" sur le serveur hote par le gestionnaire disque ISCSI et voir lien ci-dessous

    Sur les 2 VM, initiateur qui pointe sur l'IP du serveur hote , détection ok et connection ok

    Lancement gestionnaire de disque, initialisation disque sur les 2 VM, du coup, je ne comprends pas j'ai le disque en double(étrange...) et une erreur sur 1 des 2 VM (média protégé en écriture,bon pas grave)

    http://yacinesalhi.fr/wp-content/uploads/2018/03/Mise-en-place-dun-cluster-de-basculement.pdf

    Mais je bloque sur 2 choses à chaque fois, finalement dans le gestionnaire ISCSI, le target est non connecté alors que sous les 2 VM la target initiator est connectée alors qu'avant ce n'était pas le cas.

    Sous le gestionnaire ISCSI du serveur hote, la target du disque virtuel créé au départ est marqué statut Cible Connecté mais statut du disque  virtuel Non connecté alors qu'il devrait l'être...

    La deuxième est que lorsque je veux créer le Cluster, j'ai encore l'erreur

    La fonctionnalité Clustering de basculement n'est pas installée sur le serveur VMx, je l'ai fait par l'outil graphique et j'ai mis les premiers outils, même les 4 c'est pareil... Faut-il passer par POWERSHELL pour forcer l'installation ?Quelqu'un a t-il eu cette erreur ?

    Help please...

    Merci.

    jeudi 23 mai 2019 14:42
  • Dans l'observateur d'évènements, ça se rapporte à :

    DCOM n’a pas pu communiquer avec l’ordinateur WIN-VIRTULAB à l’aide des protocoles configurés ; demande du PID      67c (C:\Windows\system32\mmc.exe).

    jeudi 23 mai 2019 14:51
  • Bonjour,

    je pense qu'il manque les étapes de création du cluster dans le fichier PDF.

    Après installation de la fonctionnalité Cluster, aucun cluster n'est installé, contrairement à ce que montre les captures d'écran.

    => Il faut lancer l'outil d'administration (qui devrait être vide) et utiliser le choix "create cluster". Ensuite seulement, on pourra choisir de valider ou pas valider les composants...

    Toute cette (première) partie est indépendante de l'utilisation de iSCSI qui n'est pas obligatoire.

    A+


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(86 MCPs). MCSA Office 365,Microsoft 365 Certified: Messaging Administrator Associate,Modern Desktop Administrator Associate http://base.faqexchange.info

    jeudi 23 mai 2019 14:52
  • lundi 27 mai 2019 18:54