locked
Probleme sur page RIS (login.osc) RRS feed

  • Discussion générale

  • Bonjour,

    J'ai depuis peu un souci sur une page de configuration du serveur RIS (celle qui s'appelle login.osc) voici la structure de la page :

    <OSCML>
    <TITLE>  ########                                                   Identification </TITLE>
    <FOOTER>  [TAB] Suivant        [ESC] Retour       [F1] Aide        [F3] Redemarrage </FOOTER>
    <META KEY=F3 ACTION="REBOOT">
    <META KEY=ESC HREF="WELCOME">
    <META KEY=F1 HREF="HLPLOG">
    <META ACTION="LOGIN">
    <BODY left=5 right=75>
    <P left=20>
    <FLASH>*******************************************</FLASH><BR>
    <FLASH>* Attention le clavier est en mode QWERTY *</FLASH><BR>
    <FLASH>*******************************************</FLASH><BR>
    </P>
    <FORM ACTION="OSCUST">
    <BOLD>Nom de l'ordinateur:</BOLD> <INPUT NAME="MACHINENAME" VALUE="xxxxxxxxxxx" SIZE=12 MAXLENGTH=15><BR>
    <BOLD>Utilisateur:</BOLD> <INPUT NAME="USERNAME" VALUE="*******" MAXLENGTH=32 SIZE=8><BR>
    <BOLD>Mot de passe:</BOLD> <INPUT NAME="*PASSWORD"  VALUE="********" TYPE=PASSWORD MAXLENGTH=14 SIZE=8><BR>
    <BOLD>Domaine:</BOLD> #########<INPUT NAME="USERDOMAIN" VALUE="#########" MAXLENGTH=10 TYPE=VARIABLE><BR>
    <BR>
    <FLASH>==> </FLASH>Chemin dans l'active directory: <SELECT NAME="MACHINEOU" SIZE=2>
    <OPTION SELECTED VALUE="##########" TIP="#######" MAXLENGTH=512>STANDARD
    <OPTION VALUE="########" TIP="#######" MAXLENGTH=512>NOMADE
    </SELECT>
    <BR>
    <BR>
    <INPUT NAME="NTLMV2Enabled" VALUE=%NTLMV2Enabled% MAXLENGTH=255 type=VARIABLE>
    <INPUT NAME="ServerUTCFileTime" VALUE=%ServerUTCFileTime% MAXLENGTH=255 type=VARIABLE>
    Compte d'ordinateur (OSN): <TIPAREA LEFT=50 RIGHT=75>
    </FORM>
    <BR><BR><BOLD><FLASH>
    ATTENTION N'OUBLIEZ PAS DE SELECTIONNER l'O.U. DU COMPTE D'ORDINATEUR</FLASH><BR>
    ==> (Chemin dans l'active directory)
    </FLASH></BOLD>
    </BODY>
    </OSCML>
    Les # sont la pour remplacer les champs confidentiels ;)

    Donc voila mon souci :

    Lorsque j'arrive sur cette page le premier champ selectionner est le nom d'ordinateur (normal jusque la), puis si je fais une tabulation ou la fleche du bas j'arrive alors sur le champ Utilisateur, encore une fois et j'arrive sur le champ mot de passe.
    Et la rien ne va plus ... impossible avec la tabulation d'aller selectionner le champ selection du chemin dans l'activ directory ni meme avec la fleche du bas! et le plus etrange c'est que le seul moyen d'y aller est de remonter jusqu'a la ligne du nom d'ordinateur et de faire fleche du haut (!!??).
    A ce moment j'arrive bien sur le choix du chemin activ directory et le seul moyen d'en ressortir est la combinaison Shift+Tab qui m'amenne sur le champ mot de passe ...

    J'ai beau relire et relire le code je ne vois vraiment pas le probleme.
    Quelqu'un aurait il une idée sur la raison de ce bug ???
    Merci d'avance.
    jeudi 4 mars 2010 12:57

Toutes les réponses

  • Bonjour,

    Tu peux consulter  http://www.mvps.org/serverstuff/RIS/customrisscreens.htm pour voir un exemple de fichier login.osc personnalisé. 

    Voir aussi : http://technet.microsoft.com/fr-fr/library/cc781135(WS.10).aspx

    Caution

    • If you customize Login.osc, be careful not to modify any of the values within the following OSML tags:
    • <INPUT NAME="NTLMV2Enabled" VALUE=%NTLMV2Enabled% MAXLENGTH=255 type=VARIABLE>
    • <INPUT NAME="ServerUTCFileTime" VALUE=%ServerUTCFileTime% MAXLENGTH=255 type=VARIABLE>
    • Changing any of these values causes you to lose NTLM v2 support.

     

    Tiens-nous au courant,

    Cordialement,

    Roxana


    Roxana Panait, MSFT
    lundi 8 mars 2010 16:25
  • Bonjour,

    Merci de nous tenir au courant avec la résolution de ton problème.

    Cordialement

    Roxana


    Roxana Panait, MSFT
    jeudi 11 mars 2010 14:29
  • Bonjour ,

    J'ai été obliger de créer une nouvelle page .osc!
    Je n'ai pas pu résoudre ce bug autrement.

    En gros :
    J'ai créé une page (ou.osc) placer juste après l'écran d'accueil qui permet de demander un type de machine qui selon le cas changera l'OU dans laquelle la machine sera stockée.
    Puis ensuite viens le login.osc qui demande les identifiants et le nom de machine.

    J'ai l'impression que la FORM de login.osc ne peut pas contenir a la fois un INPUT et un SELECT ce qui provoque un comportement étrange au niveau des différents champ:
    L'OU n'est jamais prise en compte et garde l'option par défaut mais surtout la tabulation ne passe pas par tous les champs !
    Et le fait de mettre 2 FORM dans la page a des comportement encore plus étrange.
    Du coup la seule solution trouvée est de créer une nouvelle page.
    lundi 15 mars 2010 18:08