locked
Mise à jour de java impossible RRS feed

Réponses

  • Hello, .. bon on voit le bout .. enfin :)

    Alors déjà voilà ce que je retiens essentiellement :

    - TCP IP_srv_Isa:8080 IP_srv_Isa:3591 En attente 0 Idle
    - TCP IP_srv_Isa:8080 IP_srv_Isa:5043 établie 3604 isvw-http.exe

    Alors tu as le PID 0, qui est donc system ... je suspecte que tu as installé IIS sur ton serveur ISA.
    De plus, tu as une connexion établie avec le même port avec le process isvw-http.exe, donc par déduction InterScan VirusWall !!!

    Donc forcément l'écoute proxy dans ISA avec le port 8080 ne fonctionnera jamais. Déjà, il n'est pas recommandé d'installer IIS sur un serveur ISA. Je ne pense pas que cela soit un prérequis pour ISVW, donc il serait grand temps de désinstaller IIS.

    Ensuite, ton ISVW écoute sur le port 8080; le même que celui d'ISA par défaut. Alors soit tu changes le port d'écoute d'ISA, ou celui d'ISVW. Je pense que tous tes clients sont configurés pour utiliser le port 8080, donc autant conserver celui d'ISA et modifier celui d'ISVW. Cela implique de modifier la configuration d'ISA afin de renvoyer vers un serveur proxy en amont, qui sera localhost avec le nouveau port d'ISVW si tu veux continuer à utiliser le scan HTTP.

    J'ai l'impression que l'ISA n'est en fait pas vraiment utilisé ici. Ta configuration est vraiment hors norme et non supporté au vue des nombreux logs que j'ai lu. Tu vas donc devoir bien tout re configurer pour pleinement utiliser les solutions conjointes, d'autant que tu veux tout sur un seul serveur. Logiquement ISA et ISVW sont sur deux serveurs séparés.

    En tout cas, c'est bien là ... la source de tes problèmes :)

    Alex

     


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    vendredi 4 novembre 2011 12:07

Toutes les réponses

  • Bonjour,

    Il semble, après quelques recherches que c'est un problème Java. J'ai trouvé ceci :

    We found the problem to be the new setting below in the Proxy.cfg
     
    SendHTTP11Request=1
     
    Once we commented that out the problem went away.
     

    Peux-tu essayer ?


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    • Marqué comme réponse mazu26 mercredi 19 octobre 2011 13:28
    • Non marqué comme réponse mazu26 mercredi 19 octobre 2011 13:29
    mercredi 19 octobre 2011 12:26
  • Par contre je ne trouve pas ce fichier de paramètres proxy.cfg ...

    Cependant, je viens de penser à autre chose. Peux-tu essayer sur un poste de supprimer et importer les paramètres de proxy sur WinHTTP

    Depuis une station de travail avec Internet Explorer configuré correctement avec les paramètres de Proxy, tu éxécutes

    proxycfg -d
    proxycfg -u

    Voilà


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    mercredi 19 octobre 2011 12:31
  • J'ai oublié de préciser que mes clients sont tous des Windows 7. Je crois que la commande proxycfg n'existe plus sur Seven (ainsi que Vista et 2008). C'est plutôt çà que je dois faire ?

    netsh winhttp reset proxy

    netsh winhttp set proxy MyProxy:PortNum ou netsh winhttp import proxy source=ie


    • Modifié mazu26 mercredi 19 octobre 2011 15:11
    mercredi 19 octobre 2011 15:04
  • Alex fatigué ... :)

    Alors pour la seconde commande, préfère l'import plutôt : netsh winhttp import proxy source=ie

     


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    mercredi 19 octobre 2011 15:12
  • J'ai fait, redémarré mais idem.
    mercredi 19 octobre 2011 15:24
  • Alors à tout hasard, tu peux faire une journalisation au niveau d'ISA pour vérifier qu'un flux arrive tout de même en tant que Proxy ?

    Deux, tu peux croiser avec un netmon localement sur la station pour vérifier également.

     

    Cela pourrait nous aider


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    mercredi 19 octobre 2011 16:54
  • Je t'ai envoyé la journalisation ISA de la tentative de mise à jour manuelle de java sur un de mes clients Win7.

    Pour infos, aurez-tu un exemple concret d'une appli qui a besoin qu'on mette le proxy au niveau de WinHTTP. C'est juste pour mon expérience perso.

    Merci

    vendredi 21 octobre 2011 07:35
  • Hello,

     

    Je ne sais plus si tu m'as dit si ton serveur ISA est en SingleNic ou en Edge ? Par ailleurs j'ai à la fois un protocole 'http" et "Proxy http" ... Tu as crée un protocole personalisé http ? Tu as bien le filtre "Web Proxy Filter" ? Cela devient étrange ta situation, ou je deviens un peu perdu :)

    Un exemple ou j'utilise WinHTTP, des composants Windows Update sera ma première réponse ;) La preuve : http://support.microsoft.com/kb/836941#advmethodB

    Alex


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    vendredi 21 octobre 2011 18:43
  • Salut,

    Mon ISA a 2 cartes réseaux. Une reliée au LAN et l'autre vers l'exterieur.

    "http" et "Proxy http" ne sont pas sous "Définit par l’utilisateur" donc ce ne sont pas des protocoles personnalisés. "Web Proxy filter" est coché pour les 2. Qu'est-ce qui te surprends ?

    Merci


    • Modifié mazu26 lundi 24 octobre 2011 08:39
    lundi 24 octobre 2011 08:22
  • Hello,

    Là ce qui me surprend, c'est ta règle surtout. Tu n'as aucune raison à mettre "Hôte local" en destination. Comme ton serveur ISa a deux cartes, donc Edge, cela doit être Externe la destination. Si tu avais ton ISA en SingleNic, alors la destination aurai du être interne.

    De plus, tu n'as aucune raison de mettre Proxy HTTP dans cette liste, seul HTTP est suffisant.

    Alex


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    lundi 24 octobre 2011 17:51
  • Salut Alex et merci encore pour ta aide,

    J'apprends, j’apprends mais j'ai toujours des interrogations. Si je mets "Externe" en destination il faut obligatoirement que je mette la passerelle au niveau du client. C'est bien çà ? Moi je préfère ne pas coller la passerelle sur tous mes clients donc la règle ???

    Dans les param IE du client, il y a donc le nom du serveur proxy + port 8080. Je pensais que dans la règle il fallait ajouter http sur port 8080 (dans mon cas = à Proxy HTTP) ?

    mardi 25 octobre 2011 07:16
  • Hello,

    Non le fait de mettre externe, ne t'oblige pas à avoir de passerelle pour le flux web (proxy).


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    jeudi 27 octobre 2011 15:49
  • Ok Merci pour les précisions.

    J'ai refais des tests concernant ton doute sur la destination" Hôte Local" dans ma règle, j'en ai recréé 4 (en premières positions) avec l'ordre suivant pour voir laquelle est utilisée dans la journalisation. "MonPcClient" n'a que les param du proxy dans IE, pas de passerelle et pas de client firewall.

    Règle 1 : Autoriser    -    HTTP    -    MonPCTest    -    Externe    -    Tous les utilisateurs

    Règle 2 : Autoriser    -    HTTP    -    MonPCTest    -    Hôte Local    -    Tous les utilisateurs

    Règle 3 : Autoriser    -    Proxy HTTP    -    MonPCTest    -    Externe    -    Tous les utilisateur

    Règle 4 : Autoriser    -    Proxy HTTP    -    MonPCTest    -    Hôte Local    -    Tous les utilisateurs

    Et bien c'est la règle n°4 qui est utilisée. C'est elle que je vois dans la journalisation et pas la 1 ni la 2 ni la 3. Je me sens un peu perdu car d'après vous cela aurait du être la n°1.

    Je remplace protocole "Proxy HTTP" de la n°4 par HTTP et çà ne marche plus. Ce qui confirme que c'est la 4.

    Je suis largué. çà aurait du être la 1 !!!!

    vendredi 28 octobre 2011 14:04
  • Tu dois avoir un problème de configuration, à mon avis car le comportement n'est pas celui attendu.

    Peux-tu faire un ISA BPA ... et m'envoyer le XML stp. Je dois vérifier quelques points.


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    vendredi 28 octobre 2011 14:31
  • c'est envoyé.

    vendredi 28 octobre 2011 14:41
  • reçu ...

    Alors ce qui me choque de suite, c'est ceci :

    Enable Web Proxy client connections for this network    =False

    Il semble que tu n'as pas activé les fonctions proxy pour ton réseau interne.

    Peux-tu me confirmer cet onglet dans l'objet réseau interne :

    Ensuite, je vois un problème d'allocation du port 8080 sur ton serveur :

    26/10/2011 17:38:46 - Le filtre du proxy Web n'a pas pu lier son socket sur 127.0.0.1, port 8080. Cela peut être dû à un autre service utilisant déjà le même port ou à la carte réseau qui ne fonctionne pas. Pour résoudre ce problème, redémarrez le service Pare-feu de Microsoft. Le code d'erreur de la zone des données des propriétés de l'événement indique la cause de l'échec.
     La panne est due à l'erreur suivante : Une tentative d'accès à un socket de manière interdite par ses autorisations d'accès a été tentée.

    As-tu un outil, un logiciel (antivirus, ...) qui utilise ce port ? fais un netstat -ano | find ":8080" puis en fonction du process (PID) regarde à quoi le process est associé.

    Déjà cela nous donne une bonne piste.

     


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    vendredi 28 octobre 2011 14:54
  • Bonjour,

    Effectivement, netstat -ano | find ":8080" donne çà :

     

    TCP 0.0.0.0:8080 0.0.0.0:0 En écoute 3604 isvw-http.exe
    TCP IP_srv_Isa:4829 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:4948 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:4987 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:4991 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:4995 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5000 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5002 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5007 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5029 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5043 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5067 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5098 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5103 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5108 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5154 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5161 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5173 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5195 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5333 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5339 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5517 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5533 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5539 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:5541 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5543 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5545 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5552 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:5554 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:3591 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:3830 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:3839 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:3928 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:3934 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:3945 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:3983 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4068 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4173 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4416 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4514 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4516 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4587 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4589 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4755 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4822 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4882 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:4977 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:5043 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5067 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5103 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5161 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5173 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5193 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:5195 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5333 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5367 En attente 0 Idle
    TCP IP_srv_Isa:8080 IP_srv_Isa:5517 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5541 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5543 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5545 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5552 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:5554 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:40623 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:40748 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:41285 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:41874 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:42264 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:42453 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:42477 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:42935 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:42939 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:44343 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:45414 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:8080 IP_srv_Isa:55876 établie 3604 isvw-http.exe
    TCP IP_srv_Isa:25369 IP_srv_Isa:8080 Fin de l'attente 948 coreServiceShell.exe
    TCP IP_srv_Isa:40623 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:40748 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:41285 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:41336 IP_srv_Isa:8080 Fin de l'attente 948 coreServiceShell.exe
    TCP IP_srv_Isa:41874 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:42264 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:42453 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:42477 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:42935 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:42939 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:44277 IP_srv_Isa:8080 Fin de l'attente 948 coreServiceShell.exe
    TCP IP_srv_Isa:44343 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:44526 IP_srv_Isa:8080 Fin de l'attente 948 coreServiceShell.exe
    TCP IP_srv_Isa:44595 IP_srv_Isa:8080 En attente 0 Idle
    TCP IP_srv_Isa:45414 IP_srv_Isa:8080 établie 3612 wspsrv.exe
    TCP IP_srv_Isa:55876 IP_srv_Isa:8080 établie 3612

    wspsrv.exe

    vendredi 4 novembre 2011 11:02
  • Hello, .. bon on voit le bout .. enfin :)

    Alors déjà voilà ce que je retiens essentiellement :

    - TCP IP_srv_Isa:8080 IP_srv_Isa:3591 En attente 0 Idle
    - TCP IP_srv_Isa:8080 IP_srv_Isa:5043 établie 3604 isvw-http.exe

    Alors tu as le PID 0, qui est donc system ... je suspecte que tu as installé IIS sur ton serveur ISA.
    De plus, tu as une connexion établie avec le même port avec le process isvw-http.exe, donc par déduction InterScan VirusWall !!!

    Donc forcément l'écoute proxy dans ISA avec le port 8080 ne fonctionnera jamais. Déjà, il n'est pas recommandé d'installer IIS sur un serveur ISA. Je ne pense pas que cela soit un prérequis pour ISVW, donc il serait grand temps de désinstaller IIS.

    Ensuite, ton ISVW écoute sur le port 8080; le même que celui d'ISA par défaut. Alors soit tu changes le port d'écoute d'ISA, ou celui d'ISVW. Je pense que tous tes clients sont configurés pour utiliser le port 8080, donc autant conserver celui d'ISA et modifier celui d'ISVW. Cela implique de modifier la configuration d'ISA afin de renvoyer vers un serveur proxy en amont, qui sera localhost avec le nouveau port d'ISVW si tu veux continuer à utiliser le scan HTTP.

    J'ai l'impression que l'ISA n'est en fait pas vraiment utilisé ici. Ta configuration est vraiment hors norme et non supporté au vue des nombreux logs que j'ai lu. Tu vas donc devoir bien tout re configurer pour pleinement utiliser les solutions conjointes, d'autant que tu veux tout sur un seul serveur. Logiquement ISA et ISVW sont sur deux serveurs séparés.

    En tout cas, c'est bien là ... la source de tes problèmes :)

    Alex

     


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    vendredi 4 novembre 2011 12:07
  • Bonjour, pour poursuivre :


    - TCP IP_srv_Isa:8080 IP_srv_Isa:3591 En attente 0 Idle
    - TCP IP_srv_Isa:8080 IP_srv_Isa:5043 établie 3604 isvw-http.exe


    Ok mais pour le PID 0, j'ai regardé sur mon serveur, j'ai bien IIS d'installé mais j'ai rien pour le port 8080. Je n'ai que 80, 8059,et 8082 :





    Donc je ne pige pas cette ligne "TCP IP_srv_Isa:8080 IP_srv_Isa:3591 En attente 0 Idle".
    C'est pas PID 4 pour process system ?

    Merci



    • Modifié mazu26 jeudi 2 février 2012 16:34
    jeudi 2 février 2012 11:36
  • Bonjour,

    IIS utilise le PID 4 pour l'allocalisation des ports, donc c'est normal. Essaye d'arrêter IIS, et tu verras bien en refaisant le netstat si tu as encore l'écoute sur le port 8080.

    Alex


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.
    lundi 6 février 2012 15:00