none
InfoPath 2013 - People Picker stops working in desktop application

    Question

  • Hi all,

    We have been expericing an intermitten people picker issue for quite a few months now. The issue is that the people picker stops working when using the desktop version of InfoPath 2013. The issue seems quite random, where it can work absolutely fine one day and then stops working the next. We are yet to find a solution to the issue so wondering if anyone else has experienced the same or knows what could be causing it?

    We have never seen the problem occur in browser forms, only the application.

    Any advice would be massively appreciated! Thanks

    Mike

    mercredi 30 mai 2018 11:50

Toutes les réponses

  • Hi Mike,

    To troubleshoot this issue, let's verify the followings:

    1. Is there an error displaying when the people picker stopped working? If yes, please provide the detailed information about this error.

    2. Except the people picker, could other fields work well like lookup or other type?

    3. Do all people picker columns in the form have this issue?

    4. Do all users have this issue? What permissions did your account have on the site?

    For this issue, please do that:

    1. Please make sure there is no network issue in your machine when this issue occurs.

    2. Please check Event Viewer to check if there is any error message about this issue, and also collect the application log using Fiddler when this issue occurs again.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 31 mai 2018 09:02
    Modérateur
  • Hi Mike,

    I am checking to see how things are going there on this issue.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    mardi 5 juin 2018 08:37
    Modérateur
  • Hi Wendy,

    Thanks for your reply.

     1. Is there an error displaying when the people picker stopped working? If yes, please provide the detailed information about this error.

    The people picker just fails to pull any names/groups from the organisation directory. Also if you enter in a username and click to verify it comes back with red text (as if it can't find the name).

    2. Except the people picker, could other fields work well like lookup or other type?

    The people picker is used to fire an email off to the appropriate person and works fine most of the time, but when the downtime occurs it causes issues. Ideally we'd just like to understand what's causing it.

    3. Do all people picker columns in the form have this issue?

    All forms which use people picker are affected at the same time yes, so it's not down to a single form.

    4. Do all users have this issue? What permissions did your account have on the site?

    As far as i'm aware, yes. It's absolutely nothing to do with permissions I can rule that out. I'm the SP Farm Admin and have tested it on multiple accounts plus the users use these forms on a daily basis. Also users sometimes complete multiple forms a day, and it works fine, then randomly it'll stop working. Can go down anywhere from 20 minutes to a few hours.

    For this issue, please do that:

    1. Please make sure there is no network issue in your machine when this issue occurs.

    Again, 100% not a network issue on a local machine as it affects all forms company wide for all users.

    2. Please check Event Viewer to check if there is any error message about this issue, and also collect the application log using Fiddler when this issue occurs again

    I will take a look at these.

    lundi 11 juin 2018 11:56