locked
Ressources GPU via Hyper V RRS feed

  • Question

  • Bonjour,
    Étant développeur Windows Phone 8, j'ai installé le SDK ainsi que Visual Studio 2012 Express. Lors de l'installation, Hyper-V est activé afin de permettre le fonctionnement du simulateur.
    Le problème est que ce poste est ma machine personnelle et qu'elle sert donc aussi aux jeux et à la vidéo. Or là, gros problème ! Quand Hyper-V est installé, les ressources GPU sont extrêmement détériorées. Ma carte graphique est une AMD HD7970 GHz et c'est comme si j'avais une carte bas de gamme ) 30€ !
    La lecture des vidéos est saccadée et les jeux subissent une perte d'images par seconde d'au moins 50% ! J'ai donc désactivé Hyper-V et là retour à la normal, mais évidemment, plus de simulateur pour développer. Simplement arrêter le service ne corrige pas le problème.
    Existe t-il un moyen pour que l'activation d'Hyper-V ne plombent pas les performances ?
    Cordialement.
    samedi 17 novembre 2012 18:06

Réponses

  • Un petit retour depuis le temps : les pilotes 13.12 d'AMD ont résolu le problème et tout fonctionne parfaitement. Je suis de plus passé récemment à une R9 290X et ça fonctionne parfaitement, même avec les jeux utilisants Mantle.

    Ça fait plaisir de pouvoir à la fois bosser et jouer :D

    • Marqué comme réponse Aarklendoia mardi 29 avril 2014 07:18
    mardi 29 avril 2014 07:18
  • Bonjour,

    Vérifiez la configuration de votre bios(hyper-threading, VT-x), mettez à jour(bios) si nécessaire.

    Hyper-V côté serveur est très bien, malheureusement côté client...

    Après avoir tenté pas mal de choses, j'ai opté pour un logiciel tiers(Vmware workstation 9) sur mon poste personnel.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT

    samedi 17 novembre 2012 23:40
  • Hello,

    Ton problème ressemble à celui que nous avions sous Hyper-v2 (http://support.microsoft.com/kb/961661)

    Dès qu'un pilote de carte graphique "accéléré" est installée, il semblerai que ceux-ci ne soit pas bien prix en charge par l'hyperviseur. La KB préconise de faire un rollback vers le pilote de base Windows, mais celui-ci n'est pas terrible pour jouer et exploiter à fond les perf de la carte!

    D'autre part, essaie de modifier le thème de ton Windows et de prendre un thème plus classique à la Win2000 (juste pour tester), il semblerai aussi que Aero puisse avoir un rôle à jouer là-dedans.

    Mathieu

    mercredi 21 novembre 2012 16:02

Toutes les réponses