none
Service bureau à distance, accès depuis l'extérieur RRS feed

  • Discussion générale

  • Petite précision : 

    Lorsque je NAT le port 443 sur ma passerelle de bureau à distance et je me connecte depuis l'extérieur avec le programme Bureau à distance (mstsc.exe) en précisant la passerelle de bureau à distance dans les options avancées(remote.mondom.com), je peux me connecter à une machine virtuelle personnelle.

    Mais toujours se problème de connexion par le navigateur.

    Bonjour,

    Je m'adresse à vous car je bloque sur quelque chose..

    J'ai mis en place une infrastructure permettant de faire de la VDI.

    Configuration :

    1 Contrôleur de domaine physique

    2 Hyperviseurs en cluster pour accueillir mes machines virtuelles.

    En virtuel :

    RD-CB01 (Connexion broker)
    RD-SH01 (Session host)
    RD-WA01 (Web access)
    RD-GW01 (Passerelle bureau à distance)
    RD-MGT01 (Pour manager le tout)

    Au niveau certificat, j'utilise un certificat auto-signé récupérer sur internet (pour test)

    J'ai créer une collection basé sur des ordinateurs virtuel personnel

    L'accès en local fonctionne.

    L'accès depuis l'extérieur fonctionne, du moins je peux accéder à la fenêtre de login, l'authentification fonctionne et je vois ma machine virtuelle personnel.

    Mais lorsque que je télécharge mon fichier .RDP, je l'ouvre et je vois :

    Ordinateur distant : Mon serveur virtuel Broker (RD-CB01.mondomainelocal.local)
    Serveur de passerelle : Mon serveur de passerelle (RD-GW01.mondomainelocal.local)

    Déjà là, est-ce juste ?

    Ensuite, lorsque que je rentre mes données d'accès, j'obtiens l'erreur suivante :

    "Votre ordinateur ne peut pas se connecter à l'ordinateur distant, car une erreur s'est produite sur l'ordinateur distant auquel vous tentez de vous connecter."

    Auriez-vous une piste ? Le problème peut-il venir des certificats ?

    D'avance je vous remercie.


    mercredi 20 juillet 2016 19:57

Toutes les réponses

  • Après avoir un peut cherché et testé quelques manipulations. J'obtient l'erreur suivante : 

    "Votre ordinateur ne peut se connecter à l'ordinateur distant, car l'adresse du serveur de passerelle Bureau à distance est provisoirement inaccessible. Essayer de vous reconnecter ultérieurement, ou contactez votre administrateur réseau."

    Je pense que le problème vient la redirection des ports de mon firewall ou quelque chose comme ça.

    Quelqu'un aurait-il une idée ? Je ne pense pas être loin du but..

    Merci d'avance.
    jeudi 21 juillet 2016 15:46
  • Bonjour,

    à mon avis, dans les paramètres du déploiement de RDS vous avez probablement entré l'adresse interne de votre gateway (car lorsque vous téléchargez le fichier .RDP c'est RD-GW01.mondomainelocal.local qui est affichée) au lieu de l'adresse externe.

    Essayez de modifier cela dans les paramètres de déploiement, comme indiqué dans l'image ci-dessous:

    jeudi 21 juillet 2016 18:15
  • Bonsoir,

    Merci pour votre réponse.

    Malheureusement le "Server name" de la passerelle est déjà réglée comme votre proposition :

           - "connect.domaine.com" qui est aussi le même nom inscrit dans mon certificat auto-signé. 

    Merci

    jeudi 21 juillet 2016 19:45
  • D'accord, la prochaine étape serait de regarder directement dans le fichier RDP avec un éditeur de texte pour voir exactement quelles sont les différents paramètres/adresses.

    Procurez-vous le fichier RDP depuis la page web, et ouvrez-le un éditeur de texte comme notepad ou notepad++ puis jetez un oeil aux différentes adresses afin de voir si ça vous paraît correct.

    De mémoire, il devrait y avoir un gatewayhostname qui devrait correspondre à l'adresse publique de votre ferme RDS. Je n'ai actuellement pas de fichiers sous la main pour en dire plus dans l'immédiat malheureusement.

    lundi 25 juillet 2016 17:10
  • Merci encore pour votre aide.

    J'ai fais la manipulation demandé et voici les résultats :

    Précision : Le fichier RDP que j'ai ouvert est sensé exécuter la calculatrice en RemoteApp. Même erreur qu'un bureau virtuel.

    redirectclipboard:i:1
    redirectprinters:i:1
    redirectcomports:i:0
    redirectsmartcards:i:1
    devicestoredirect:s:*
    drivestoredirect:s:*
    redirectdrives:i:1
    session bpp:i:32
    prompt for credentials on client:i:1
    span monitors:i:1
    use multimon:i:1
    remoteapplicationmode:i:1
    server port:i:3389
    allow font smoothing:i:1
    promptcredentialonce:i:1
    videoplaybackmode:i:1
    audiocapturemode:i:1
    gatewayusagemethod:i:1
    gatewayprofileusagemethod:i:1
    gatewaycredentialssource:i:0
    full address:s:connect.mondomaine.com
    alternate shell:s:||win32calc
    remoteapplicationprogram:s:||win32calc
    gatewayhostname:s:connect.mondomaine.com
    remoteapplicationname:s:Calculatrice
    remoteapplicationcmdline:s:
    workspace id:s:RD-CB01.labvdi.local
    use redirection server name:i:1
    loadbalanceinfo:s:tsv://VMResource.1.Windows_Full
    alternate full address:s:connect.mondomaine.com

    J'ai également lu qu'il fallait créer un enregistrement DNS type (A) dans mon DNS interne : connect.mondomaine.com -> ip public

    Est-ce correct ? Le FQDN donnerait donc connect.mondomaine.com.mondomainelocal.local

    Encore une chose, je travail uniquement avec une seul adresse public. J'ai donc du modifié le port d'écoute de la passerelle de bureau à distance pour ensuite pouvoir faire correctement mes redirections de port. (444 au lieu de 443 par défaut.)

    J'ai suivis également quelques conseil du post suivant mais sans résultat.

    http://www.networksteve.com/forum/topic.php/Server_2012_RDWeb_internal_/_external_domain_name_mismatch/?TopicId=64291&Posts=16

    D'avance je vous remercie.

    lundi 25 juillet 2016 21:01
  • Je reviens vers vous pour vous donner quelques nouvelles,

    Toujours en essayant d'exécuté une machine virtuelle en pool depuis ma page web (RDWeb), j'ai essayé de modifier le fichier .RDP que j'obtenais en cliquant sur ma machine à disposition. 

    Voici le fichier original que je télécharge :

    redirectclipboard:i:1
    redirectprinters:i:1
    redirectcomports:i:0
    redirectsmartcards:i:1
    devicestoredirect:s:*
    drivestoredirect:s:*
    redirectdrives:i:1
    session bpp:i:32
    prompt for credentials on client:i:1
    server port:i:3389
    allow font smoothing:i:1
    promptcredentialonce:i:1
    videoplaybackmode:i:1
    audiocapturemode:i:1
    gatewayusagemethod:i:1
    gatewayprofileusagemethod:i:1
    gatewaycredentialssource:i:0
    full address:s:connect.mondomaine.com
    gatewayhostname:s:connect.mondomaine.com
    workspace id:s:RD-CB01.labvdi.local
    use redirection server name:i:1
    loadbalanceinfo:s:tsv://VMResource.1.Windows10
    use multimon:i:1
    alternate full address:s:connect.mondomaine.com
    signscope:s:Full Address,Alternate Full Address,Use Redirection Server Name,Server Port,GatewayHostname,GatewayUsageMethod,GatewayProfileUsageMethod,GatewayCredentialsSource,PromptCredentialOnce,RedirectDrives,RedirectPrinters,RedirectCOMPorts,RedirectSmartCards,RedirectClipboard,DevicesToRedirect,DrivesToRedirect,LoadBalanceInfo
    signature:s:AQABAAEAAAAiFwAAMIIXHgYJKoZIhvcNAQcCoIIXDzCCFwsCAQExCzAJBgUrDgMC  GgUAMAsGCSqGSIb3DQEHAaCCFRkwggQ2MIIDHqADAgECAgEBMA0GCSqGSIb3DQEB  BQUAMG8xCzAJBgNVBAYTAlNFMRQwEgYDVQQKEwtBZGRUcnVzdCBBQjEmMCQGA1UE  CxMdQWRkVHJ1c3QgRXh0ZXJuYWwgVFRQIE5ldHdvcmsxIjAgBgNVBAMTGUFkZFRy
    ...

    En modifiant le fichier de la manière ci-dessous, miracle, j'arrive me connecter..

    redirectclipboard:i:1
    redirectprinters:i:1
    redirectcomports:i:0
    redirectsmartcards:i:1
    devicestoredirect:s:*
    drivestoredirect:s:*
    redirectdrives:i:1
    session bpp:i:32
    prompt for credentials on client:i:1
    server port:i:3389
    allow font smoothing:i:1
    promptcredentialonce:i:1
    videoplaybackmode:i:1
    audiocapturemode:i:1
    gatewayusagemethod:i:1
    gatewayprofileusagemethod:i:1
    gatewaycredentialssource:i:0
    full address:s:connect.sol-vdi.ch
    gatewayhostname:s:connect.sol-vdi.ch:444
    workspace id:s:RD-CB01.labvdi.local
    use redirection server name:i:1
    loadbalanceinfo:s:tsv://VMResource.1.Windows10
    use multimon:i:1
    alternate full address:s:RD-CB01.labvdi.local

    D'après vous, que faut-il changer dans ma configuration ?

    J'ai déjà exécuté la commande suivante sur mon serveur de connexion broker, et j'obtient le même fichier que celui qui est fonctionnel mais avec les 2 lignes de fin (signscop, signature).

    Set-RDSessionCollectionConfiguration –CollectionName "nomcollection" -CustomRdpProperty "gatewayhostname:s:connect.mondomaine.com`n alternate full address:s:RD-CB01.labvdi.local"

    Cette commande marche uniquement si on à créer une collection basé sur des hôtes de session bureau à distance et non sur une collection basé sur des hôtes de virtualisation des services de bureaux à distance

    Savez-vous si une commande identique pour les hôtes basé sur la virtualisation des bureaux à distance existe ?

    D'avance je vous remercie.

    jeudi 28 juillet 2016 13:11
  • Bonjour,

    la commande équivalente à celle que vous mentionnez est celle-ci: Set-RDVirtualDesktopCollectionConfiguration

    effectivement, le problème vient du fait que ce n'est pas un port habituel qui est utilisé pour la gateway: 444.

    Et dans l'interface de configuration on ne peut à priori pas entrer de port au format ":444", car le fait de changer le port de la gateway n'est pas recommandé par Microsoft.

    Si ça fonctionne en rajoutant un paramètre RDP personnalisé comme vous l'avez fait pour les session host, tant mieux, bien que ça ne soit pas une solution techniquement parfaite...

    jeudi 28 juillet 2016 18:29
  • Merci pour votre réponse, D'accord, Microsoft ne recommande pas de changer le port de base, mais alors faut-il mettre le Web Access sur le même serveur que la passerelle de bureau à distance ? Dans pas mal d'exemple les deux serveurs sont séparés alors comment font-ils avec les redirection de ports ? Merci
    jeudi 28 juillet 2016 21:19
  • Bonsoir,

    mettre le WebAccess et la Gateway sur le même serveur ne pose pas de problème.

    Sinon, pour utiliser une seule adresse IP  publique et garder le port 443 pour toutes les accès, il "suffit" d'utiliser Web Application Proxy qui permet de rediriger en fonction du nom demandé.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    jeudi 28 juillet 2016 22:17
  • Merci pour la précision, je ne connaissais pas ce procéder.

    Actuellement mes deux serveurs sont séparés. (Web Access, Gateway).

    Puis-je installer le rôle Web Application Proxy sur le serveur Web Access ou dois-je le mettre sur un autre serveur appart.

    Merci d'avance.

    vendredi 29 juillet 2016 06:38
  • Bonjour,

    J'ai pris connaissance du rôle Web Application Proxy et lu quelques exemple d'installation.

    Je peine sur la première partie qui consiste à mettre en place le rôle AD FS.

    Est-ce possible de mettre en place se système avec ma configuration soit :

     - Une adresse IP public

     - Un domaine en .local 

    Sur la plupart des exemples, ils parlent de créer un enregistrement DNS qui pointe sur le serveur AD FS. Le pointeur doit-il avoir comme valeur adfs.mondomaine.local pointant sur IP local ?

    Ou alors la valeur adfs.mondomaine.com pointant sur IP public avec redirection de port ? Si oui comment fait-on cette entrée ?

    Au niveaux des certificats, doit-je prendre un auto-signé sur internet pour le domaine adfs.mondomaine.com ?

    Merci

    mardi 2 août 2016 12:26