locked
Accès distant FTP / Windows Server 2008 R2 RRS feed

  • Discussion générale

  • Bonjour à tous,

    J'utilise un serveur avec Windows Server 2008 R2. J'ai installé les rôles Serveur DNS, Serveur Web IIS et Serveur DHCP. J'ai ainsi créé différents utilisateurs AD qui utilise le domaine. J'ai créé un site FTP, dans lequel se trouvent plusieurs dossiers. Je l'ai paramétré afin de définir l'accès selon les identifiants AD du domaine.

    Je parviens à y accéder depuis n'importe quel ordinateur local avec un navigateur ou FileZilla Client, en utilisant soit l'adresse IP du serveur : ftp://xxx.xxx.x.xx, soit avec le nom de l'ordinateur : ftp://Nom_de_lordinateur. Les autorisations sont effectives.

    Mon souci est que je souhaite pouvoir y accéder en externe. Lorsque que j'utilise un poste ne faisant pas partie du domaine. L'accès est impossible même en utilisant l'ip wan du serveur : xxx.xxx.xx.xxx. ou le nom de domaine que j'ai essayé de paramétrer dans le dns : ftp.xxxxx.fr. Lorsque j'essaie en utilisant ce dernier, l'erreur "530 user cannot login in" apparait.

    J'avais le même type d'erreur en local lorsque les liaisons de mon site FTP étaient mal configurées.

    Malgré de nombreuses recherches et essais je ne parviens pas à trouver de solution. J’ai par exemple essayé de désactivé le pare feu. Mais en vain…

    Je vous remercie par avance pour votre aide.

    Cordialement. 

    lundi 22 octobre 2012 06:53

Toutes les réponses

  • Bonjour,

    lors de l’accès a votre site FTP utilise cette forme du login : Domain\NomUtilisateurAD

    Cordialement,


    Cordialement, Oussema FEKIH Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de Voter ou de la marquer comme Utile. Best Regards, Oussema FEKIH If my reply has helped you or made a resolution, thank you to vote it as helpful or mark it as answer.

    lundi 22 octobre 2012 09:08
  • Bonjour Oussema,

    Tout d'abord, merci pour votre réponse.

    Je viens de testé, je reçois le même message d'erreur lorsque j’essaie depuis mon navigateur et l'adresse ftp.xxxxx.fr.

    Avec FileZilla je reçois le message suivant : Échec de la tentative de connexion avec "EAI_NODATA - No address associated with nodename".

    Merci.

    lundi 22 octobre 2012 09:35
  • Bonjour,

    Vous pourriez vérifier dans le Centre Réseau et partage, Paramètres de partage avancés, comment  les options de partage pour d’autres profils réseau sont-elles configurées.

    Merci de nous tenir au courant.

    Cordialement,

    Dan


    Dan BAJENARU, MSFT    Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    mardi 23 octobre 2012 12:29
  • Sur l'IIS a activer svp l'authentification de base. Ceci active l'authentification en format NTLM. (http://www.iis.net/configreference/system.webserver/security/authentication/windowsauthentication/providers/add)

    En html les identification Windows passe de cette maniere (en exemple le owa d'Exchange). Si tu utilise IE pour "surfer" le site sa dverait marcher, en filezilla je ne sais pas s'il supporte ce protocole.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    mercredi 24 octobre 2012 01:37
  • Bonjour,

    J'ai modifié les paramètres du serveur DNS en rajoutant un hôte vers mon ip locale dans les zones de recherche directes. Cela permet désormais d'accéder en local avec l'adresse : ftp.xxxxx.fr. Mais pas d'effet en externe.

    J'ai également installé le service management de gestion du serveur web (IIS). Du coup, j'ai pu permettre l'authentification IISManagerAuth à mon serveur FTP.

    J'ai ensuite tenté le paramétrage de Dan.

    http://social.technet.microsoft.com/Forums/getfile/184005

    La case activer la découverte réseau ne se mémorise pas, malgré que je clique sur enregistrer les modifications. En fait lorsque j'enregistre, puis ferme ; lors de l'ouverture la case n'est plus cochée.

    Ensuite, sur les conseils de Yagmoth555, j'ai installer les services activation de base et activation windows du rôle du serveur web (IIS). Mais pas d'amélioration.

    Je teste avec les sites www.g6ftpserver.com et www.http://ftptest.net/. Voici respectivement les résultats :

    * About to connect() to ftp.xxxx.fr port 21 (#0)
    * Trying 193.252.XXX.XXX... connected
    * Connected to ftp.xxxx.fr (193.252.XXX.XXX) port 21 (#0)
    < 220 Microsoft FTP Service

    > USER xxxxx
    < 331 Password required for xxxxx.

    > PASS *****
    < 530 User xxxxx cannot log in.
    * Access denied: 530
    * Closing connection #0

    curl: (67) Access denied: 530

    -----------------------------------------------------------------------------------------------------

    Status: Resolving address of ftp.xxxx.fr

    Status: Connecting to 193.252.XXX.XXX

    Status: Connected, waiting for welcome message

    Reply: 220 Microsoft FTP Service

    Command: CLNT http://ftptest.net on behalf of 217.128.XX.XXX

    Reply: 500 'CLNT http://ftptest.net on behalf of 217.128.XX.XXX': command not understood

    Command: USER xxxxx

    Reply: 331 Password required for xxxxx.

    Command: PASS *********

    Reply: 530 User xxxxx cannot log in.

    Error: Login refused by server

    Merci par avance pour votre aide.

    Sincères salutations.

    • Modifié Remrem42 mercredi 24 octobre 2012 10:59
    mercredi 24 octobre 2012 10:55
  • Sur ton DC voit tu des erreur de login dans l'eventlog, onglet sécurité ?

    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    mercredi 24 octobre 2012 23:41
  • hrmm, sa doit etre la fatigue, mais un point majeur me dérange, je n'avais pas fait le lien et sa vient de me frapper

    Pourquoi lie tu un ftp externe avec ton AD ?

    - Tu est en train de me dire que je pourrait faire un bruteforce pour avoir ton mot de passe admin de ton domaine ? (Car par default le compte admin ne ce barre pas).

    - A tu mis du SSL ??? capter des mot de passs en clear texte est pas super.

    - Cela veut dire aussi que ton serveur parle a  tout les port entre la DMZ et le LAN


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    jeudi 25 octobre 2012 00:53
  • Bonjour Yagmoth555,

    Merci pour vos réponses.

    En fait je n'avais pas exigé l'authentification SSL car je pensais la configurée une fois la connection possible et que tous fonctionne. Afin de réduire le champ d'erreurs. Peut-être est-ce une mauvaise idée ?

    Je m'excuse pour mon amateurisme mais je débute sur la gestion de réseau.

    En ce qui concerne les ports et la prise en charge du pare-feu. Je ne sais pas quelle plage de ports est nécessaire. De plus à quoi correspond l'ip externe du pare-feu ? Est-ce l'ip Wan ?

    Que me conseillez-vous alors ? Comment puis-je créer d'autres utilisateurs que ceux de l'AD afin de leurs rendre possible l'accès distant au FTP ?

    Encore merci.

    Bonne journée...

    :-)

    jeudi 25 octobre 2012 07:29
  • Allo Remrem42, pas de probleme!, et coté sécurité l'impact est dure a voir des fois.

    Pour l'IP externe je voulais dire l'IP du WAN.

    En tant normal, et d'autre pourront me corriger, je mets toujours mon serveur FTP dans un workgroup, et je l'isole dans un vlan/dmz a part. Comme cela si le serveur ce fait attaquer, il ne risque pas d'infecter ton réseau.

    A partir de la, s'il est dans une DMZ, toi tu peut de l'interne copier les fichiers dessus, et tu crée les usager a la mains dessus pour l'utilisation.

    Sinon, je conseil un routeur ou un serveur qui te permet du vpn. Comme cela ton usager est authentifier a l'interne, et apres il ouvre les fichier de ton serveur/serveur ftp. Donc tu n'ouvre jamais ton serveur ftp interne a l'externe directement de cette maniere.

    C'est sure que rien ne t'empeche de publier ton ftp lier a ton AD non plus, mais j'aimais mieux te prévenir quand même ! Si tu aime mieux continuer dans ce sens, je vais regarder si je trouve d'autre piste pour ton probleme d'origine.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    jeudi 25 octobre 2012 12:24
  • Merci de nouveau.

    Lorsque j'exige la connection SSL. Je ne parviens pas à me connecter en local.

    Je vais essayer de faire les choses bien et de configurer selon vos préconisations.

    Cependant je ne sais comment créer une DMZ. Malgré des recherches dans l'aide de windows server. Après quelques recherches web, j'ai vu qu'il s'agit en fait de créer un autre réseau différent du domaine derrière le pare-feu.

    Mais j'ai du mal à trouver plus d'infos.

    Sincère salutations.

    jeudi 25 octobre 2012 14:03
  • Je ne veut pas chambouler ton setup non plus.

    La avant de continuer, j'ai d'autres questions, donc je ne sais pas si ici c'est la meilleur place pour cela (marque de routeur, etc..). Envoi moi un email (supprimé par l'administrateur) svp, et je continurait par email pour re-finir ici par après.

    Sinon pour le probleme de base; regarde cet article http://www.iislogs.com/articles/adftparticle/ il parlent du setup ftp de a à z.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/



    jeudi 25 octobre 2012 20:16
  • Bonjour,

    De notre part, il n’y a aucun souci si vous discutez ici sur le forum, mais au contraire, il sera mieux afin que d’autres personnes puissent poursuivre l’évolution de la discussion.

    En suivant l’étiquette du forum, j’ai supprimé l’adresse d’email : ''Ne communiquez jamais vos mots de passe ou votre numéro de carte bancaire dans vos échanges ou toute information sensible  (journaux d'évènements complets et/ou configuration détaillée de vos systèmes, etc.) qui serait susceptible d'être utilisée par un utilisateur malveillant.''

    Quand meme, vous pourriez  m’envoyer un courriel si vous voulez le faire d’une manière différente.  

    Merci d'avance pour votre compréhension et collaboration.

    Cordialement,

    Dan


    Dan BAJENARU, MSFT    Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.


    vendredi 26 octobre 2012 07:32
  • Bonjour Yagmoth555,

    J'ai regarder le lien. Je vais essayer de faire quelque réglages sur mon FTP. Si non je vais essayer de reprendre depuis le départ...

    Je vous tiens au courant dès lundi.

    Bon week-end...

    vendredi 26 octobre 2012 19:04
  • Suivant le conseil a Dan, je vais continuer ici alors :)

     

    Si cela ne marche ce weekend, répond ici la marque de ton routeur et qu'est-ce que ton adresse interne a l'air. Je vais vérifier si tu peut pour la dmz. Des routeur de base on une option DMZ, mais une vrai DMZ ce situe dans un port optionel de ton routeur dans un autre adressage en tant normal.

    Avec la marque/model je vais pouvoir te donner des faq de configuration.

    A tu beaucoups d'usager qui ce connecte de l'externe ?


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    samedi 27 octobre 2012 01:50
  • Bonjour Yagmoth555,

    Je viens de reprendre l'intégralité du tutoriel, cela ne fonctionne toujours pas. Les tests de connexion donnent le même résultat. A la fin de ce dernier, dans le trouble shooting le test de vérification est réalisé en local car il utilise son ip locale. Cela fonctionne chez moi.

    Mon adresse ip est de type 192.168.0.XX.

    En ce qui concerne le nombre d'utilisateur externe, je pense à un ou deux. Au maximum 5.

    Merci par avance.

    Sincères salutations.

    lundi 29 octobre 2012 12:42
  • Avant de continuer;

    Check ce KB: http://support.microsoft.com/kb/200475

    Error message in IIS: "530 User <Username> cannot log in. Login failed."


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    lundi 29 octobre 2012 14:28
  • Bonjour Yagmoth555,

    Tout d'abord désolé pour cette période de silence mais je ne pouvais pas me consacrer efficacement à essayer ce KB.

    Je viens de le faire et voici les résultats :

    • Résolution N°1 : Pas nécessaire puisque déjà désactivé.
    • Résolution N°2 :

              - Dans les paramètres de sécurité de la console MMC, Ouvrir une session localement n'est pas disponible.

              - Interdire d'ouvrir une session localement est cependant disponible avec un utilisateur "support" de renseigner par défaut.

    • Résolution N°3 : J'ai rajouter mon utilisateur dans accéder à cet ordinateur depuis le réseau.
    • Résolution N°4 : Spécifié le domaine ne change rien.

    Au final :

    Lorsque je me connecte en local cela ne fonctionne plus et le message 530 Valid hostname is expected apparait.

    En externe toujours 530 User xxxxx cannot log in.

    Sincère salutations.


    • Modifié Remrem42 mardi 6 novembre 2012 16:46
    mardi 6 novembre 2012 16:44
  • Commencon par regler le nouveau trouble. Le binding de ton ftp n'est plus ok.

    Regarde cela; http://www.iis.net/learn/publish/using-the-ftp-service/using-ftp-virtual-host-names-in-iis-7

    Essai d'y accéder par l'IP directement aussi, si c'est le site ftp par default sa devrait ouvrir.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    mardi 6 novembre 2012 19:25
  • Bonjour Yagmoth55,

    Je viens de vérifier le fichier host comme décrit et la syntaxe correspond à ce qui est décrit dans le tutoriel.

    J'ai essayer de désactivé le parefeu, si je me connecte avec l'adresse ftp.xxxxx.fr alors : 530 User xxxxx cannot log in. Et avec l'ip locale : 530 Valid hostname is expected

    Merci encore, bonne journée...

    mercredi 7 novembre 2012 08:02
  • J'aurais tendance a refaire de A à Z ton ftp. Est-il en production en ce moment ?

    Si non, reset par default ton ftp et donne lui aucun host.

    Mon but était au depart d'ajouter le groupe anonymous et de l'externe de voir si cela ce connecte quand meme. Cela aurait isoler ta méthode d'authentification qui serait coupable pour le 530.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    samedi 10 novembre 2012 05:29
  • Salut Yagmoth555,

    J'ai supprimer mon serveur FTP !

    J'ai ensuite suivi le tutoriel indiqué dans votre message du 25/10.

    Le serveur fonctionne très bien en local sans l'isolation des utilisateurs et le chiffrage SSL des connexions. Ceci en utilisant l'ip ou l'adresse ftp...

    En externe toujours 530 User xxxxx cannot log in !

    J'ai ainsi permit l'authentification anonyme. Elle fonctionne en local cependant en externe avec ftptest.net cela donne :

    Status: Resolving address of ftp.xxxxx.fr

    Status: Connecting to xxx.xxx.xxx.xxx

    Status: Connected, waiting for welcome message

    Reply: 220 Microsoft FTP Service

    Command: CLNT http://ftptest.net on behalf of xxx.xxx.xxx.xxx

    Reply: 500 'CLNT http://ftptest.net on behalf of xxx.xxx.xxx.xxx ': command not understood

    Command: USER anonymous

    Reply: 331 Password required for anonymous.

    Command: PASS ************************

    Reply: 530 User anonymous cannot log in.

    Error: Login refused by server

    Sincères salutations...

    lundi 12 novembre 2012 13:02
  • Avec tout ce qu'ont a fait je commence a etre en manque d'idée. Comprend-tu l'anglais ? Il aurait les forum sur iis.net, des MVP d'IIS et des personnes meilleur que moi qui ce tienne sur ce forum serait peut-etre mieux placer pour aider.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    vendredi 16 novembre 2012 03:34
  • Bonjour Yagmoth555,

    Merci encore pour ton aide. Pour l'anglais cela devrait le faire...

    A plus.

    vendredi 16 novembre 2012 05:56