locked
Ajout de fonctionnalités impossible sous Windows 7 Pro [Résolu] RRS feed

  • Question

  • Bonjour,

    L'ajout d'une nouvelle fonctionnalité échoue systématiquement avec le message :

    Une erreur s'est produite. Certaines fonctionnalités n'ont pas été modifées correctement.

    Cela concerne tous les composants que j'ai essayé d'installer (IIS, client telnet, les jeux...)
    Cela génère systématiquement des événements CbsPackageServicingFailure2 et WindowsWcpOtherFailure3.
    La commande
    fsutil resource setautoreset  true  C:\ ne corrige pas le problème (après reboot).
    C:\Windows\Logs\CBS\CBS.log remonte pas mal d'erreurs. Un extrait est disponible en http://d3dal3.blogspot.com/2010/07/unable-to-add-new-components-in-windows.html.
    Ma meilleure piste actuellement est que windows recherche des packages en allemand (culture de-DE) alors que mon portable est configuré en français.
    L''outil d'analyse de l'installation conforme des mises à jour du système (http://support.microsoft.com/kb/947821) ne trouve aucun problème après 25 min d'analyse.

    Merci d'avance pour votre aide

    ded'

    • Modifié Vianney lundi 26 juillet 2010 12:15 in French
    samedi 24 juillet 2010 22:42

Réponses

  • Bonjour Vianney,

     

    • Vianney à écrit : Problème résolu en installant le pack MUI allemand avec vistalizator.

     

    Même si ce n'est pas une procédure préconisée par Microsoft, on n'est content que ton problème soit solutionné.

     

    Merci pour le retour et bonne continuation sur Windows 7,

     

    @+


    Cordialement, chantal11 - MVP - Blog Windows 7 / Windows Vista
    • Marqué comme réponse chantal11MVP lundi 26 juillet 2010 12:31
    lundi 26 juillet 2010 12:28

Toutes les réponses

  • Précisions : l'installation d'une fonctionnalité recherche les fichiers du MUI (Multiple User Interface) Language Pack en allemand qui n'est pas installé sur mon portable (je n'ai pas de DVD d'installation).

    Est-il possible de faire oublier à Windows 7 ce language pack sans tout réinstaller ?

    A défaut, puis-je réinstaller le language pack allemand ?
    -> C'était possible sur la RTM d'après mydigitallife.
    -> Je n'ai que Windows 7 Pro qui ne permet pas a priori l'ajout de language packs (il faut l'édition Ultimate).

    • Modifié Vianney lundi 26 juillet 2010 09:34 typo
    lundi 26 juillet 2010 09:31
  • Problème résolu en installant le pack MUI allemand avec vistalizator.
    lundi 26 juillet 2010 12:14
  • Bonjour Vianney,

     

    • Vianney à écrit : Problème résolu en installant le pack MUI allemand avec vistalizator.

     

    Même si ce n'est pas une procédure préconisée par Microsoft, on n'est content que ton problème soit solutionné.

     

    Merci pour le retour et bonne continuation sur Windows 7,

     

    @+


    Cordialement, chantal11 - MVP - Blog Windows 7 / Windows Vista
    • Marqué comme réponse chantal11MVP lundi 26 juillet 2010 12:31
    lundi 26 juillet 2010 12:28