locked
WAMP Serveur ne peut être démarré RRS feed

Réponses

  • Bonjour,

    As tu skype démarré sur ta machine ? Si oui, quitte le et essaye de démarrer WAMP. Tu pourras le relancer ensuite


    Revue du Geek | Astuces pour déployer Windows 7

    lundi 3 juin 2013 16:03
  • Ce problème est à la fois bénin et fréquent :  la plupart du temps c'est dû à l'utilisation du port 80 par une autre application.

    Donc au choix :

    • on configure Apache sur un autre port qui soit libre ( 81, 8080, ...)
    • on configure l'application concernée de façon à ce qu'elle n'utilise plus le port 80 (souvent Skype se l'accapare par défaut)

    Depuis l'icône dans "le systray" de WAMP, un clic gauche ouvre son menu.
    Cliquer sur "Apache" / "Service" / "Tester le Port 80"
    On obtient ceci :
    http://www.bellamyjc.org/captures/test80.jpg
    qui permet de savoir s'il y a ou non un conflit avec le port 80.

    Quant au port d'Apache (80 par défaut), il se modifie dans httpd.conf (menu "Apache" / "httpd.conf")
    Chercher la ligne qui commence par  "Listen ....."
    P.ex.
      Listen localhost:80

    La remplacer (éventuellement) par (ce sont des exemples) :
      Listen localhost:8080
    ou
      Listen 192.168.0.20:81
      ...



    En ce qui concerne Skype, tout se joue ici :

      "Options" / "Avancées" / "Connexion"

    Par défaut, la case "Utiliser les ports 80 et 443 comme alternative" est cochée, ce qui signifie que si le port prévu au départ (47526 dans mon exemple) ne répond pas, Skype va basculer sur le port 80 et donc l'accaparer, à l'insu de l'utilisateur.

    Donc si on ne veut pas de conflit, il vaut mieux DÉCOCHER cette case.

    http://www.bellamyjc.org/captures/connexionSkype.jpg

    lundi 3 juin 2013 18:56

Toutes les réponses