none
Fuite mémoire RRS feed

  • Question

  • Bonjour,

    Depuis un certain temps, j'ai une fuite mémoire sur tous mes sites SharePoint 2010, existe-il un correctif?

    Pour information mon serveur est en mode standalone.

    Merci par avance pour votre aide

    mercredi 4 novembre 2015 12:49

Toutes les réponses

  • Bonjour,

    Tu peux nous en dire plus sur cette "fuite mémoire" (memory leak) ?

    • Tu as déterminé de quel code venait ce memory leak ?
    • As tu cherché au niveau du code ?
    • Y a t il déjà du code déployé sur ta ferme pour être responsable de cela ?
    • Sur quel version CU es tu ? 

    Pour moi , le correctif passe déjà par se poser ce genre de question.

    Maintenant si tu veux une solution "temporaire", tu dois recycler les pools d'applications réguliérement (au niveau IIS) pour revenir à un état plus normal sauf que cela aura des conséquences sur ton service : sur l'expérience utilisateur, légère baisse de performance et possibilité de perdre des données (selon les activités des end-users).

    Cela est à mon sens un bon compromis jusqu'à que tu trouves les réponses à tes questions.

    Bon courage


    Mutandis mutatis

    mercredi 11 novembre 2015 08:12
  • Bonjour,

    La fuite impacte tous les sites SharePoint (du standard , pas de code spécifique) --> détectée via les outils de supervision. Je suis sur la version 2010 entreprise

    Le service en question est w3wp.exe.

    Pour le recyclage de pool, c'est ce que je fais, mais ce n'est pas une solution dans le temps vu les conséquences évoquées.

    Sur la ferme, au niveau des correctifs, je suis au service pack 1, j'ai vu qu'il y avait le pack 2, mais Est-ce que ça va résoudre mon problème?

    J'ai trouvé l'outils debugDiag, Est-ce qu'il peut servir? si oui, comment le paramétrer?

    Merci par avance pour votre aide.

    lundi 16 novembre 2015 09:23